Hacking Stuck on Atmos 0.20.1. Cant update further (fatal error).

Rewinding

Member
OP
Newcomer
Joined
Sep 5, 2021
Messages
14
Trophies
0
Age
32
XP
51
Country
United States
I was able to update my Switch to FW 12.1.0 and Atmos to 0.19.5 last year. So far so good.

Today I wanted to update both FW and Atmos to the latest versions. I started with Atmos, but I decided to upgrade to 0.20.1. I did a drag and drop, both fusee bin and secondary were updated. I removed the SD from PC and plug it back in, before I boot up the Switch I insert the RCM loader dongle. I get greated with a black screen (Fatal Error, Press power button to reboot) , I press the power buttton and the Switch proceeds to the Atmos logo and then home screen (everything works fine).

Since everything has been somewhat good so far (minus black screen). I decide to upgrade again to Atmos 1.0.0. Took me a year to try 1.0.0 because I was confused regarding the change from fusee.primary to fusee.bin and fusee.secondary to package3. Do I remove fusee.primary and fusee.seconday and replace them with the new versions or keep all 4 in their correct locations?

Today, I decided to remove fusee.primary and fusee.secondary and added fusee.bin and package3 in their correct places (as well as drag/drop new 1.0.0 files). When I started the Switch I got the same fatal error, but this time it said it could not start without fusee.primary/secondary. I go back to my PC and re add fusee.primary/secondary along with fusee.bin/package3. I boot up Switch, I get the black screen again (from second paragraph), I press the power button and then I see the Atmos logo and it seems its going to start but I get (a fatal error has occurred abort called 0xffe) and can't proceed. I remove the new 1.0.0 files (along with fusee.bin/package3) from the SD card and replace them back with 0.20.1. (Backup) The Switch is now functioning normally again, but now I'm stuck with Atmos 0.20.1.

I dont know what I'm doing wrong, If I cant update to 1.0.0 then theres no way I can update to current version.
Sigpatches are not lastest, they are from when FW 12.1.0 and 0.19.5 were released ( 1-2 years ago?). (I do this for record keeping purposes).

Is my error because I need to update sig patches? Maybe I need to update the RCM loader? Is Atmos 1.0.0 not compatible with my FW? Is it something else? Please help, thx.
 
Last edited by Rewinding,
  • Angry
Reactions: LeyendaV

Ferris1000

Well-Known Member
Member
Joined
Mar 10, 2017
Messages
184
Trophies
0
Age
31
XP
1,684
Country
Germany
Delete everything except the Nintendo Switch folder and copy all Atmosphere files (a fresh Copy) to your SD Card and try to boot again.

If it still doesn't work check if your SD Card is formated to FAT32 if it's exFat then format to FAT32 before you copy the files to your SD Card.

Since a specific version of Atmosphere exFAT doesn't work and corrupt your entire Filesystem on your SD Card.
 

LeyendaV

The One and Only
Member
Joined
Jun 5, 2020
Messages
744
Trophies
1
Age
31
Website
heylink.me
XP
1,629
Country
Argentina
It's most likely that a homebrew you have in your SD is not compatible. Unless you show us the error, or at least give us a detailed explanation about it, you are gonna have to do your research and find the problem, or wipe the SD and make a clean installation.
 

Rewinding

Member
OP
Newcomer
Joined
Sep 5, 2021
Messages
14
Trophies
0
Age
32
XP
51
Country
United States
Delete everything except the Nintendo Switch folder and copy all Atmosphere files (a fresh Copy) to your SD Card and try to boot again.

If it still doesn't work check if your SD Card is formated to FAT32 if it's exFat then format to FAT32 before you copy the files to your SD Card.

Since a specific version of Atmosphere exFAT doesn't work and corrupt your entire Filesystem on your SD Card.
I will try this. Question on Atmos 1.0.0, should I keep fusee.primary and secondary? Or switch them over to fusee.bin/package3? Not sure if fusee.primary/secpndary are supposed to be deleted.
did you have themes installed?
No themes.
It's most likely that a homebrew you have in your SD is not compatible. Unless you show us the error, or at least give us a detailed explanation about it, you are gonna have to do your research and find the problem, or wipe the SD and make a clean installation.
The error report was saved to the SD card. I will take a pic, or uploaded it on here.
 

kidkat210

Well-Known Member
Member
Joined
Nov 9, 2016
Messages
741
Trophies
0
Age
27
XP
1,508
Country
United States
With atmosphere 1.x.x, fusee-primary and fusee-secondary no longer work. Your problem is probably a clash of files due to merging/overwrite of previous updates.
 

mrdude

Well-Known Member
Member
Joined
Dec 11, 2015
Messages
1,540
Trophies
1
Age
54
XP
4,275
Country
Remove Atmosphere folder from your memory card completey, you will have a module or theme or patch installed that is not compatible with your current firmware or the newest Atmosphere. A clean reinstall of Atmosphere is always recommended when doing an update and solves any issues pretty much 100% of the time. Remember and update your sig patches and hekate version as well if you are running those.
 
General chit-chat
Help Users
    KenniesNewName @ KenniesNewName: Kathy Ireland Sheet Sets w/ Side Pocket - $20.99 - Free shipping for Prime members...