Strange brick, no SYSCONF?

Discussion in 'Wii - Hacking' started by KirovAir, May 15, 2009.

May 15, 2009

Strange brick, no SYSCONF? by KirovAir at 9:40 AM (1,738 Views / 0 Likes) 4 replies

  1. KirovAir
    OP

    Member KirovAir Dutch Alcoholic Programmer

    Joined:
    Dec 7, 2006
    Messages:
    587
    Location:
    Netherlands
    Country:
    Netherlands
    Well, I recently fully bricked my wii. I removed the system menu through a wad. (See: http://gbatemp.net/index.php?showtopic=154886)
    But, I had BootMii installed so I was able to reinstall the system menu wad by recompiling wad manager to use a GC controller instead of the wiimote.

    However, I still cannot boot the system menu. Probably because all system settings are deleted. When I open anyregion changer, it gives a -106 error at SYSCONF_Init();

    So, is there any way to re-create this/these files?
    Or, could someone explain me how to add tona's patches to libogc, so I can recompile anyregion changer to (maybe) fix these settings for me?

    - I can still acces the HBC.
    - My Wiimotes do NOT work with homebrew.
    - My Wiimotes DO work with games.
    - I can still boot games. [​IMG]
    - I don't have a good NAND dump.

    Any help is greatly appreciated.
     
  2. piratesmack

    Member piratesmack GBAtemp Advanced Fan

    Joined:
    Mar 28, 2009
    Messages:
    787
    Location:
    $(pwd)
    Country:
    United States
    Damn that sucks
    Well I have no idea if this can be used to help you, but I dumped my Wii's SYSCONF:
    http://www.mediafire.com/?9bnq3oufn92

    My Wii is NTSC-U with System Menu 4.0, if that matters
     
  3. KirovAir
    OP

    Member KirovAir Dutch Alcoholic Programmer

    Joined:
    Dec 7, 2006
    Messages:
    587
    Location:
    Netherlands
    Country:
    Netherlands
    Thanks, might be able to just dump that one on my Wii. [​IMG]
    But, I need to be able to edit anyregion changer's source code. Which requires a modified libOGC (tona's patches). And I don't know how to apply them. [​IMG]
    Also, I don't know if the encryption is made with a key inside the sysmenu, if so I hope I did not delete that key. Otherwise, I'm quite screwed.
     
  4. WiiBlaster

    Member WiiBlaster GBAtemp Maniac

    Joined:
    Nov 23, 2008
    Messages:
    1,189
    Country:
    United States
    Well hopefully you can get it fix, Maybe going on efnet #wiidev might find some good help there
     
  5. KirovAir
    OP

    Member KirovAir Dutch Alcoholic Programmer

    Joined:
    Dec 7, 2006
    Messages:
    587
    Location:
    Netherlands
    Country:
    Netherlands
    Now, I installed a 3.3 system menu by editing waninkoko's downgrader, but, I get an error: "Could not retrieve current region code". Again, this points to corrupt SYSCONF/settings.txt files. So I started editing anyregion changer. I'm still editing it right now. But I get loads of errors when (re)writing the file, even if I ignore the read errors. [​IMG]

    So, I need some serious help since I'm not a good programmer, and I don't know alot of the system menu structure.
    I'll keep trying. Any hints/tips/help is still greatly appreciated.

    Thanks. I'll have a look on it. [​IMG]
     

Share This Page