Still stay on lowest firmware

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by jonesy101, Apr 24, 2018.

  1. jonesy101
    OP

    jonesy101 Member

    Newcomer
    1
    Apr 2, 2018
    United States
    Dumb question...

    With all the exploit releases coming out the past couple of days, does staying on the lowest firmware still apply?

    I wonder if more permanent (untethered) solutions will come first to older firmwares.
     
  2. RySe96

    RySe96 Member

    Newcomer
    1
    Mar 28, 2018
    United States
    Yes! This will always be the case. If you're on a low enough firmware you might not even have to short the pins. Maybe lower firmware will have an untethered hack sooner than later firmware versions. If your interest is in the hacking scene it's always best to stay on the lowest firmware.
     
    Last edited by RySe96, Apr 24, 2018
    leafeon34 and Rauliki like this.
  3. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    9
    Jun 28, 2014
    United States
    Arizona Bay
    Just wait. Unless your a dev this really means nothing for the end user. Best to wait and weigh out your options
     
    Quantumcat, PacPera and peteruk like this.
  4. yardie

    yardie Banned

    Banned
    8
    Mar 27, 2016
    United States
    None of these things are ready for end users yet
    Gotta wait for a bit.
     
  5. MrCokeacola

    MrCokeacola GBAtemp Fan

    Member
    5
    Feb 26, 2018
    Canada
    Depends how thirsty you are to play online and play the newest games.
     
  6. Loke

    Loke GBAtemp Fan

    Member
    5
    Jan 7, 2014
    Netherlands
    The hype is real.

    There's still no difference with a 3.0.0 console though. Except 3.0.0 can launch hbl. This is great for developers as a lot of them don't have a 3.0.0 switch.
     
  7. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    9
    Jun 28, 2014
    United States
    Arizona Bay
    I'm still holding onto the fact that 1.0 might be the holly grail and won't upgrade until cfw is released. This really should be applied to any firmware at this point.

    Yes it looks like every switch on the market can be hacked but the qustion is how easily and would have it been worth it to wait
     
    charlieb and AzizR like this.
  8. kumikochan

    kumikochan GBAtemp Psycho!

    Member
    11
    Feb 4, 2015
    Belgium
    Tongeren
    You don't need to bend the pins on 3.0. you can launch every other exploit through the webkit exploit
     
  9. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    15
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 23, 2012
    United States
    Octo Canyon
    I'll buy an extra right joycon if I have to, but I'm gonna wait and see what turns up from all this. Linux on my Switch is cool and all, but only if it's easy to do. Once some guides pop up, and things get refined for the end-user, then I'll dive in.
     
    konamicode89 likes this.
  10. smf

    smf GBAtemp Psycho!

    Member
    9
    Feb 23, 2009
    United Kingdom
    If you could sell the 1.0 switch and can get enough money to buy a new switch, a mariko switch and the fusee gelee dongle and still be left with money spare then I would do it.

    Having a launch mariko ready for when an exploit comes out will be good because it's got faster ram and gpu....

    It might even be that certain firmwares get it and others don't.
     
    Last edited by smf, Apr 24, 2018
  11. LikeATrollFace

    LikeATrollFace Advanced Member

    Newcomer
    2
    Apr 24, 2018
    Netherlands
    I'm on 2.0.0, I unfortunately updated on release day.
     
    srDP likes this.
  12. albion

    albion Member

    Newcomer
    2
    Oct 31, 2017
    Switzerland
    I will stay in 1.0.0, the strategy seems very simple, can be updated at any time in new versions, otherwise there is no downgrade.
     
  13. Tumoche

    Tumoche GBAtemp Regular

    Member
    5
    Apr 30, 2017
    Spain
    Im on 4.1.0 should i update to 5.0.2?
     
  14. Biff627

    Biff627 GBAtemp Advanced Maniac

    Member
    9
    Aug 15, 2015
    United States
    Id stay on 4.1.0 tbh. Thats what im doing.

    Edit- Tbh I wish I wouldnt have caved and would have just stayed on 3.0.0. Mario Odyssey made me cave though xD Still looking to find a 3.0.0 or a 1.0.0 switch... Basically impossible now without it being overpriced.
     
    Last edited by Biff627, Apr 24, 2018
  15. Yanda

    Yanda GBAtemp Regular

    Member
    3
    Aug 26, 2015
    I always said that we should stay on lower FW.
    But now it is not.
    There is no reason to stay there if it is 3.0.1 or higher.:D
     
  16. notimp

    notimp GBAtemp Addict

    Member
    10
    Sep 18, 2007
    I'd say lets make this a thread where all the different people always asking these kind of question can talk to each other in circles for as long as they want. :)

    Lets just not give them any answers - for as long as there is nothing to do with that answer. :)

    In the interest of enlightenment. Nothing needs to be bent - if you have another way of shorting two pins at bootup. Like "puting a piece of tinfoil on the tip of your nose, and pressing your nose against them - juuust the right way", or using a dongle, or a screwdriver, just lightly pressing something metal against those pins.

    The instagramm faction currently is very vocal in here - imagining the world one impressive image at a time. They saw bent pins. And by god, that stuck in their heads. Now thats all they can talk about.

    — Posts automatically merged - Please don't double post! —

    Alternatively - lets see how this answer is liked:

    If you see all the talk about pin bending, and having to use dongles, or screwdrivers after every boot - and immediatly think "thats something - I would like to do thousands of times" in the following years - then perhaps immediately updating might seem like the way to go for you.

    If it sounds "somewhat bothersome" to you - wait for more information on better/easier methods. (If they become available might still depend on your firmware (- or on what a modchip does, once information about them gets released))

    And dont always ask how this "effects you on your firmware" - take the available information, make sense of it on your own. A forum is not a "thinking service" for everyone that just asks.

    "I have a 72% neediness to play the current "whatever" - online, how does this go together with the 20% likelyhood of me seeing a better way to get "something unspecified" on exactly 4.2.0?"

    "I have a 64% neediness to play the current "whatever" - online, how does this go together with the 5% likelyhood of me seeing a better way to get "something unspecified" on exactly 5.0.0?"

    If you think that other people will answer that question for you - eh.. Maybe not...

    Also - yes, we think that you are pretty much dumb.. (This was added after this posting already received one like. :) )

    "Lower is better" is the statement that makes the percentage depicted above in BOLD rise. By an unspecified amount. Apart from that it doesn't do much. If you are on 1.0.0 - there still might be a chance, that you are getting "the holy grail" of software exploits ("press A and it just works") - thats still not there yet. If you are on 3.0.0 you have little need to update from a homebrew perspective - currently. If you are above that, you are betting against unknown odds of stuff being discovered and implemented.

    For your next betting tips, please consult a friend - or that random guy on the internet, that always tells you which cryptocurrencies you should invest in. I think his name is Pete and hes in advertising.
     
    Last edited by notimp, Apr 24, 2018
    geek_76 likes this.
  17. LikeATrollFace

    LikeATrollFace Advanced Member

    Newcomer
    2
    Apr 24, 2018
    Netherlands
    Is 2.0.0 better than 3.0.0 in any way at all(exploit wise)?
     
Quick Reply
Draft saved Draft deleted
Loading...