Stay on 3.2 or not to stay

Discussion in 'Wii - Hacking' started by only1blitz, Apr 16, 2010.

  1. only1blitz
    OP

    only1blitz Newbie

    Newcomer
    7
    0
    Apr 16, 2010
    United States
    Hi guys

    Started getting rid of the dust off my wii after a year mainly because of the the new monster hunter game which I've preordered =). My wii is softmodded up to 3.2e with starfall and backup launcher using this guide http://gbatemp.net/index.php?showtopic=118446. Do i need to update to 4.2 or can I leave it as it is to play the current new games?
     
  2. tj_cool

    tj_cool Site dev

    Supervisor
    9,989
    -1
    Jan 7, 2009
    Belgium
    This planet
    Don't fix what ain't broken [​IMG]

    Although I'd update your loader to the newest NeoGamma (R9 Beta6)
     
  3. only1blitz
    OP

    only1blitz Newbie

    Newcomer
    7
    0
    Apr 16, 2010
    United States
    Cool thanks. I'll have a look for neogamma then =) Just worrying a bit about the new updates from the the latest games. I randomly read that they delete the home channel or even brick wiis on lower than the 4.2 version. Kinda behind in the latest development of updates/issues and wondering for what reason everyone is trying to update to the latest firmware if 3.2 still works fine
     
  4. Krestent

    Krestent What to post?

    Member
    3,953
    33
    Mar 31, 2009
    United States
    And also your cIOS to rev17
     
  5. VashTS

    VashTS Beat it, son

    Member
    3,896
    698
    Mar 14, 2009
    United States
    Upstate NY
    only update if you want the sd channel but with triiforce its not even necessary.

    don't go to 4.2 go to 4.1...less region restrictions.

    sd channel is the only real benefit.
     
  6. vegemikee

    vegemikee GBAtemp Fan

    Member
    356
    6
    Aug 17, 2008
    id update to 4.1; im not forcing you, of course but its what id recommend. 4.1 has a fix for wii sports resort and sd card channel. and there actually arent any region restrictions. thats on 4.2
     
  7. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1,481
    1
    Apr 30, 2008
    United States
    I agree. There's absolutely no reason to stay on 3.2 anymore. It's easy enough to update without losing any of your hacks, too.
     
  8. tj_cool

    tj_cool Site dev

    Supervisor
    9,989
    -1
    Jan 7, 2009
    Belgium
    This planet
    The "fix for WSR" isn't needed on 3.2 since its not broken there (it's only broken on 4.0)
    And region free can be restored on 4.2 with Priiloader which should be installed anyway...
     
  9. only1blitz
    OP

    only1blitz Newbie

    Newcomer
    7
    0
    Apr 16, 2010
    United States
    Thanks everyone =) Decided to update to 4.1e. Does anyone know of a good guide that they recommend or are all of them good? Just worried about bricking my wii
     
  10. bula

    bula GBAtemp Advanced Fan

    Member
    814
    0
    Feb 4, 2009
    United States
    Install IOS60-v6174 and then SM4.1E-v450, done. BTW you can use DOP-Mii to do this upgrade or you can download them with NUS, pack them as wads and install them with WADmanager.
     
  11. vegemikee

    vegemikee GBAtemp Fan

    Member
    356
    6
    Aug 17, 2008
    or follow zxzeros complete softmod guide. complete with all recommended IOS' for updating
     
  12. only1blitz
    OP

    only1blitz Newbie

    Newcomer
    7
    0
    Apr 16, 2010
    United States
    I had a look at the zxzero softmod guide but found this one (link at bottom) which for some reason seems easier for me to follow. Seeing as the link is a bit old, is it still ok and safe following it? Also, will it have the same effect as the zxzero one?

    http://www.wiihacks.com/recommended-faqs-g...od-any-wii.html