Starcraft lags at University!! plz help!

Discussion in 'Computer Games and General Discussion' started by da_head, Sep 29, 2008.

Sep 29, 2008
  1. da_head
    OP

    Member da_head A dying dream..

    Joined:
    Apr 7, 2008
    Messages:
    2,953
    Location:
    Toronto, Canader!
    Country:
    Canada
    k guys, i've given up on playin sc at home (due to fuckin modem issues), so i'm only able to play it at school. a few weeks ago, it was playin perfectly, but as the weeks progressed on, i started laggin more and more. today, it took a good minute to log on b.net, and i was full red bars (worst lag u can get). i'm 99.9% i don't have any viruses, and everything thing else seems to be running fine. any ideas? is the university blocking those specific ports somehow? or has the uni internet simply gotten worse?
     
  2. Ferrariman

    Member Ferrariman Hip-Flop and cRap

    Joined:
    Dec 9, 2007
    Messages:
    3,357
    Location:
    Canader.
    Country:
    Canada
    Defrag drive/ registry, try running at on high priority, don't download anything, blah blah blah




    I have no idea.
     
  3. Law

    Member Law rip ninjacat that zarcon made me

    Joined:
    Aug 14, 2007
    Messages:
    4,132
    Location:
    ‭jerkland
    Country:
    United Kingdom
    Probably trying to block it.

    Either that or somebody is using the university's internet for some hardcore torrenting.
     
  4. da_head
    OP

    Member da_head A dying dream..

    Joined:
    Apr 7, 2008
    Messages:
    2,953
    Location:
    Toronto, Canader!
    Country:
    Canada
    i have nothing open while i'm scing. i defrag regularly, registry is also good (i use cc cleaner). and i use avg, malwarebytes anti-malware, and my single player games r running smoothly. therefore, its either an internet issue, or mebe my laptop wireless card is fucked up...

    btw back when it was working fine, i would have msn and bittorrent open with no slow downs...
     

Share This Page