SSB4 does not recognize update data on CakeFW1.7, emuNAND 10.5, o3DS EU

Discussion in '3DS - Flashcards & Custom Firmwares' started by FySkire, Feb 11, 2016.

  1. FySkire
    OP

    FySkire Member

    Newcomer
    13
    1
    Jun 6, 2015
    Gambia, The
    So, I've got a weird problem and can't find anything on google. Maybe somebody here knows what to do?

    I installed an emunand on an european o3ds using CakesFW 1.7, emunand is on 10.5 using a 4GB large SD. About 900mb are taken through the emunand partition. I followed wurstpistoles guide and had in mind that I used an o3DS.

    Installing cias like the HomebrewLauncher worked flawlessly.

    The problem is, that my SSB4 cadrige does not recognize the 1.1.4 update, which I downloaded through the e-shop, like I would do on a normal system.

    It started after setting up the emunand. When I started the game, it appeared an error claiming, that the save data needs a newer version of the game. So, I downloaded the update.
    Still the same error. The only possibility was to start the game without saving.
    Interesstingly, the home-button lets the system freeze (is that normal on o3ds? On my n3DS it behaves completely normal).

    I did an factory reset of the cadrige using savedatafiler, which allows me to play normaly on 1.0.1, which is the version of the cadrige, I guess..

    But obviously this cannot be the solution as it is very unsatisfying and blocks me from playing with friends.

    I deleted every SSB4 data I could find and redownloaded the Update 3 times, without success.

    Does anybody here know how to fix it?
     
  2. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,002
    1,054
    Jun 28, 2014
    United States
    Arizona Bay
    Try a larger SD card.

    Emu + Cia + update on a 4gb will give you a memory error
     
    Last edited by Ronhero, Feb 11, 2016
  3. FySkire
    OP

    FySkire Member

    Newcomer
    13
    1
    Jun 6, 2015
    Gambia, The
    Thank you for your fast answer. I will give it a try as soon as my new SD arrives, as I already ordered one. Indeed, 4GB is uncomfortably small as I cannot even do an EmuNand Backup...

    I didn't think of this, as I thought 600mb free space would be enough...

    Edit: Migrated to a 8GB SD, redownloaded, it still does not work.
    Deleted the dbs data completely and am redownloading the update. Fingers crossed.
    If somebody has an idea, please comment.

    The last options I see is to try RXTools or installing my NAND backup to the Sysnand and creating a new EmuNand.
    Is using the NAND backup that easy or do I have to pay attention to some steps?

    Edit2: Downloaded, does not work again... I'm going to try RXTool now.

    Edit3: Set up rxTools, works perfectly. Info to myself, recreating the dbs folder deletes FBI, too... Guess I'm going to create a new emuNAND from my NAND backup...

    Edit4: In case somebody had similiar problems: No need to work with the NAND backup. Just make an backup of your sd after making the NAND backup. If you rebuild your db and "lost" everything, you can just copy&paste your sd backup back onto the sd and FBI is back.
     
    Last edited by FySkire, Feb 11, 2016