SOS - Original Copy of Goldene Eye not working modded Wii!

Discussion in 'Wii - Hacking' started by diuqil, Nov 6, 2010.

  1. diuqil
    OP

    Newcomer diuqil Member

    Joined:
    Nov 28, 2006
    Messages:
    10
    Country:
    Canada
    I'm freaking out right now, hopefully somebody can lend me a hand!

    I just purchased a new copy of Golden eye.

    I also updated my Wiikey to 1.99b. My Wii firmware is still probably 4.0 and lower.

    All my older games (backed-up and original copy) work. I popped in the Golden eye disc and click play and I get a black screen.

    Anybody know why this may be happening? Maybe the disc can detect my mod chip? Maybe my disc is defective?

    Any help would be great!
     
  2. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    You appear to be missing an IOS. If you have the HBC, run the game through Gecko OS.
     
  3. diuqil
    OP

    Newcomer diuqil Member

    Joined:
    Nov 28, 2006
    Messages:
    10
    Country:
    Canada
    I've not touched my Wii in almost 2 years (I cracked it out today). The last time I fiddled with this stuff only involved installing a hard mod and updating the wiikey firmware.

    What is this IOS stuff?

    Shouldn't the game work, since I don't have any homebrew installed?

    Will updating my wii through internet solve my problem?
     
  4. Ron

    Member Ron somehow a weeb now.

    Joined:
    Dec 10, 2009
    Messages:
    2,837
    Location:
    here
    Country:
    Canada
    Well theres your problem! You probably don't have the IOS required to play it. I wouldn't update it online just now, but you could probably get a 4.2 or 4.0 wad from NUSD and install it, then use DOP-MII to install the other IOSes. DO THIS AT YOUR OWN RISK. Updating to 4.3 might disable your modchip, I'm not sure. maybe not. But even still, you will have to reinstall a heckload of things

    BTW, games require IOS to work. Think of IOS as a .NET Framework and the Newer games need that .NET framework to run.
     
  5. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    you have something that's blocking disc updates....like priiloader or startpatch....something....(possible your wiikey is doing it)...

    anyhow, the game is requiring an IOS that is not there (likely because it's been idle for 2 years)...

    i suggest doing a softmod guide to get your IOSes up to date....alot has been added in the past two years....try Modmii or the 'update any wii' guides

    edit: Ron975 beat me to the punch....
     
  6. diuqil
    OP

    Newcomer diuqil Member

    Joined:
    Nov 28, 2006
    Messages:
    10
    Country:
    Canada
    I guess my question is...

    I don't care so much for the ability to do homebrew at the moment. In another thread I asked a question regarding wiikey and was told that 1.99b would be fine with 4.3u (all correct region games will work) but I will lose the ability to do homebrew.

    In my case. If I update through the internet, will the game work right away?

    Edit: Btw, thanks for all the help. I really do appreciate it. [​IMG]
     
  7. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    it will likely work right away yes....but to warn you, i have no hardmod experience....so i cannot guarantee there won't be wiikey conflicts with your other non-original games.... (although Ninty's updates have only been aimed at the softmodders AFAIK)

    but if i were you, i would install the latest HBC first (at the very least)

    either way, you won't lose the ability to homebrew, but it will save a headache later if you were to ever want to get into modding (installing HBC on 4.3 is trickier than whatever you're currently on). once there, it'll stay there; headache avoided....it only takes a minute.
     
  8. smash_brew

    Member smash_brew I may or may not have fallen

    Joined:
    Oct 8, 2008
    Messages:
    708
    Country:
    United States
    you can do an update via the internet and you should be able to play this immediately afterword. this shouldn't effect your chip, and you can still install hbc on 4.3 if you ever feel the need to. the only thinkg to consider is that you won't be able to play out of region games with your chip after the 4.3 update, but there are ways around that.
     
  9. diuqil
    OP

    Newcomer diuqil Member

    Joined:
    Nov 28, 2006
    Messages:
    10
    Country:
    Canada
    I guess I will leave 'update through the internet' as a last resort.

    I think it may be prudent for me to update to 4.2u using the soft mode guide? (This way I will retain my HBC I have yet to install and my ability to play off region games).

    Or will I only have to update IOS?

    (Furthermore, I'm going to assume I can't play Goldeneye online unless I have 4.3u)

    Thanks once again. I'm sure this thread will be invaluable to those have similar problems as me.
     
  10. brausm08

    Member brausm08 GBAtemp Advanced Fan

    Joined:
    Nov 15, 2009
    Messages:
    721
    Location:
    USA - Midwest
    Country:
    United States
    assumption incorrect...you can't play it without the required IOS....

    you can technically stay on whatever your current SM is and just update you IOS'es....

    the whole thing would be much much easier if you follow a guide though....

    Modmii would probably be the easiest....
     
  11. smash_brew

    Member smash_brew I may or may not have fallen

    Joined:
    Oct 8, 2008
    Messages:
    708
    Country:
    United States
    if you already have hbc just use modmii to download ios56 and install with wadmanager. problem solved.
     
  12. Ron

    Member Ron somehow a weeb now.

    Joined:
    Dec 10, 2009
    Messages:
    2,837
    Location:
    here
    Country:
    Canada
    Or you could update. First, Install bootmii boot2 using the HackMii Installer.
    Then create a backup of your NAND.
    When your done, use the HackMii Installer to install HBC
    Then, Download DOP-MII through HBC and download System menu 4.2X
    X= E if you have an european wii, U for an NTSC-U (USA/Canadian/Mexican) wii, J for a Japanese wii and K for a Korean Wii.

    Then you should be able to play
     
  13. diuqil
    OP

    Newcomer diuqil Member

    Joined:
    Nov 28, 2006
    Messages:
    10
    Country:
    Canada
    Because time is of the essence, I decided to jump the gun and just update through the internet.

    Good news. No brick. Golden eye works. All my old back-ups work. I have not tried off-region back-ups yet.
     
  14. smash_brew

    Member smash_brew I may or may not have fallen

    Joined:
    Oct 8, 2008
    Messages:
    708
    Country:
    United States
    I think, although i haven't tried it out being as i don't have a mod chip and i'm still on 3.2, that just changing the region using regionfrii should work for out of region games with 4.3. enjoy goldeneye.
     
  15. Ron

    Member Ron somehow a weeb now.

    Joined:
    Dec 10, 2009
    Messages:
    2,837
    Location:
    here
    Country:
    Canada
    Or just use Gecko?
     

Share This Page