Some how when updating IOS's, IOS36 wasnt patched - need this 4 Ge

Discussion in 'Wii - Hacking' started by alex.ap.pacman, Feb 20, 2012.

  1. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    Does anyone know if its possible to use ModMii to patch up all the IOSs I have? or do I have to do that manually?


    Some how IOS36 isnt patched..

    see syscheck:

    Warning: Spoilers inside!
     
  2. Hielkenator

    Member Hielkenator GBAtemp Psycho!

    Joined:
    Feb 7, 2010
    Messages:
    4,176
    Country:
    Netherlands
    This is rght. Your patched ios36 is installed in slot 236 for you.
    You can use that slot .


    All ios lower than 200 and ending wth a zero, are safety patches.
    Those ios are used for the various system menu's.
    all other offcal ios are kept intact.

    No worries perfect softmod.
     
  3. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    So why can't I get gecko os to load VC channels anymore? It used to have the option but now it doesn't...
     
  4. Elaugaufein

    Member Elaugaufein GBAtemp Regular

    Joined:
    Jan 26, 2010
    Messages:
    180
    Country:
    Australia
    Gecko hasn't been updated in ages, it requires the IOS it loads with (can't remember the number) to be patched with ES Identify IIRC in order to launch Virtual Channels, rather than automatically loading an appropriate IOS. You could theoretically fix this from Gecko's source but I've had a look at it and tried compiling it and it appears that the source provided doesn't work properly when compile. Basically you need to patch the IOS that Gecko uses to run Virtual Channels from Gecko.

    ETA - Just had a look at the Gecko OS site, a newer version of the source has been uploaded, haven't had a chance to check if that compiles and works yet though.

    ETA2- Had a look at it. Still doesn't seem to work, even after updating it to account for the changes to libogc that have happened since it was out. Oh, I had a look, it'd be IOS 249 that would need ES_Identify , though IOS36 would also work. Unfortunately you probably don't want to mess with IOS36 and IOS249 is probably a much newer cIOS without ES_Identify and who knows how that'll interact.
     
  5. alex.ap.pacman
    OP

    Member alex.ap.pacman GBAtemp Regular

    Joined:
    Sep 5, 2010
    Messages:
    133
    Location:
    Seattle, Washington
    Country:
    United States
    Is there another Wiibrew program that will allow me to load up GC Games with Ocarina as well as VC games with Ocarina?
     

Share This Page