Some games shutting of wii when using "Return to menu" option

Discussion in 'Wii - Hacking' started by dragon_slayerxd, Jun 15, 2013.

  1. dragon_slayerxd
    OP

    dragon_slayerxd GBAtemp Regular

    Member
    132
    3
    May 7, 2013
    United States
    Houston, Texas
    I'm using usb loader 3.0 r1215 Ios 249 (rev21008 ) (d2x v8 final base56

    The problem is when I try to go back with PAL games not with ntsc. Anyone know how to make this problem go away, (other than only downloading NTSC games) Also I have a problem with booting Usb loader gx from the wii by installing it with priiloader If I do it it goes black. should I install The forwarder or the channel? Is there a difference?
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    install the forwarder's dol (located in the Wad folder of the all-in-one package) in priiloader's boot menu, and place the r1215 boot.dol on your SD card.

    I don't know about the "return to" problem with out of region games.
    I don't have problem with NTSC games on PAL Wii, but I don't own a NTSC wii to test PAL games. (I won't change my wii's region)
     
  3. dragon_slayerxd
    OP

    dragon_slayerxd GBAtemp Regular

    Member
    132
    3
    May 7, 2013
    United States
    Houston, Texas
    I installed the dol and when I tell priiloader to load the dol it goes blank also I already have thatin my boot .dol

    And really? hmmm I thought there was some settings I needed to mess with to prevent my wii from crashing when I tell it to return to menu in a pal game...
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    I don't know why you still can't boot the loader through priiloader+forwarder.
    it's working for other users, so maybe you did something wrong.

    the loader's dol is in the correct folder ?
    /apps/usbloader_gx/boot.dol

    you can install the loader's dol instead of the forwarder's dol, but you won't have AHB access.

    if you have black screen in both cases, do you have the sound or does it freeze ?
    Maybe it's a video mode problem, hence why you have problem exiting a PAL game too.

    What's your video setting/cable ?
     
  5. dragon_slayerxd
    OP

    dragon_slayerxd GBAtemp Regular

    Member
    132
    3
    May 7, 2013
    United States
    Houston, Texas
    hmmm idk neither I loaded the cfg loader dol and it worked fine I think is my video settings here they are

    Video Patch:Region Patch
    VIDTV PATCH ON
    Sneek Video Patch ON
    Aspect Ration System Default
    Gamelanguage default
    PAtch country strungs ON

    Ocarina Off

    Boot/Standard IOS 249
    Quick Boot ON

    Error 002 fix Anti

    Block IOS Reload Auto

    Return to OFF

    Nand Saves Emulation Off

    Nand Chan Emulation Full

    Hook type None

    Wiird Debugger OFF

    Debugger Paused Start OFF

    Channel Launcher Main DOL




    My Priiloader hacks that are enabled:


    REGION FREE EVERYTHING

    Block Disk updates

    Region free Wii games

    Auto press A at Health screen

    Replace Health screen


    I don't know maybe it is my video settings... Does anything look off?
     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    You didn't tell me your Wii's video setting and which cable you are using.

    The default values in USBLoaderGX are :

    Video Mode: Disc/game default to use the video based on the game's region
    VIDTV PATCH OFF enable it only if no other video mode worked. I think it's used to force the Wii to output the video in a specific way instead of using the game's internal rendering video mode. (not sure it's really doing that, but it should be kept to OFF by default).
    Sneek Video Patch OFF most games don't need it.
    Patch country strings OFF only required on japanese games if you don't see japanese characters


    if Disc default make black screen with imported game, it probably means that your TV doesn't accept PAL.
    You can try to set Video mode to "Console default" (to force output to NTSC if your Console is NTSC) and enabled VIDTV if it's in black and white or not working.

    enabling all settings randomly is not recommended, it can conflict.
    disable VIDTV and try Sneek video patch instead (I don't remember which game required it, but only one did if I remember).
     
  7. dragon_slayerxd
    OP

    dragon_slayerxd GBAtemp Regular

    Member
    132
    3
    May 7, 2013
    United States
    Houston, Texas
    hmmm Idk still and still get black screen is there a place where I need to put the forwarder Dol I have it in my WAD folder, and also my tv is in 480 i and Av input
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    The forwarder dol need to be installed in the priiloader's dedicated menu if you want to auto-boot the loader on Wii power ON.

    placing the dol in the wad folder will do nothing at all.
    in the all-in-one package, the dols are located inside the /wad/ folder, but it's only the place they were stored, it's not the folder the user need to use on their Wii.
    just extract that dol and put it on your SD card, then in priiloader select that dol to be installed on your Wii, then set priiloader to auto-boot the installed dol.