Softmodded Wii with d2x cios installed not loading games from USB; Syscheck report included

Discussion in 'Wii - Backup Loaders' started by jameslieb1, Oct 8, 2015.

  1. jameslieb1
    OP

    jameslieb1 Member

    Newcomer
    26
    1
    Nov 24, 2012
    United States
    Something happened and my Wii stopped loading Wii games from USB. It still shows the games in USBLoaderGX and Wiiflow but will not start any game. Launching from USBLoaderGX sends me back to Homebrew Channel. I attempted reinstalling d2x cios v6 using d2x cios installer but this did not seem to help. My syscheck report is as follows:

    sysCheck v2.1.0b19 by Double_A and R2-D2199 Nano
    ...runs on IOS58 (rev 6176).
    Region: NTSC-U
    System Menu 4.3U (v513)
    Priiloader installed
    Drive date: 2006.05.26
    Homebrew Channel 1.1.0 running on IOS58
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 68200120
    Boot2 v4
    Found 140 titles.
    Found 55 IOS on this console. 3 of them are stub.
    IOS4 (rev 65280): Stub
    IOS9 (rev 54321): Trucha Bug
    IOS10 (rev 768): Stub
    IOS11 (rev 54321): Trucha Bug
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 54321): Trucha Bug ES Identify Flash Access NAND Access
    IOS17 (rev 1032): No Patches
    IOS20 (rev 54321): Trucha Bug
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 54321): Trucha Bug
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 54321): Trucha Bug ES Identify NAND Access
    IOS37 (rev 5662): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 16174): Trucha Bug NAND Access
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 54321): Trucha Bug
    IOS51 (rev 4864): Stub
    IOS52 (rev 16174): Trucha Bug NAND Access
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5661): No Patches
    IOS57 (rev 5918): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 54321): Trucha Bug
    IOS61 (rev 5662): No Patches
    IOS70 (rev 54321): Trucha Bug
    IOS80 (rev 54321): Trucha Bug
    IOS90 (rev 54321): Trucha Bug
    IOS202[60] (rev 65535 Info: hermesrodries-v6): Trucha Bug NAND Access USB 2.0
    IOS222[38] (rev 4 Info: hermes-v4): Trucha Bug ES Identify NAND Access USB 2.0
    IOS223[38+37] (rev 4 Info: hermes-v4): Trucha Bug ES Identify NAND Access USB 2.0
    IOS224[57] (rev 65535 Info: hermesrodries-v6): Trucha Bug NAND Access USB 2.0
    IOS236 (rev 54321): Trucha Bug ES Identify NAND Access
    IOS245[37] (rev 21010 Info: d2x-v10beta53-alt): Trucha Bug NAND Access USB 2.0
    IOS246[38] (rev 21010 Info: d2x-v10beta53-alt): Trucha Bug ES Identify NAND Access
    IOS247[57] (rev 21006 Info: d2x-v6): Trucha Bug NAND Access USB 2.0
    IOS248[56] (rev 21006 Info: d2x-v6): Trucha Bug NAND Access USB 2.0
    IOS249[37] (rev 21006 Info: d2x-v6): Trucha Bug NAND Access USB 2.0
    IOS250[38] (rev 21006 Info: d2x-v6): Trucha Bug ES Identify NAND Access
    IOS251[53] (rev 21006 Info: d2x-v6): Trucha Bug NAND Access USB 2.0
    IOS252[55] (rev 21006 Info: d2x-v6): Trucha Bug NAND Access USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10 (DIOS MIOS 2.6.1+)
    Report generated on 2015/10/08.
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,028
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    your d2x is old.
    install at least v8 final.

    The base are all shifted, base 56 should go to slot249, but you have it to slot248
    base 57 should go to slot250, but you have it in slot 247


    249 : d2x v8 base 56
    250 : d2x v8 base 57
    unless you know what you are doing and install base in uncommon location on purpose.

    that's all. you don't need anything else. just (re)install these two.
     
  3. jameslieb1
    OP

    jameslieb1 Member

    Newcomer
    26
    1
    Nov 24, 2012
    United States
    I downloaded d2x cios installer v8 from the link you gave, put it on my sd and deleted the old one yet when i open it in homebrew, the latest version of d2x cios it will let me install is still v6.
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,028
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    did you try pressing D-pad left or right to change the version?

    if you only have v6, then you didn't install it correctly on your SD card.
     
  5. jameslieb1
    OP

    jameslieb1 Member

    Newcomer
    26
    1
    Nov 24, 2012
    United States
    I extracted all the files from the zip to the root of my sd. Is there something else I need to do? Yes i tried scrolling through versions with no luck.

    Also tried doing what you said, but with v6, and the original problem did not fix.
     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,028
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    if you extracted to the root, you did wrong.

    ALL homebrew are going into /apps/<name of the homebrew you want>/boot.dol

    for example, create a folder "d2x installer" inside apps
    SD:/apps/d2x installer/

    and extract everything in THAT folder, not on root.

    apps/installer/boot.dol
    apps/installer/meta.xml
    apps/installer/icon.png
    apps/installer/ciosmaps.xml
    apps/installer/v7/
    apps/installer/v8/
    apps/installer/v10/


    I should really create a new package being "extract on root" friendly. nobody seems to understand that "boot.dol" goes like any other homebrew, into a subfolder inside the apps folder.
     
  7. jameslieb1
    OP

    jameslieb1 Member

    Newcomer
    26
    1
    Nov 24, 2012
    United States
    I did what you said and put it in the right place. Started up d2x cios installer on the Wii and I was able to install the two cios using v8-final. Yet when I try to launch a game in USBLoaderGX it still has the same effect.

    Maybe important: during the install of the second cios, there was a failure in one of the steps, but when the installation finished the block was still marked green as a success.
     
    Last edited by jameslieb1, Oct 8, 2015
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,028
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    good that you could install it :)
    now we can look at the loader's issue without caring about the outdated cIOS.

    going back to HBC or system menu happen when the console can't find the ISO.
    it's either because the cIOS is wrong (but you updated it), or the HDD can't be mounted (wrong USB Port?), or the ISO is corrupted.

    verify that you are using port0 (the bottom one)
    verify that the settings in the loaders are correctly set to use slot249:
    settings > loader settings > game's IOS : 249

    and also, that you are using an updated version of the loader (latest revision is 1256)
     
  9. jameslieb1
    OP

    jameslieb1 Member

    Newcomer
    26
    1
    Nov 24, 2012
    United States
    The version of USBLoaderGX I have is 3.0 r1256-1257. I tried changing the IOS in the loader settings with no effect. The game I'm trying to load is Brawl which is formatted as a split wbfs. I should mention that I launched this exact file from USB before I had the issues and it started up fine. I have the files in my SD for Project M Patt Edition, a modded version of Brawl.

    — Posts automatically merged - Please don't double post! —

    The version of USBLoaderGX I have is 3.0 r1256-1257. I tried changing the IOS in the loader settings with no effect. The game I'm trying to load is Brawl which is formatted as a split wbfs. I should mention that I launched this exact file from USB before I had the issues and it started up fine. I have the files in my SD for Project M Patt Edition, a modded version of Brawl.
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,028
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    the game is on usb ?
    if you want to enable projectM patching, don't forget to enable the individual game option : hooktype : VI

    try another loader, maybe your ISO is corrupted?
     
  11. jameslieb1
    OP

    jameslieb1 Member

    Newcomer
    26
    1
    Nov 24, 2012
    United States
    Ultimately got it to work by launching Project M from Gecko OS. Thank you a ton for your assistance. :) If I encounter any more related issues I will contact you directly sir.
     
  12. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,028
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    that's good that you can play the game, but it didn't fixed your issue with the loader.
    USBGX is working only with Wii games on USB, so maybe it's related to projectM being on SD card, I don't know.

    well, as long as you can play what you want that's fine.
     
  13. jameslieb1
    OP

    jameslieb1 Member

    Newcomer
    26
    1
    Nov 24, 2012
    United States
    Oh yes, I'm going to put another wii iso on my usb hdd and see if i encounter the same problem. I also considered that it may be an issue with loading the Project M sd files.