Softchip r99 + 4.2U + MH3 = Fail?

Discussion in 'Wii - Backup Loaders' started by Kornflake, Oct 16, 2009.

Oct 16, 2009
  1. Kornflake
    OP

    Newcomer Kornflake Newbie

    Joined:
    Oct 16, 2009
    Messages:
    3
    Country:
    United States
    So, I updated my wii to the latest 4.2U; I can run every backup with the normal backup launchers but I always had the SoftChip launcher to play Monster Hunter 3. Before updating to 4.2U I needed to run MH3 from the SoftChip launcher using a bugfixed ios55. (If I didn't do it like that, monster hunter would just give a buzzing sound after selecting the first option on the menu).

    Now if I try to run monster hunter tri I get this error on SoftChip:

    Exception: loctl error (DI_ReadID)

    and it won't load any game.

    I can load MH3 from the other backup launchers but it freezes and starts to "buzz" after selecting the first option, just like it did before the cios55bugfix.

    --

    Any way of fixing this error? do I just reinstall the bugfix, or will that mess with something that the 4.2 uses? (don't really know if the ios55 was updated in 4.2)

    I'm running with rev10 (I won't update, since this cios lets me jump the 002 error without mods), softchip running the game with IOS55 (monster hunter requires to run in 55) and same disc I used before.
    Before updating to 4.2 I had the same setup, and the game worked fine. I just need a way to play Monster Hunter 3 on 4.2U or a way to revive SoftChip's ability of running MH3/Jap. xD

    note: I also tried using IOS249, and I re-burned the game with IOSPatcher to "work" in 249 but the game keeps "buzzing" on the other launchers and failing to load on SoftChip. [​IMG]
     
  2. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    All IOS were updated, and it's to be expected that all IOS get updated again by the next update. Your IOS55 bugfix, is a cIOS not a bugfix. You can run other games with that as well even with no (regular) cIOS installed at all.
     
  3. Kornflake
    OP

    Newcomer Kornflake Newbie

    Joined:
    Oct 16, 2009
    Messages:
    3
    Country:
    United States
    ok then thanks for the answer [​IMG] I installed the ciosbugfix and now the game works like before.


    And I now know what the

    Exception: loctl error (DI_ReadID)

    error is; I was trying to run the game from an IOS that wasn't used for loading backups. Since softchip changes to ios36 after "attempting" to load with the selected ios, the disc was always forced to the ios36 which is not ment to load that particular game... go figure xD I updated the ios55 and then installed the bug, and the softchip is running my imports again.
     

Share This Page