Soft modding a virgin 2.0U Wii without updating to 4.2...

Discussion in 'Wii - Hacking' started by brett824, Oct 15, 2009.

  1. brett824
    OP

    brett824 Advanced Member

    Newcomer
    52
    0
    May 6, 2007
    United States
    I found my brother's old Wii today and to my surprise, it's still on 2.0. I want to homebrew it, but I don't want to risk updating to 4.2 with Ninty's shitty code. I don't have Twilight Princess, so what would be the best way to get Homebrew it to use some sort of safe updater to a higher firmware? Will Bannerbomb work on 2.0U?
     


  2. Rise

    Rise Member

    Newcomer
    49
    3
    Sep 13, 2009
    Think you`ll need to find a game disc with a 3.x update on it and install that, then use bannerbomb.

    EDIT: Bannerbomb only works on 3.x and above
     
  3. smf

    smf GBAtemp Maniac

    Member
    1,116
    218
    Feb 23, 2009
    Personally I'd update it to 4.2 from Nintendo.

    Why? Because if it hasn't had any homebrew run on it already & the update breaks it, then they've said they'll fix it for free.

    After you have 4.2 on it, you can mod it as much as you want & you know you aren't going to get problems upgrading to boot2v4 in the future.

    It's no harder to hack 4.2 than it is to hack 3.4 onwards.
     
  4. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    The update reportedly has bricked only a small number of Wiis. I don't imagine it will give you any trouble.
     
  5. Lindfalas

    Lindfalas Member

    Newcomer
    33
    0
    Feb 26, 2009
    Upgrade to 4.2.
    It would work for 99% Wii.
    So its no use to start messing around with old stuff.

    Greetz
     
  6. brett824
    OP

    brett824 Advanced Member

    Newcomer
    52
    0
    May 6, 2007
    United States
    Eh, I ended up getting to 3.1U with a Brawl disc I found laying around and updating to 4.1U from there. Thanks for the suggestion Rise, I completely forgot discs used to come with System Menu updates.
     
  7. jazvdb

    jazvdb GBAtemp Advanced Fan

    Member
    835
    0
    Jul 22, 2009
    United States
    In front of computer...

    Where have you been?

    Just update officially then hack from there using bannerbomb
     
  8. ether2802

    ether2802 we have the techno...!!

    Former Staff
    4,350
    5
    Oct 14, 2007
    Mexico
    Pto. Vallarta
    Well I would update with a disc to 3.1, then install HBC and all the cIOSes (202, 222, 223, 249) and then use Safe Firmware Updater to 4.2, it is way easier than go to 4.2 and then have the hasle of the restrictions to install these..!! [​IMG]
     
  9. Lindfalas

    Lindfalas Member

    Newcomer
    33
    0
    Feb 26, 2009
    Why?

    Its so easy to update direct to 4.2 and do the few things you need to get things working.
    It would take less time and you will know it will work.
    I dont understand why people use Safe firmware updater at all
    Is safe to upgrade to 4.2 from nintendo. Its is a few Wii that has been broken and if you have so bad luck you can get it fixed at nintendo for free.

    Greetz
     
  10. brett824
    OP

    brett824 Advanced Member

    Newcomer
    52
    0
    May 6, 2007
    United States
    This is some flawed logic.

    "There's only a SMALL CHANCE your 250 (well 200 now) dollar console gets broken forever, why would you jump through a small extra hoop to avoid that?"
     
  11. smf

    smf GBAtemp Maniac

    Member
    1,116
    218
    Feb 23, 2009
    If it breaks updating to 4.2 and you hadn't installed homebrew, then they'll fix it for free. Now you've installed homebrew, they won't.
    There is a small chance that any time you write to your nand that it will cause it to brick.
     
  12. Lindfalas

    Lindfalas Member

    Newcomer
    33
    0
    Feb 26, 2009
    Well if you break it when you upgrade, they dont see it anyway.
    But the chance it will break is less then 1%.
    ITs bigger chance you break it when you upgrade it with other stuff.

    Greetz
     
  13. G0dLiKe

    G0dLiKe who needs a title ;)

    Member
    1,674
    51
    Aug 2, 2009
    United States
    Just install BootMii to boot2, make a Nand backup, keep it somewhere safe on your computer and after that, try your desired way to update.
     
  14. wiiztec

    wiiztec GBAtemp Fan

    Member
    380
    6
    Apr 3, 2009
    United States
    Updating to 4.2 with nintendo is the stupidest thing you could ever do, it updates boot2 to boot2v4 which wipes out bootmii and makes it so you can't downgrade IOS's it also updates all homebrew/backup loading IOS's to stubs

    Golden rule of having a modded Wii is DON'T EVER UPDATE THROUGH NINTENDO! EVER!
     
  15. odinthegreatone

    odinthegreatone Member

    Newcomer
    15
    0
    Apr 16, 2009
    Canada
    There are plenty of guides to get homebrew and backups working on 4.2. (wiihacks.com has plenty of guides as well as on this forum). Plus its no harm compared to Waniko`s update that somehows trucha bug every ios.
     
  16. wiiztec

    wiiztec GBAtemp Fan

    Member
    380
    6
    Apr 3, 2009
    United States
    That's what cioscorp does not Waninkoko's updater
     
  17. xzxero

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    its not bad to update via nintendo.
    its only a hassle if you got cioscorp installed.
     
  18. ztien

    ztien Newbie

    Newcomer
    4
    0
    Dec 21, 2014
    i got an old wii v2.0u i want to update it and make a softmodding my problem is that the only cd i have is "SONIC and the Secret of the Ring" anyone can help me to make it possible to update without buying a new CD of WII Games products?
     
  19. Lacius

    Lacius GBAtemp Guru

    Member
    6,104
    2,436
    May 11, 2008
    United States
    Connect to the internet and update to 4.3 before softmodding.
     
  20. ztien

    ztien Newbie

    Newcomer
    4
    0
    Dec 21, 2014
    WII products are not supported by manufacturer so even i have an internet i cant update it.