So is it possible to softmod a Wii with the current firmware?

Discussion in 'Wii - Hacking' started by Anakinnnn, Nov 16, 2008.

  1. Anakinnnn
    OP

    Newcomer Anakinnnn Member

    Joined:
    Nov 11, 2008
    Messages:
    13
    Country:
    United States
    Okay, over the past two weeks, I decided to try the softmod on my Wii. During that time I obviously came across the problems with the October 23rd update. The problem is that there are 20+ guides out there explaining how to downgrade your CIOS, or how to modify it, or how to uninstall the update or whatever. Some refer to having a ModChip installed, some don't. The forum documentation is sparse in accuracy, and yet there's hundreds of threads dedicated to it.

    I have followed 12 different guides and posts now on how to SoftMod my Wii using the Twilight Hack. I have used probably a couple of hundred different combinations and uninstalled and reinstalled so many WADs and MODs that I can't see straight. I have YET to have a single error in any of the installations too! So I know I am doing everything right.

    But no matter what, when I try to put in a retail movie, a burned movie, or a burned Wii game, I get exactly the same issue. There's this goofy message about "loading" and then the next line is "SET ENTRY POINT NOT FOUND ON DVD" or something like that because I can't read it. The text is all written over itself. I have used WiiGator3, BackupLoader .1 and BackupLoader .3 and every other version of Backup Loaders and not one has made any difference.

    Can someone, anyone, please give me some solid instructions to SoftMod a updated firmware Wii of 3.3U? I can almost guarantee you I have all the necessary files because I have now collected 931Mb of files through various channels (many files duplicated and of various versions) so now all I need is to know why after I follow the rules precisely does it still not work...

    This was a virgin Wii up until two weeks ago. I now have a the Twilight Hack installed and tons of CIOS files installed as well as a Homebrew Channel and various other channels. The first time I ran the Homebrew Channel it went online and accessed a channel and I downloaded some stuff. It has never worked since then...I can only get it to load stuff off of a SD card.....so somewhere, that part of the channel went away.

    Can someone help me with this? I am not an idiot. I have spent hours on this, but without the theory on what these files do, I can't even make an educated guess as to what is happening.
    Thanks
    Anakinnnn
     
  2. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States
    try doing the pack in my sig....
    then get back to me, and I will help you get the NEWEST stuff,
    as the stuff in that package is one generation back...

    but if it works, we'll know what we have to do. (I will, and I'll walk you through it)

    also, I'm updating that pack soon, and I'll make sure V3 overwrites V2
     
  3. rmorris003

    Newcomer rmorris003 Newbie

    Joined:
    Nov 9, 2008
    Messages:
    6
    Country:
    Canada
    My mom just bought our wii yesterday and i used the above pack and it worked great on 3.3 but we didnt have the oct 23rd update yet and ive updated it and still going strong.

    Just follow the guide and use the twilight hack and I used homebrew channel and works great with the new cios rev 7
     
  4. Anakinnnn
    OP

    Newcomer Anakinnnn Member

    Joined:
    Nov 11, 2008
    Messages:
    13
    Country:
    United States
    So should I uninstall anything before I even start this? And also, will your guide work with the current firmware or do you know?
    I am willing to give it a try and see where it goes......then maybe together we can figure out how to put out a current guide.

    Thanks a lot for responding.
     
  5. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States
    well....in the guide I believe it says both:

    -works with newest update, no downgrading
    -should just overwrite anything, but if you get problems try uninstalling other crap you've installed.


    just try using it first, as instructed.
    you shouldn't get any errors, if you do, read the common problems area.

    its pretty dummy-proof.
     
  6. Anakinnnn
    OP

    Newcomer Anakinnnn Member

    Joined:
    Nov 11, 2008
    Messages:
    13
    Country:
    United States

    Thanks a lot for your help. I am trying it now.....
    I will respond back here with the results shortly.
     
  7. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States

    ok, I'm going to bed......have fun with those launchers and I'll get back to you about more goodness later.
     
  8. Anakinnnn
    OP

    Newcomer Anakinnnn Member

    Joined:
    Nov 11, 2008
    Messages:
    13
    Country:
    United States

    Okay, here's my update. I used the Twilight Hack for 3.3 and put that in the root of the SD card along with your SD card files. I also added IOS16 to the card, just in case.

    So, from scratch, I did the Twilight Hack and booted into the Wad Manager you provided. I installed everything in order.

    I restarted the Wii.

    My first problem here is that I have a bunch of channels that are all the same now and I have no idea which ones are yours and which ones I had already. I would like to get rid of all of the garbage on my system now and then do your method just so I know what is going on. But that's just me wanting to do good housekeeping.

    Next, I put in a retail movie DVD. (This is where I am confused about the loading of it I guess.) I tried to load it using one of the backup loaders or whatever. It never plays and gives that weird LOADING and then it can't identify the disc and it says something like ioctrl or something. Remember, I can play regular Wii store bought discs fine.

    Then, I put in two different burned Wii games that I know are working. I get the same loading error I described before. However, they are on Memorex DVD+R discs. I saw mention that you should use DVD-R discs. I can try that next since I have both.

    So basically, I have a mess of installed files and channels now and I have no idea what is good and what isn't. Is there any easy way to get rid of everything and just get the current Wii IOS and the channels I should have?
    Also, I am trying to figure out where I first used that interface for the HBC and got online with it to download all kinds of files. Where did that go? I still have the channel, but it doesn't do anything but load up to an animated screen waiting for something from the SD card.

    Thanks
     
  9. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States
    ok I really am going to bed, but I'll answer first.
    you've really got two issues going on here:

    A) plain and SIMPLE, you cannot use BOTH the 0.1 backup launcher in my or any pack AND the DVD-Playback features,
    so if you want video playback, you need to do things a little different.....DVDx_247 is all wrong for you, you need to do a standard install of DVDX (it'll overwrite your old one, so thats fine, just use DVDx installer and do "normal"...btw, the playback ability is shite right now, not DVDx's fault) once you work that out, you play DVD-Video through MPlayerDVD (Twiizers Edition) [and that is the only thing that will play DVD-Videos, no other progs will work, no launchers, etc.]

    ok...

    B) I have no idea what the hell you have installed, but yes, a lot of the same banners have gotten around. Mine have "Titles" with no spaces, if that helps.
    I have no idea if there is a simpler way to remove them all than just assembling all the wads into your "wad" folder, and using wad manager to (-) uninstall them all one-by-one (a lot quicker than installing, btw)....you can uninstall anything that talks about DVDx, Wiigator, SoftChip, Waninkoko, cIOS, 249, 247.....if you use "AnyTitle Deleter" you'd have an easier time, but you'd need to know SOMETHING about Title-Id's, and I kinda feel like that might be beyond you right at the moment (no offense)....but if you go down that road, a helpful hint....the lists in that prog begin with the most recently installed titles, so if all you have installed lately is this stuff, that in the "downloaded channels" tab, you can kinda work backwards, just make sure you don't delete legitimately purchased VC content.
     
  10. Anakinnnn
    OP

    Newcomer Anakinnnn Member

    Joined:
    Nov 11, 2008
    Messages:
    13
    Country:
    United States
    Thanks a lot NoobWarrior. I really do appreciate you working with me on this. Your patience with me on this is truly appreciated.

    Oddly enough, I am an I.T. professional and working with these files for hacking and modding is nothing new to me, but for whatever reason, the Wii SoftMod scene seems like a trainwreck. I had no idea that Oct 23rd update caused so many problems.

    Here's what I am looking for man. I actually don't want the DVD playback. I have a PS3, a Xbox 360, a HTPC, an Upconverting DVD player, and a computer network for video streaming, all for use in playing DVDs. The last thing I am ever going to do with the Wii is play a DVD. But what I had been doing before your pack was trying to play a retail DVD to make sure the pack installed correctly. Apparently, that was a stupid test now that I am understanding playback doesn't work without loading up MPlayer. (I had Mplayer installed a FEW times already and I couldn't load the DVD movies even then so who knows what kind of mess I have.) All I am looking to do is play Wii game backups. That's all. I am not really interested in all of the Homebrew stuff or adding a bunch of Apps or anything. Just game backups. I also am not interested in making my own backups. I have plenty of sources to obtain backups that are tried and tested without worry of public files and other garbage getting in my Wii.

    So basically, I want to run an app or channel on my Wii after putting in a DVDR of a game and then hit Launch. I assume that is what the rest of the world is doing...

    As for cleaning up the Wii currently. I went through after you went to sleep and went into the Wii Data area and "ERASED" all of the channels that I didn't want or need anymore including the ones from your pack. I left the channels for the Shopping, Internet, and other garbage from Nintendo. But I got rid of everything that had been added recently through mods and wads including the HBC. That left me with what looked like my original Wii (on the front end only of course). So then, I followed your method without error. I got the 4 or 5 channels that comes with following every step of your method. I tried to put in a backup and it gives me the same error I have been having which is the text written over top of itself (something about "identify DVD set point something"). As of right now, I believe this has GOT to be because of the media I am using (Memorex DVD+R). I am going to burn an ISO of a working game on a DVD-R and see if that improves my issues.

    Also, I wanted to know how to get my HomeBrew Channel back again at some point without having to use the Twilight Hack. Or is that the best way to add a new channel like that? Or can you tell me if it's safe to use your Wad Manager channel from your method to load a HBC Beta 9?

    Thanks so much for your help. Sorry for the longwindedness, but I try to be thorough in everything I do so people have an easier time of helping me with issues.
    Thanks again.
    Anakinnnn

    UPDATE: I tried burning an ISO of Metroid Prime on a DVD-R and the WiiShizzza Backup Loader actually read the disc this time and saw that it was a game finally. It did give me an error about the game disc not being able to load but it looked like a Nintendo error or something. Maybe the loader doesn't work with this game. I will look into it. I am trying to run a burn of another game shortly. I will give you an update on that afterwards. So it does look like the media was a major problem. As for adding the HBC back on, I tried to do the Twilight Hack to add in the HBC Beta .9 and it fails out because it can't find boot.elf or something... I am going to work on that more, but I decided I would wait until you give me a better idea if loading that through the hack is going to screw up something I have already done from your pack. I was mistaken that your pack does not provide the HBC channel or a Wad Manager channel. Would I add those through a Wad Manager? And how do I load something right now without using the Twilight Hack? Thanks again for your help.
     
  11. noobwarrior7

    Member noobwarrior7 GBAtemp Advanced Maniac

    Joined:
    Aug 2, 2008
    Messages:
    1,594
    Location:
    USA
    Country:
    United States
    I came back, cuz Im burning something...

    ok...so you did my whole pack......

    it is likely you will resolve your problem with a media change.....DVD+R's not only need to be booktyped as DVD-ROM, but are also finicky.



    the reason why DVD-R's don't need to be booktyped? THEY DO, they just ALREADY ARE.

    if that doesn't work, make sure you are testing games that work before gamma came out,

    AND, make sure with 0.1 you are using decrypted(patched) discs.

    beyond that, I've only known 3-4 reports that absolutely none of this worked for them.

    4 versus over 120 confirmed, not sure I believe the 4 are doing what they should be.

    PS: Im not sure you understood, so just to say again, the only problem with DVD-Video, is you can't be using the 0.1 launcher, because it needs dvdx pointing at 249, and you for DVD-Playback, you need it pointing elsewhere....

    if you dont need 0,1, you can enable the POC dvd playback easiily, with a regular ole DVDX install.


    PS2: if you are trying this on a chipped system, reverse everything...launchers don't work period, and DVD-Video works no matter what cIOS you point it at.


    Finale: use the tp-hack with hbc installer .dol to get it back, best way for sure.
     
  12. Anakinnnn
    OP

    Newcomer Anakinnnn Member

    Joined:
    Nov 11, 2008
    Messages:
    13
    Country:
    United States
    Okay, so I played my first Wii backup last night with your help.
    I tried out the Rockstar Games Table Tennis. The game sucked, but it did play off of the burned disc.
    The odd thing is, I was able to play for about 20 minutes and I heard the disc drive kind of freaking out and then I got a message saying "unable to read disc" and it locked the Wii. So I was able to load the game again and it worked again but during the entire time, the disc drive was still making a lot of racket. None of the retail discs do that of course, so I know it's not my drive.
    I will again, chalk it up to the media.

    Do you have a recommended brand of media out there that has good results?
    I have used the Memorex purple label stuff and now some Philips stuff, both retail packages from major retailers.

    What about the Virtual Console stuff out there? I have seen packs of that stuff to try to install. If I choose to try any of that does it interfere with the mod?

    Also, do you consider there to be a great place to see the database of games that consistently work with the softmod so I know what will and won't work so I don't waste my time?

    One more thing, I have an NTSC North American release Wii. Will your loader work with PAL discs? or do I need to run them through some kind of patcher first? Or do I just stick with NTSC?

    And lastly, if a game is asking for an update, can I still choose to do so at this point in time? I have the latest firmware already, so would it matter that a game asks for another update?

    Thanks again for your help.

    Anakinnnn
     

Share This Page