So if on 5.5.0, is there any reason not to update to 5.5.1?

Discussion in 'Wii U - Hacking & Backup Loaders' started by DiscostewSM, Jan 28, 2016.

  1. DiscostewSM
    OP

    DiscostewSM GBAtemp Guru

    Member
    5,027
    2,663
    Feb 10, 2009
    United States
    Sacramento, California
    Title says it all. Been waiting to hack my 5.5.0 system with things like the IOSU exploit, but from what I hear going around, supposedly 5.5.1 can/will do all that 5.5.0 because the update doesn't affect the portions that 5.5.0 hacks work off of. Is this true?
     


  2. VinsCool

    VinsCool Comfortably Numb

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,856
    28,351
    Jan 7, 2014
    Canada
    Another World
    From what I understood. There is nothing in the system that changed, only a web browser patch between these 2 versions.
     
  3. hashcheck1

    hashcheck1 GBAtemp Fan

    Member
    424
    125
    Aug 5, 2013
    I think its a great time to grab stuff of eshop now ie updates etc as we know its safe for iosu exploit. that said i have decided to stay at 5.5 as from past experience you always regret updating
     
  4. Selim873

    Selim873 Nunnayobeesnes

    Member
    1,174
    588
    Jul 31, 2010
    United States
    Chillin' with Bob Ross
    Except it was actually confirmed by Hykem that 5.5.1 is safe from my understanding. All you lose is most entry points, the only one left available being the one by Yellows, which is in fact the most stable.

    EDIT: You are right in most cases though, should have pointed that out. The 5.5.1 version should be able to launch using Yellow's entry point. (Guessing) But it was confirmed that the IOSU exploit will work on 5.5.1.
     
    Last edited by Selim873, Jan 28, 2016
  5. piratesephiroth

    piratesephiroth I wish I could read

    Member
    3,007
    1,619
    Sep 5, 2013
    Brazil
    Unless you really want to download something from the eshop right now, you have no good reason to update
     
  6. Mhetralla

    Mhetralla Member

    Newcomer
    49
    29
    Apr 17, 2009
    I'm waiting on 5.5.0. The only thing N updated was the browser, but they maybe implemented a way block the browser in old versions, like they did with the 3DS. And without browser, we don't have any entry point.
    Hykem said that the exploit works in 5.5.1, but maybe it only works now. Maybe they block mp4 playback remotely when the exploit is released, and then fix it with an update.
    I'm paranoic, but every caution matters with this things.
     
  7. Selim873

    Selim873 Nunnayobeesnes

    Member
    1,174
    588
    Jul 31, 2010
    United States
    Chillin' with Bob Ross
    That's what kept my WiiU unplugged from power for over a month. As soon as I found out Hykem confirmed it would work on 5.5.1, I went ahead and updated so I could play Splatoon and Mario Maker. Hopefully one of those background devs with the IOSU exploit has an EmuNAND solution in the works, which is really all I need. (I heard there's a group working with Hykem)
     
  8. Chuardo

    Chuardo GBAtemp Fan

    Member
    306
    182
    Oct 4, 2015
    Uruguay
    They didn't add a way to block the browser in older versions, Crediar already said that there is no such thing on the Console.
     
    ashio83 likes this.
  9. ashio83

    ashio83 Member

    Newcomer
    25
    18
    Jan 15, 2016
    Sesspool UK
    EXACTLY!

    The misinformation on these forums in incredible.
     
    Chuardo and licantropo94 like this.
  10. hashcheck1

    hashcheck1 GBAtemp Fan

    Member
    424
    125
    Aug 5, 2013
    Smea, crediar, Yellow8 Confirmed on irc they are on 5.5.1 today

    OSv10 (ISOU, PPC kernel, SDK libs) wasn't update between 5.5.0 and 5.5.1
    webkit was updated but the exploit we got still works
     
    Last edited by hashcheck1, Jan 28, 2016
    ashio83 likes this.
  11. Bhampster

    Bhampster Member

    Newcomer
    11
    0
    Jan 6, 2016
    United States
    Yeah well... I update everything that gets an update.

    I don't care anymore about the vapor-ware exploits and there's plenty of stuff I want from the eshop.

    Wii U is about done ... Focus and hype is for NX. I think I can outright buy all the Wii U games I'm going to want.

    That said, I'm very grateful I was able to homebrew my Vwii or else I would need to keep my Wii in my already complicated system.
     
  12. hashcheck1

    hashcheck1 GBAtemp Fan

    Member
    424
    125
    Aug 5, 2013
    I agree... NX hopefully will bring Nintendo back. Really excited and will be buying day1
     
  13. fiveighteen

    fiveighteen High Hopes and Low Expectations

    Member
    1,755
    1,264
    Jun 30, 2008
    United States
    Do you want to at least, idk, see the reveal of the console before throwing your money at it? Lol.
     
    henn64 likes this.
  14. jimbo13

    jimbo13 GBAtemp Fan

    Member
    379
    364
    Jun 21, 2012
    United States
    The rule of thumb is never update, Stickies said 5.4 and 5.5 were both exploitable meanwhile only 5.4 has anything coming out.

    But I don't think anything is coming out anytime soon, yes it's all done and sitting on peoples hard drive and it's going to stay there while they troll, post pictures, make false announcements for publicity to get followers on their twitter and if you dare ask if/when you are either going to be lied to or told you are cheap and need to go buy a 5.3.2 console you dirty pirate.

    So if it's keeping you offline I'd go ahead and update, or be prepared to be trolled indefinitely while elitists slurp up your tears for nourishment.
     
    Guy50570 likes this.
  15. TheDarkGreninja

    TheDarkGreninja How could you hate that face?

    Member
    2,261
    956
    Aug 25, 2014
    On his bed
    Thats off topic...

    On topic: Anyways i updated since i really wanted to play online.
     
  16. monito uchiha

    monito uchiha Member

    Newcomer
    23
    6
    Oct 9, 2015
    Here is my situation! My console is at 5.5.0 and I like to play Mario Maker levels on-line but they release a new update today for the game so I'm forced to update the firmware to 5.5.1 just to get the new software update! And 3 of the best hacker's (in consoles) are telling to us that 5.5.1 its okay. So there's no problem. The rule always is not to update but Hykem wrote that is fine so... The rule doesn't apply..

    (Sorry for my bad English)
     
  17. JohnathanMonkey

    JohnathanMonkey GBAtemp Advanced Fan

    Member
    577
    185
    Apr 26, 2013
    United States
    5.5.1 with tubehax is fine. Trust me, I'm a doctor.
     
    Guy50570 likes this.
  18. Bhampster

    Bhampster Member

    Newcomer
    11
    0
    Jan 6, 2016
    United States
    I won't go beyond 5.5.1 (till 5.5.2 is released)
     
  19. hashcheck1

    hashcheck1 GBAtemp Fan

    Member
    424
    125
    Aug 5, 2013
    The thing with online consoles is you really have to decide if you want online(ie patches online play) or homebrew. It's catch 22. I think when my Nintendo network rolls out the wiiu is going to see a major is update and we will be in that hard choice again
     
  20. Slartibartfast42

    Slartibartfast42 GBAtemp Advanced Fan

    Member
    822
    234
    Mar 6, 2013
    United States
    New Guitar Hero Live update. I can't play it online unless I update.