So how long do you think Gateway will last?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Jiro2, Dec 25, 2013.

  1. Kane49

    Kane49 GBAtemp Fan

    Member
    3
    Nov 4, 2013
    Gambia, The


    Not terribly difficult is an understatement @_@ Verifying a correct Dump is a science in itself not to mention that installing the flasher is quite the pain ^^
     
  2. XDel

    XDel Author of Alien Breed: Projekt Odamex

    Member
    8
    Jul 25, 2012
    United States
    Another Huxleyian Dystopia
    I was under the impression that the R4 3DS could work on the latest firmware. Was I misinformed?
     
  3. Ryukouki

    Ryukouki See you later, guys.

    Member
    12
    Jan 31, 2008
    United States

    Only the emulated portion will, but not the actual system firmware. Your actual firmware must be between 4.1 to 4.5.
     
    XDel likes this.
  4. Jiro2
    OP

    Jiro2 GBAtemp Advanced Fan

    Member
    4
    Mar 28, 2011
    United States
    The problem is that Gateway is made by a company who only is motivated to update the Gateway as long as they can still sell Gateways. At some point there won't be any more 4.5 systems on the market, so they won't be able to sell any more Gateways, so they'll stop releasing updates.

    You can't compare this to the firmware 3.55 PS3 scene because the updates that are needed on hacked PS3s come from hackers, not from a company, and they just release updates because they want to, not because the updates go with a product that they are trying to sell.
     
  5. XDel

    XDel Author of Alien Breed: Projekt Odamex

    Member
    8
    Jul 25, 2012
    United States
    Another Huxleyian Dystopia
    Well I guess if the PS3 kept going strong, then I presume there is nothing to worry about with the 3DS either. Though I would think that that would make the price of a 3DS with lower firmware go up as time goes on, but I could be wrong.

    As for me, next month I'll invest in a used 3DS and cross my fingers that it never needs repairs.
     
  6. Xzi

    Xzi All your base are belong to the proletariat

    pip Contributor
    19
    Dec 26, 2013
    United States
    Spiraling Out
    Consider however that updating also increases interest and sales. For at least some period afterward. From this point on, there will always be a 3DS "scene," and being the foremost innovator/leader in that is a matter of hobby and pride, not just financials. If another group manages to take the reins, starts releasing several innovative features, AND 4.5 systems are pretty dried up, then Gateway might die down. But by that time, I think 3DS flash carts will essentially be feature-complete. You really have to consider how big a market we're dealing with here, when the DS scene was really darn big.
     
  7. EvilMakiPR

    EvilMakiPR GBAtemp Addict

    Member
    7
    Apr 9, 2013
    All we need is a real hack or Hardware Hack for the 3DS. We need to steal Smea's work XD
     
  8. Abcdfv

    Abcdfv What comes around goes around.

    Member
    5
    Dec 24, 2013
    United States
    I would pay so much for this if there was some way to get all thee CPUs working in harmony.
     
  9. Tattorack

    Tattorack Interstellar Explorer

    Member
    3
    Jun 15, 2011
    Denmark
    Calisto Prime Orbital
    You serious? Did you ever check ebay?
    When I look for 3DS' with these search terms: "3DS v4.5" or "3DS gateway complatible" I get over two pages of 3DS' avaible.
    That hasn't changed yet...
     
  10. EvilMakiPR

    EvilMakiPR GBAtemp Addict

    Member
    7
    Apr 9, 2013
    "eBay"
     
  11. RaMon90

    RaMon90 GBAtemp Advanced Fan

    Member
    2
    Dec 3, 2013
    Italy
    Anyone can explain why it's only possible to install on 4.5 below firmwares? With R4i flash carts you can even install it on 6.3 and play just NDS games.
     
  12. Xzi

    Xzi All your base are belong to the proletariat

    pip Contributor
    19
    Dec 26, 2013
    United States
    Spiraling Out
    Because 4.5 and earlier have an exploit that allow access of 3DS mode through DS mode. A fair number of DS exploits will still work past 4.5, but the 3DS mode cannot be accessed in the same way, thus barring you from playing 3DS backups, but not DS backups.
     
  13. Tattorack

    Tattorack Interstellar Explorer

    Member
    3
    Jun 15, 2011
    Denmark
    Calisto Prime Orbital
    Oh the gods! I forgot a capitol letter!
    That totally changes the argument.
     
  14. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23
    Nov 21, 2005
    United Kingdom
    I do not know if that was a quibble with your grammar/spelling (which I agree would be a pointless thing to pull you up on) or that the ebay part of the equation caused issues (many do not like ebay and would not consider shopping there).
     
    EvilMakiPR likes this.
  15. Tattorack

    Tattorack Interstellar Explorer

    Member
    3
    Jun 15, 2011
    Denmark
    Calisto Prime Orbital
    Well, yeah, there's something I can agree on, I don't like ebay that much either, but that is the only place that sells the most 3DS' with v4.5 firmware...
     
  16. EvilMakiPR

    EvilMakiPR GBAtemp Addict

    Member
    7
    Apr 9, 2013
    And I don't know in which eBay are you searching cuz in the US one only appear like 2 or 3 3DS in a list of other stuff that are not even related to 3DS
     
  17. Sparks43

    Sparks43 Advanced Member

    Newcomer
    1
    Jan 1, 2014
    Does Gateway work on Japanese region 3ds systems?

    I have a 4.0 or so system that i got cheap that i would be happy to have a go at and purchase a card for.

    Dont mind too much if all i can play is japanese backups as i have a fully updated xl for all the new games and eshop releases.
     
  18. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    9
    Oct 22, 2011
    Gambia, The
    Yep. It's independent of the region.

    Gateway makes the 3DS region free (at least for ROMs you play with the GW).
     
    Sparks43 likes this.
  19. Sparks43

    Sparks43 Advanced Member

    Newcomer
    1
    Jan 1, 2014
    Nice going to have to get one soon so.

    Just finished Link between worlds and now my daughter has her hands on the 3ds and i dont think i will be seeing it much for the foreseeable future.

    My view on gateway is that if they can find one exploit for a system on 4.5 given time they will or someone else will crack the later firmwares.

    Im a big believer in anything a man can make a man can crack.
     
  20. mathieulh

    mathieulh GBAtemp Fan

    Member
    5
    Feb 28, 2008
    France
    You can already run code in the kernel context using the mset (userland exploit) and the rsa_verify (Kernel exploit triggered from userland through ROPs) exploits.
    Python scrips that can generate ROP chains for both have been publicly released last night. (although the actual payload and comments are missing from the kernel exploit python script)

    It's not hard, especially to those who have reversed the whole ROP chain before to see that the kernel exploit relies on a HUGE rsa_verify request feeding your payload to a specific address (0x080C3EE0 on gateway's ROP chain).
    Even though that's a userland address the payload will execute with kernel privileges at this point.
    (it is later on copied to the kernel which triggers an overflow)

    Considering you are now running code with full privileges, you aren't too far from someone having the "bright" idea to write his own 3DS Warez loader (hell, all it really takes is a redirection).
    That should be it as far as Gateway or other 3DS "flashcards" go.
     
    Margen67, mocalacace, xerpi and 2 others like this.
Loading...