SMA4: SMB3 corrupted save data on an EZ-Flash IV

Discussion in 'GBA - Flashing Hardware and Software' started by Prof. 9, Dec 27, 2008.

  1. Prof. 9
    OP

    Prof. 9 GBAtemp Fan

    Member
    318
    116
    Jun 17, 2008
    Netherlands
    The Netherlands
    I've tried multiple patches, releases and saves, but I keep getting the "Saved data is corrupted" error :/

    What am I doing wrong?
     
  2. Maedhros

    Maedhros GBAtemp Advanced Fan

    Member
    897
    4
    Nov 26, 2008
    Brazil
  3. Prof. 9
    OP

    Prof. 9 GBAtemp Fan

    Member
    318
    116
    Jun 17, 2008
    Netherlands
    The Netherlands
    Am I supposed to apply them before patching the game with EZ4 Client, or afterwards?

    Also, should I check the "Add Save Patch" box or not?
     
  4. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,516
    9,335
    Nov 21, 2005
    Try 8:3 naming for the rom and the corresponding save. I keep meaning to change it in the GBA list but I have not been up for it yet.
     
  5. Prof. 9
    OP

    Prof. 9 GBAtemp Fan

    Member
    318
    116
    Jun 17, 2008
    Netherlands
    The Netherlands
    Thanks, it worked! I still get the "Saved data is corrupted" message, but at least now I can save.
     
  6. triften

    triften Advanced Member

    Newcomer
    72
    0
    May 12, 2008
    United States
    Does this pertain to GBA ExpLoader, too? I have an EZ V Plus & EZ 3-in-1 loading ROMs with GBA ExpLoader 0.58b

    When I load a clean ROM with filename "SMA 4," my saves become corrupted.
    When I IPS patch a clean ROM with the same filename, the game locks up.

    This happens with both Super Mario Advance 2 - Super Mario World and Super Mario Advance 4 - Super Mario Bros. 3. Every other game (including the other SMA games) seem to play and save just fine...