Slow Internet on WiFi and Ethernet Windows 10 - GNU/Linux is fine

Discussion in 'Computer Software and Operating Systems' started by Cuelhu, Sep 29, 2018.

  1. Cuelhu
    OP

    Cuelhu GBATemp's Pepelatz Driver

    Member
    2
    May 19, 2010
    Brazil
    Fantasy Land
    Hey, guys! Long time no see. I have this Dell laptop with Windows 10 on it and just upgraded my Internet connection from 35Mbps to 50Mbps. Before then, I don’t remember the last time I did a speed test.

    The problem is: either via WiFi or Ethernet I get a maximum of 16Mbps.

    I’ve tried resetting adapters, reinstalling drivers, to no avail. There's also no program/application using my connection as Glasswire monitored. My GNU/Linux PC has normal Internet speed, and so my laptop when booted to Ubuntu 18.04.

    Formatting is my last option, does anyone know what could be my problem’s cause?

    Thanks in advance.
     
  2. Cuelhu
    OP

    Cuelhu GBATemp's Pepelatz Driver

    Member
    2
    May 19, 2010
    Brazil
    Fantasy Land
    I've just discovered! The problem was Smartbyte from Rivet (installed by Dell). I've booted to safe mode and the Internet was just fine, then rebooted and turned off service by service to see if the speed came back to normal.
    All is fine now.
     
  3. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Don't you just love bloatware?
     
    Cuelhu likes this.
Loading...