sky3DS+ can support the newest 3DS V10.4.0-29 !

Discussion in '3DS - Flashcards & Custom Firmwares' started by LurkerA, Jan 19, 2016.

  1. LurkerA
    OP

    LurkerA ㊣New3DS

    Member
    291
    68
    Apr 8, 2010
    United States
    sky3DS+ just released a news on their official site www.sky3DS.com
    • * It's confirmed! sky3DS/sky3DS+ can support the newest 3DS V10.4.0-29 (01/19/2016)
     
  2. Neptune

    Neptune GBAtemp Advanced Maniac

    Member
    1,588
    531
    Dec 7, 2003
    United States
    Internet
    Doesn't need a new thread...
     
  3. AceEvo55

    AceEvo55 GBAtemp Regular

    Member
    174
    44
    Nov 3, 2015
    Canada
  4. LurkerA
    OP

    LurkerA ㊣New3DS

    Member
    291
    68
    Apr 8, 2010
    United States
    Sorry please remove this thread.