Hacking RELEASE Sigpatches for Atmosphere (Hekate, fss0, fusee & package3)

Stallzart

Member
Newcomer
Joined
Sep 25, 2021
Messages
13
Trophies
0
Age
39
XP
27
Country
United States
i also did the same thing and now alot of nintendo branded games dont work. they show icon but say their corrupt. uninstalling game did nothing cause now i cant install the corrupt games as they say invalid, sigpatch too low. ive updated all files. is this problem just a early sigpatch files for download and i should wait for updated sigpatches? p.s alot of my games on my sd card still work just not the nintendo branded games and a few others like ori & the wisp that i notice.
i'm hoping thats all it is. i've had cfw for years now and never had this problem. usually just drag and drop the new files and done this update has been a pain
 

CaptainCrunch

Member
Newcomer
Joined
Feb 16, 2019
Messages
12
Trophies
0
Age
38
XP
83
Country
United States
i also did the same thing and now alot of nintendo branded games dont work. they show icon but say their corrupt. uninstalling game did nothing cause now i cant install the corrupt games as they say invalid, sigpatch too low. ive updated all files. is this problem just a early sigpatch files for download and i should wait for updated sigpatches? p.s alot of my games on my sd card still work just not the nintendo branded games and a few others like ori & the wisp that i notice.
I'm having the same problem as you. Something similar happened with the last Atmosphere and sigpatches update. Many installed games (mostly Nintendo brand) were said to be corrupt. That time, deleting the games and reinstalling solved the issue. Same as for you, this time re-installation fails with both Awoo Installer and Goldleaf.

I'm guessing we need updated patches, but if anyone solves this problem another way, please let us know! Thanks!

UPDATE:
I solved this problem, at least for me. It turns out the problem was the game files, not the sigpatches. It turns out, the games I was having problems with were cartridge dumps converted to NSP files. When I tried with official eShop version NSP files, the games installed properly. Hope this helps and works for everyone else having the same problem!
 
Last edited by CaptainCrunch,

ShadowOne333

QVID PRO QVO
OP
Developer
Joined
Jan 17, 2013
Messages
10,745
Trophies
1
XP
12,648
Country
Mexico
I'm having the same problem as you. Something similar happened with the last Atmosphere and sigpatches update. Many installed games (mostly Nintendo brand) were said to be corrupt. That time, deleting the games and reinstalling solved the issue. Same as for you, this time re-installation fails with both Awoo Installer and Goldleaf.

I'm guessing we need updated patches, but if anyone solves this problem another way, please let us know! Thanks!

UPDATE:
I solved this problem, at least for me. It turns out the problem was the game files, not the sigpatches. It turns out, the games I was having problems with were cartridge dumps converted to NSP files. When I tried with official eShop version NSP files, the games installed properly. Hope this helps and works for everyone else having the same problem!
That's a really important finding.
So cart dumps converted to NSP files can cause issues with the sigpatches. I'll probably add that to the Sigpatch fixing guide tomorrow
 

Phoenix12321

Member
Newcomer
Joined
Aug 30, 2021
Messages
8
Trophies
0
Age
28
XP
26
Country
India
Try this. Load up Lockpick and dump your prod.keys from the Switch. Download Switch Army Knife on your PC, put the prod.keys in the bin folder of Switch Army Knife. Convert the base game .nsp file to an .xci file with Switch Army Knife. Install the converted .xci with Awoo and NS-USBloader over USB or copy it to your SD card and install with Awoo. Install your .nsp updates and DLC after that. If you still get "Unable to start software" restart the Switch and load the game again. I had this issue along with another person and this worked for us. I have no idea why converting the base game to an .xci worked for us but it got the game running.
I tried downloading patched XCI and Normal XCI as well. Didn't even install. Gave an error. Will try converting my nsz to xci next
 

Stallzart

Member
Newcomer
Joined
Sep 25, 2021
Messages
13
Trophies
0
Age
39
XP
27
Country
United States
I’m assuming y’all are talking about games from tinfoil? If so that doesn’t help me one bit. All my games are either physical or purchased from the e shop and none of them will work while in cfw but work completely fine while not in cfw
 

idSkeetOnU

Member
Newcomer
Joined
Sep 25, 2021
Messages
17
Trophies
0
Age
36
XP
17
Country
United States

I’m assuming y’all are talking about games from tinfoil? If so that doesn’t help me one bit. All my games are either physical or purchased from the e shop and none of them will work while in cfw but work completely fine while not in cfw
i tried installing tinfoil.nsp and i get same low sigpatch error. i tried also installing using awoo and goldbrick and the app doesnt install. same as trying to install games from pc thru usb.
 

idSkeetOnU

Member
Newcomer
Joined
Sep 25, 2021
Messages
17
Trophies
0
Age
36
XP
17
Country
United States
i get invalid sigpatch on some games like the nintendo branded but not all as i have pokemon shield and sword but one is corrupt and other works fine. i deleted luigis mansion 3 and tried to instsll using goldbrick but get same invalid sigpatch error. i have like 30 games on a 256gb sd and only like 10 are showing corrupt but game icons are showing just corrupt when trying to load.
 

Stallzart

Member
Newcomer
Joined
Sep 25, 2021
Messages
13
Trophies
0
Age
39
XP
27
Country
United States
All my games show the cloud icon above them while in cfw the physical game in the system tells me it needs to update before I can play it and all my games I have downloaded from the eshop say they aren’t on my SD card when I click on them. But everything works completely fine while not on cfw. So I’m assuming it’s a sig patch problem that will hopefully be sorted out soon.
 

ShadowOne333

QVID PRO QVO
OP
Developer
Joined
Jan 17, 2013
Messages
10,745
Trophies
1
XP
12,648
Country
Mexico
Updated the fixing guide with the solution posted by @CaptainCrunch the other day

Also, what's the deal with the people getting the "Sigpatch too low" error message?
I vaguely remember that issue being mentioned before, but I never knew why it tends to happen and/or how people were able to fix that one.
 
  • Like
Reactions: gelderm

idSkeetOnU

Member
Newcomer
Joined
Sep 25, 2021
Messages
17
Trophies
0
Age
36
XP
17
Country
United States
Updated the fixing guide with the solution posted by @CaptainCrunch the other day

Also, what's the deal with the people getting the "Sigpatch too low" error message?
I vaguely remember that issue being mentioned before, but I never knew why it tends to happen and/or how people were able to fix that one.
it actually says "invalid nca (might mean missing sigpatches or a too low firmware)"
 

idSkeetOnU

Member
Newcomer
Joined
Sep 25, 2021
Messages
17
Trophies
0
Age
36
XP
17
Country
United States
i have a first gen unpatched switch that i upgraded to 13.0.0 on sysnand and emunand. i get the invalid nca (might mean missing sigpatches or a too low firmware) error. can i downgrade to 12.1?
 

ShadowOne333

QVID PRO QVO
OP
Developer
Joined
Jan 17, 2013
Messages
10,745
Trophies
1
XP
12,648
Country
Mexico
i have a first gen unpatched switch that i upgraded to 13.0.0 on sysnand and emunand. i get the invalid nca (might mean missing sigpatches or a too low firmware) error. can i downgrade to 12.1?
Did you redump your keys with Lockpick on 13.0.0?
I am not sure if the recent installers handle 13.0.0 at all.
 
  • Like
Reactions: impeeza

gelderm

Member
Newcomer
Joined
Aug 16, 2021
Messages
18
Trophies
0
Age
29
XP
123
Country
Italy
i have a first gen unpatched switch that i upgraded to 13.0.0 on sysnand and emunand. i get the invalid nca (might mean missing sigpatches or a too low firmware) error. can i downgrade to 12.1?
I think so. According to this from 12.0.2 to 13.0.0 you still have 15 burned efuses

EDIT: better restore the v12.1.0 NAND backup, instead to install older firmware
 
Last edited by gelderm,

idSkeetOnU

Member
Newcomer
Joined
Sep 25, 2021
Messages
17
Trophies
0
Age
36
XP
17
Country
United States
Did you redump your keys with Lockpick on 13.0.0?
I am not sure if the recent installers handle 13.0.0 at all.
im sorry i dont know much about updating. i have lockpick on hbc but it says it closed with error. am i suppose to use lockpick after i update? when i bought the switch it had firmware 10.0. i followed a hack switch guide and used it at cfw emunand 10.0 till i updated to 13.0.0
 

gelderm

Member
Newcomer
Joined
Aug 16, 2021
Messages
18
Trophies
0
Age
29
XP
123
Country
Italy
i checked hekate and the fuses burnt show 15 - 0. so does that mean my nand backup from firmware 10.0 is no good?
yup, no good!!

next time follow this steps:
1 - Update Hekate, Atmosphere and then sigpatches
2 - Update FW
3 - Go to Hekate and backup emuMMC RAW GPP + Boot0 & Boot1
4 - In Hekate launch LockPick_RCM (official page) and backup yours keys
5 - Move this backups on a safety place
 
General chit-chat
Help Users
    HarvHouHacker @ HarvHouHacker: Is there no way to use a smartphone as a Steam VR headset?