1. prototech

    OP prototech GBAtemp Fan
    Member

    Joined:
    Jan 3, 2015
    Messages:
    448
    Country:
    United States
    Is there an advantage to upgrading to 10.3 since homemenuhax still works on it? I'm currently on 9.0 on my N3DS.
     
  2. G25900

    G25900 Advanced Member
    Newcomer

    Joined:
    Oct 26, 2015
    Messages:
    75
    Country:
    If you're on 9.0 then you have an exploitable firmware so no point in upgrading as you'll basically be losing things you can do for now.
     
    The9thBit likes this.
  3. Zidapi

    Zidapi GBAtemp Psycho!
    Member

    Joined:
    Dec 1, 2002
    Messages:
    3,092
    Country:
    Everything to lose, nothing to gain.

    lol sure, why not.
     
  4. Ra1d

    Ra1d GBAtemp Maniac
    Member

    Joined:
    Jul 31, 2010
    Messages:
    1,361
    Country:
    Canada
    For now you'll be taking an unnecessary risk, wait for GW/RX to release an update and then decide.
     
  5. Quantumcat

    Quantumcat Dead and alive
    Member

    Joined:
    Nov 23, 2014
    Messages:
    15,149
    Country:
    Australia
    When GW were developing the <=9.2 solution, they told people to update if they were above 4.5. Since they haven't told anyone to update, I am guessing there's no extra benefit.
     
  6. prototech

    OP prototech GBAtemp Fan
    Member

    Joined:
    Jan 3, 2015
    Messages:
    448
    Country:
    United States
    I read somewhere that N3DS may be able to run a more current emunand if the native firmware is 9.5+ since we will have the keys at boot, but I wasn't sure how accurate or reliable that really was.
     
  7. Hiatus

    Hiatus Member
    Newcomer

    Joined:
    Oct 12, 2015
    Messages:
    23
    Country:
    United States
    Just stay at 9.0 for now. Since you're already on an exploitable firmware you can always update to 10.3 later with sysupdater whenever you'd like.
     
    The9thBit and Xenon Hacks like this.
  8. xdarkmario

    xdarkmario Philosopher
    Member

    Joined:
    Dec 30, 2010
    Messages:
    1,578
    Country:
    United States
    if you have 9.2 and below DO NOT EVER UPDATE!!
     
    Tony_93 likes this.
  9. Hiatus

    Hiatus Member
    Newcomer

    Joined:
    Oct 12, 2015
    Messages:
    23
    Country:
    United States
    I wouldn't say don't EVER update. For instance, people are trying to update from 4.5 to 9.0 to have homemenuhax (who doesn't want autoboot?). Perhaps there's something to be desired on 10.3 that isn't on 9.0 as time goes on. Only time will tell :)
     
    The9thBit likes this.
  10. N64

    N64 GBAtemp Fan
    Member

    Joined:
    Apr 16, 2014
    Messages:
    425
    Country:
    United States
    i would say stay at 9.0 right now... wait for the exploits to be implemented (and tried by folks that have a higher firmware like 10.3)... and then make your decision
     
  11. Tony_93

    Tony_93 GBAtemp Addict
    Member

    Joined:
    Jun 13, 2015
    Messages:
    2,453
    Country:
    United States
    If you go to ther website they have confirmed that they are working in 10.3 support.

    — Posts automatically merged - Please don't double post! —

    But 9.0 is already hackeable... You will be just losing time.
     
  12. xdarkmario

    xdarkmario Philosopher
    Member

    Joined:
    Dec 30, 2010
    Messages:
    1,578
    Country:
    United States
    well yea but he said N3ds and theres no 3ds ver 4.0 on N3ds
     
  13. Hiatus

    Hiatus Member
    Newcomer

    Joined:
    Oct 12, 2015
    Messages:
    23
    Country:
    United States
    It was just an example. Something like that could happen for 9.0 & 10.3 for the n3ds. Obviously OP should stay on 9.0 until 10.3 is exploited, but don't rule out the option of updating!
     
  14. Quantumcat

    Quantumcat Dead and alive
    Member

    Joined:
    Nov 23, 2014
    Messages:
    15,149
    Country:
    Australia
    Yes but what I mean is that there won't be any extra benefit to being on 10.3 as opposed to 9.2 when the exploit comes out, otherwise they would be telling people to update. I didn't say they weren't working on it.
     
    Tony_93 likes this.
  15. Lilith Valentine

    Lilith Valentine GBATemp's Official Imp: Am imp
    Member

    Joined:
    Sep 13, 2009
    Messages:
    24,144
    Country:
    Antarctica
    You are already on an exploitable firmware! Don't update your system!
     
  16. xdarkmario

    xdarkmario Philosopher
    Member

    Joined:
    Dec 30, 2010
    Messages:
    1,578
    Country:
    United States
    im pretty sure there 0% benefits other then nintendo features to update pass 9.5
     
    Quantumcat likes this.
  17. soulskeeper

    soulskeeper GBAtemp Regular
    Member

    Joined:
    Aug 16, 2007
    Messages:
    201
    Country:
    Iceland
    so if my N3ds xl is on 9.5 should I or shouldn't I update?
     
  18. Quantumcat

    Quantumcat Dead and alive
    Member

    Joined:
    Nov 23, 2014
    Messages:
    15,149
    Country:
    Australia
    Don't update, because SNShax will come out first which only supports n3ds up to 10.1.
     
    soulskeeper likes this.
  19. leonmagnus99

    leonmagnus99 GBAtemp Psycho!
    Member

    Joined:
    Apr 2, 2013
    Messages:
    3,678
    Country:
    Iraq
    dude , dont update man just dont.
     
  20. Ra1d

    Ra1d GBAtemp Maniac
    Member

    Joined:
    Jul 31, 2010
    Messages:
    1,361
    Country:
    Canada
    If you're on 9.0 you can update to any version you want after release anyway (Through 3DNUS), so wait for the official release, and then update if necessary.
     
    Last edited by Ra1d, Jan 1, 2016
    Quantumcat likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - upgrade, Should,