1. TheZoc

    OP TheZoc GBAtemp Fan
    Member

    Joined:
    Apr 6, 2009
    Messages:
    310
    Country:
    Brazil
    Hello,

    Since I'm out of the loop for a long while, the question is that simple: Should I upgrade from 5.00 m33-6 firmware to 6.20 PRO-B5 ?
    I heard some games doesn't work on old firmwares. Also, some people told me that I should not upgrade, but they couldn't give me a good reason for it.

    Since you guys are the best at this stuff, what's your advice ? Is there any good updates or fixes for 6.20 firmware ? (Or maybe, even 6.35 I guess ?)

    My PSP is the ancient one (PSP1001 on the bottom label).

    Thanks in advance! [​IMG]
     
  2. demonicstrife

    demonicstrife *INSERTGENERICTITLE*
    Member

    Joined:
    May 22, 2008
    Messages:
    769
    Country:
    United States
    Upgrading to 6.20 will fix certain PS1 titles (while breaking a few others) and allow you to play all the latest games without issues. But, it has less homebrew and plugin support if you're into that. On your current firmware, I believe you can just update to 5.00 Prom-4 instead to play all the latest games, and use a plugin called POPSLoader for maximum compatibility with PS1 (no popsloader for 6.xx yet). Or you can patch all your games with ISO_tool. It also has the best compatibility with all homebrew.
     
  3. TheZoc

    OP TheZoc GBAtemp Fan
    Member

    Joined:
    Apr 6, 2009
    Messages:
    310
    Country:
    Brazil
    Is the 5.00 Prom-4 you meantioned actually 5.50 Prom-4 ? ( I found out this one: http://filetrip.net/f12022-5-50-Prometheus-4.html )

    Also, is there any "changelog" between firmware revisions (from Sony) and/or a feature list for CFW, showing what each firmware is capable of doing ?

    Also, I couldn't find popsloader on filetrip, and not a single post on gbatemp having it as the main subject. Is there any link you could give me with popsloader (or any plugin) installation tutorial? I wasn't aware you could install plugins on PSP, these are awesome news! (well, at least for someone out of the loop for a long time anyway).

    Thanks again!
     
  4. MrCooper

    MrCooper GBAtemp Regular
    Member

    Joined:
    Apr 2, 2010
    Messages:
    165
    Country:
    United States
    You could just keep m33-6 and run plug-ins for better compatibility
     
  5. Joe88

    Joe88 [λ]
    Global Moderator

    Joined:
    Jan 6, 2008
    Messages:
    12,627
    Country:
    United States
  6. DSdonkey77

    DSdonkey77 GBAtemp Regular
    Member

    Joined:
    Feb 20, 2011
    Messages:
    162
    Country:
    Canada
    upgrade to 5.50 m33
     
  7. marcus134

    marcus134 GBAtemp Advanced Fan
    Member

    Joined:
    May 7, 2011
    Messages:
    584
    Country:
    Canada
    In those times google is your best friend.

    here's a link
    http://pspslimhacks.com/popsloader-easy-in...or-500-m33-v11/
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - upgrade, Should,