Should I update US N3ds if i bought sky3ds?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Itsthenew, Jul 19, 2015.

  1. Itsthenew
    OP

    Itsthenew Newbie

    Newcomer
    7
    0
    Jul 19, 2015
    United States
    I just bought a Sky3ds v2 after purchasing a New 3DS (US version if that matters). The installed firmware is 9.5.0-22u. It seems as though the sky 3ds is compatible with the newest firmware but I was wondering if there was any downside to upgrading.
     
  2. Rioluwott

    Rioluwott GBAtemp Advanced Fan

    Member
    650
    92
    Feb 23, 2014
    Mexico
    9.5.0-22u doesn´t have any exploit that 9.9 not so upgrade if you want
     
    Adeka likes this.
  3. Adeka

    Adeka Beta Tester

    Member
    4,144
    1,287
    Mar 19, 2013
    United States
    either 9.2 or update all the way. there's no reason to be on 9.5
     
  4. juan_3579

    juan_3579 GBAtemp Regular

    Member
    101
    18
    Jun 25, 2015
    United States

    There's not much to offer yet for 9.5 on the New 3DS. You don't have to update though, you can play online if the game has the latest update data available, however there's no way to update game data on a 9.5 3DS without upgrading to the latest firmware.

    Another problem is headers when playing online. The Sky3DS uses public headers so the risk of getting banned is pretty high unless you have your own headers patched into Diskwriters template file. If you don't plan on playing any games online, then just keep your 3DS at 9.5.
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,297
    5,321
    Mar 17, 2010
    Norway
    Alola
    None that we know of anyway. But even if there were kernel exploits on 9.5 it's not like we'd know about it, the devs keep that stuff to themselves.
    Probably not much point in staying on 9.5 though.
     
  6. Rioluwott

    Rioluwott GBAtemp Advanced Fan

    Member
    650
    92
    Feb 23, 2014
    Mexico
    on 9.3 to 9.5.0-20 there was spider exploit

    EDIT Sorry i thought that o3ds you can update
     
  7. Itsthenew
    OP

    Itsthenew Newbie

    Newcomer
    7
    0
    Jul 19, 2015
    United States
    Thanks for the quick replies, you guys are super helpful!
     
  8. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,039
    1,063
    Jun 28, 2014
    United States
    Arizona Bay
    Update to 9.9 before it's too late; with ninjahax 2.0 it makes region free on sky3ds soo easy
     
    Melon__Bread likes this.
  9. tivu100

    tivu100 GBAtemp Addict

    Member
    2,023
    438
    Jun 6, 2015
    United States
    Rumor is 9.5 keys were leaked. There would be a chance of better homebrew support for 9.5 in not far future. Nothing's confirmed yet. So don't have your hope high. If you are interested though, stay at 9.5.
     
  10. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,039
    1,063
    Jun 28, 2014
    United States
    Arizona Bay
    Not so much a rumor as a fact; you do bring up a very good point though
     
  11. Tempest228

    Tempest228 GBAtemp Regular

    Member
    167
    105
    Jul 13, 2015
    United States
    What do these keys enable? I'm on 9.8, so it really doesn't matter to me.
     
  12. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,039
    1,063
    Jun 28, 2014
    United States
    Arizona Bay
    It may lead to piracy on 9.5 with cubic ninja as a way to access arm11