Should I update from 3.2U to current?

Discussion in 'Wii - Hacking' started by nitrodude150, Jul 25, 2008.

Jul 25, 2008
  1. nitrodude150
    OP

    Member nitrodude150 GBAtemp Regular

    Joined:
    Feb 2, 2008
    Messages:
    210
    Country:
    United States
    I have:
    Wiikey 1.9s
    3.2UWii
    Homebrew Channel Installed Beta 8
    and most importantly, I play SMG and SSBB via trucha hack, but do i need to worry cuz i have 1.9s, I'm just wondering what I should do?
     
  2. ZombiePosessor

    Member ZombiePosessor GBAtemp Fan

    Joined:
    May 1, 2008
    Messages:
    445
    Location:
    West Virginia
    Country:
    United States
    Stay with what you have until you're FORCED to update. I've got the same setup, Wiikey 1.9s, Wii FW 3.2U, and I couldn't be happier. I don't rely on trucha signed games, don't play GH3 or whatever else. If you go the 3.3U route, the Twilight Hack has been updated so you can use it on 3.3U firmware, and you can load Trucha games through Gecko Region Free in the homebrew channel. I'd just stay with what you have tho, since I didn't really see any need for the 3.3U update.
     
  3. SenorClean

    Member SenorClean GBAtemp Advanced Fan

    Joined:
    Mar 21, 2008
    Messages:
    522
    Country:
    Australia
    Being logical...

    Pros to upgrading:
    Less likely to "cross region" brick your wii in the future - ie if you install 3.3 from another region off a game disc.

    Updated mii parade (lol)

    Cons to upgrading:
    No more trucha - you can use Gecko OS to get around this.

    No more twilight hack (fixed).

    Fewer possibilities to recover from "banner bricking"! - if you are on 3.2, you can make an auto-boot disc of wad manager, trucha sign it and remove the problem wad from there. In 3.3, you can make an autoboot copy of zelda (this doesn't need re-signing) and through twilight hack, launch wad manager and recover this way - but it requires you to have twilight hack savegame on your wii before you bricked it!


    I'm staying with 3.2E for now... The trouble is, my flatmates play zelda regularly... so I can't really leave the twilight hack savegame on it. I guess when I upgrade, I'll get a copy of zelda from a different region and leave twilight hack for it on my wii as a safeguard.
     
  4. linkinworm

    Member linkinworm GBAtemp Maniac

    Joined:
    May 30, 2008
    Messages:
    1,324
    Location:
    Birmingham (England)
    Country:
    United Kingdom
    if you do update you can still use geckoOS to run trucha games
     

Share This Page