Should I buy the EZ Flash Vi now that it can work with 1.4?

Discussion in 'NDS - Flashcarts and Accessories' started by Link5084, Aug 10, 2009.

  1. Link5084
    OP

    Member Link5084 Sword & Shield at your service

    Joined:
    Aug 6, 2008
    Messages:
    1,367
    Country:
    United States
    Just saw the news on the main page. Is it currently the best DSi flashcart out right now? Need to buy a DSi flashcart now to tide over the release of the CycloDSi
     
  2. Da-Bomb1

    Member Da-Bomb1 GBAtemp Advanced Fan

    Joined:
    Apr 19, 2009
    Messages:
    795
    Location:
    BC, Canada
    Country:
    Canada
    The Acekard team will probably come out with something soon...there's no point in jumping the gun and just choosing the first card to come out with a fix. I'd say the AK2 with AKAIO's probably a much nicer card too. The M3 team will probably come out with one soon too.
     
  3. DeltaBurnt

    Member DeltaBurnt I'm bored

    Joined:
    Feb 21, 2009
    Messages:
    3,353
    Location:
    Where intellect matters
    Country:
    United States
    How come all of a sudden when somethings first it's automatically the best? The acekard2i was the first DSi flashcart and it was the "best" and now the EZVi is the best cause it's the first to bypass 1.4? I also suppose that the first computer company or website out there is also the best too?

    Seriously I don't get you people, for the past few months EZVi has been crap (pretty much) no one even mentions it now outside of the actual forum and now all of the sudden it's the best cause it's the first? You better bet the other teams aren't far behind.
     
  4. UniqueGeek

    Member UniqueGeek PMD Researcher

    Joined:
    May 29, 2009
    Messages:
    1,326
    Country:
    United States
    1. The R4i was the first.
    2. If you looked, there isn't a release date yet.
     
  5. GenesisX

    Member GenesisX GBAtemp Fan

    Joined:
    Apr 12, 2009
    Messages:
    395
    Location:
    a vagina :)
    Country:
    United States
    i don't see why you can't just use a dsl.... most of the latest flashcarts support the dsl, and the only difference between the dsl and dsi is a camera, No slot-2, and the internet browser
     
  6. 4coolday

    Newcomer 4coolday Member

    Joined:
    Jul 21, 2009
    Messages:
    48
    Country:
    China
    you'd better not upgrade your DSi and wait for a few days.
     
  7. gamekool

    Member gamekool GBAtemp Regular

    Joined:
    Dec 31, 2008
    Messages:
    132
    Country:
    United States
    consider about GUI and loading speed...you surely have better choice..
    but if you just need a card to support DSi V1.4,yeah..that's it...
    this one is much more decent the R4i gold things.
     
  8. fliegen

    Newcomer fliegen Member

    Joined:
    Nov 11, 2004
    Messages:
    26
    Country:
  9. DeltaBurnt

    Member DeltaBurnt I'm bored

    Joined:
    Feb 21, 2009
    Messages:
    3,353
    Location:
    Where intellect matters
    Country:
    United States
    No they never established whether or not the actual team of the R4i made the block or some random person made a quick hardware fix in which fact it wouldn't actually be the first one.

    Still even if it isn't the first my point is still valid it's close enough to first >.>
     
  10. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    We still don't have any 1.4-compatible devices at all. None. We've got a video here and there of a team saying "we've done it" but until they actually make a release, there's no sense allowing 1.4 compatibility to affect your purchase decision.

    If I was in the market for a new device right this instant, I would first limit my choices to only the ones with upgradeable firmwares, and then wait a few weeks until some of them (at the very least, more than one company/device) got updates.
     
  11. cngamemart

    Banned cngamemart Banned

    Joined:
    Jul 30, 2009
    Messages:
    129
    Country:
    China
    that's a acceptable idea [​IMG]
     
  12. ashley.ince

    Newcomer ashley.ince Advanced Member

    Joined:
    Aug 5, 2009
    Messages:
    51
    Country:
    United Kingdom
    an update will be out for m3i zero and supercard soon, you can rely on it. The r4i team seem to sergest u need a new card one that was made today or onwards for the update to work - so its a hardware fix, and the ez flash uses a .nds file of some sort using a ds or non updated dsi for power / running. (as seen in video)
     
  13. r4buyer2008

    Newcomer r4buyer2008 Member

    Joined:
    Aug 11, 2009
    Messages:
    10
    Country:
    United Kingdom
    i asked my suppliers, was told that the EZ flash Vi, which can work with 1.4, still have not been released yet.
     
  14. gamekool

    Member gamekool GBAtemp Regular

    Joined:
    Dec 31, 2008
    Messages:
    132
    Country:
    United States
    they said to be updatable with a DSL console of the old cards.
     
  15. TheWorldEndsWith

    Newcomer TheWorldEndsWith Advanced Member

    Joined:
    Aug 11, 2009
    Messages:
    84
    Country:
    United States
    i will rather buy m3 i zero and wait for the update
     

Share This Page