Should I Always Update rxtools' CFW to highest firmware?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Calico, Dec 3, 2015.

  1. Calico
    OP

    Calico Member

    Newcomer
    27
    1
    Jan 12, 2015
    Canada
    North Pole, New York
    Should I update it to 10.3 as of now, or use an updater to update emunand to 9.0-9.2? Should I block Nintendo's updates on my emunand, (doesn't anyone have advice on how I should do so?)
     
  2. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    Dalvík, Iceland
    Block Nintendo, and don't update to 10.3. Doing so will actually update your SysNand and you're screwed. RxTools doesn't support anything past 9.5.
     
  3. Calico
    OP

    Calico Member

    Newcomer
    27
    1
    Jan 12, 2015
    Canada
    North Pole, New York
    rxtools doesn't support emunand 10.3? I swear I saw people using 10.3 emunand on rxtools.
     
  4. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    Dalvík, Iceland
    EDIT: Here lies an old post.
    I'm an idiot. XD
    RxTools EmuNand on the older systems support all the updates.
    9.5 for N3DS
     
    Last edited by Ruby Gloom, Dec 3, 2015
  5. shadowofdarkness

    shadowofdarkness GBAtemp Fan

    Member
    489
    161
    Apr 17, 2007
    Canada
    rxTools supports 10.3 on o3ds but only up to 9.5 on n3ds
     
    vinz262002 likes this.
  6. Karuta

    Karuta

    Member
    113
    38
    Nov 4, 2015
    The latest rxTools nightlies (lavanoid.github.io) support emuNAND 10.3 on Old 3DS and 9.5 on New 3DS. You can update if you'd like, but make sure you only do it you're using emuNAND. If you update your sysNAND past 9.2, you will lose the ability to access rxTools.

    If you're using an Old 3DS (or XL, or 2DS) then you can just update from system settings (on emuNAND of course).
    If you're using a New 3DS (or XL) then use sysUpdater and the 9.5 update pack from your region (available on a certain ISO site).
     
  7. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    Dalvík, Iceland
    It must not include the 2DS because I wasn't able to get on the latest FW
    ^ Ignore this. It's false. XD
     
    Last edited by Ruby Gloom, Dec 3, 2015
  8. Karuta

    Karuta

    Member
    113
    38
    Nov 4, 2015
    The latest rxTools nightlies support 10.3 emuNAND on everything except the New3DS/New3DSXL. Same for Gateway and other CFWs. It's not due to limitations of the CFW, it's just because 9.6+ encryption hasn't been broken yet on the New 3DS.
     
  9. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    Dalvík, Iceland
    Gotcha. Thanks. :)
     
  10. Tony_93

    Tony_93 GBAtemp Addict

    Member
    2,178
    992
    Jun 13, 2015
    United States
    California
    I have an o3DS with the official 2.6 rxTools release and emunand 10.3 works just fine.
     
  11. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,056
    3,371
    Nov 13, 2014
    United States
    This is not true
     
  12. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    Dalvík, Iceland
    Already reviewed and discussed. I'll edit it.
     
  13. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,056
    3,371
    Nov 13, 2014
    United States
    While in Emunand you can update through the system settings app.
     
  14. Karuta

    Karuta

    Member
    113
    38
    Nov 4, 2015
    If he has an Old 3DS. New 3DS will require sysUpdater and the 9.5 update files.
     
  15. Calico
    OP

    Calico Member

    Newcomer
    27
    1
    Jan 12, 2015
    Canada
    North Pole, New York
    I have an Old 3DS, 4.4 sysnand as of now. I'm thinking of getting rxtools CFW and then updating my sysnand to 9.2 to autoboot. It's just that I don't know if I should always be updating emunand to 10.3 right now or update it to a lower version; any benefits of updating emunand to 9.2 vs 10.3?
     
  16. Karuta

    Karuta

    Member
    113
    38
    Nov 4, 2015
    You can update your sysNAND to 9.2 easily enough through sysUpdater, just make sure you use a CFW without firmlaunch (PastaCFW / rxTools dev mode) while you're doing it. Gateway launcher or standard rxTools will cause a brick.

    Main advantages of 10.3 emuNAND are not having to spoof the eShop or firmware spoof games that require higher firmware. Apart from that not much, but its easy to do so I'd recommend it.
     
    Last edited by Karuta, Dec 3, 2015