Shin Megami Tensei: Persona PSP (u)

Discussion in 'PSP - Games & Content' started by Azngamer15, Sep 23, 2009.

Sep 23, 2009
  1. Azngamer15
    OP

    Azngamer15 Newbie

    So guys, it's the dawn of another major 5.55 game release. Anyone try it out yet? Course the Japanese one was released last year, and definitely playable, but then again so was Disgaea 2, and well, haha here we are still not able to play THAT either. I'm currently getting it as we speak, I'm wondering if anyone beat me to the punch? (haha does it work? have you tried to modify the iso in any way? what happens? etc.)

    ITT we report our findings
     
  2. Rock Raiyu

    Member Rock Raiyu Clock Up

    Joined:
    Jul 14, 2007
    Messages:
    5,066
    Location:
    Walking the path of heaven
    Country:
    United States
    Needs 5.55 and you can't switch out the eboots so we're going to have to wait for a new CFW, whenever that is.
     
  3. Ryupower

    Member Ryupower Brood

    Joined:
    Oct 8, 2007
    Messages:
    2,763
    Country:
    United States
    any game that comes out now will most likely need 5.55+
     
  4. Azngamer15
    OP

    Azngamer15 Newbie

    sucks, considering I have a 3000, so I can't even play it if/when a new CFW comes out =(, currently on 5.03 GEN anyway. we shalt see...
     
  5. neorebirth

    Newcomer neorebirth Newbie

    Joined:
    Oct 25, 2008
    Messages:
    2
    Country:
    Canada
    same goes for me, just tried it and couldn't run, less disapointing then disagaea 2 since I was kind of expecting =( hope that the CFW will out soon
     
  6. Donald Serrot

    Member Donald Serrot GBAtemp Fan

    Joined:
    May 11, 2009
    Messages:
    366
    Country:
    United States
    I just got the actual game UMD. I was hoping when I logged in I'd see something for getting it to work, but looks like I gotta wait huh? Darn. Oh well, at least I have the 2 disc soundtrack I can listen to while I wait. Curse you Sony and your tricky... trickiness! [​IMG]

    {EDIT}
    And then I saw how old this topic was... Hey! At least I used search! This was just close to the top. lol
     
  7. BKZ

    Member BKZ GBAtemp Regular

    Joined:
    Mar 29, 2008
    Messages:
    127
    Location:
    Vancouver
    Country:
    Canada
    Upgrade to 5.50 GEN D-2. That firmware plays all 5.55+ without patching. Also this topic is almost 2 months old so its kinda old and outdated
     
  8. Donald Serrot

    Member Donald Serrot GBAtemp Fan

    Joined:
    May 11, 2009
    Messages:
    366
    Country:
    United States
    Yeah, I realized that after I posted. Working on getting what I need to switch to GEN already now that I found where I needed to go. (Thought this was like the topic specifically for Persona like the NDS games get, guess not) Thanks though. [​IMG]
     
  9. scizo

    Newcomer scizo Advanced Member

    Joined:
    Nov 10, 2008
    Messages:
    58
    Country:
    Belgium
    i played it and didnt like it somehow.
     
  10. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
    everyone has their own opinions.
     

Share This Page