[Sharing Story] I was stuck with arm11.bin to get OTP for 2 days and found the unlikely problem

Discussion in '3DS - Homebrew Development and Emulators' started by cutterline, May 27, 2016.

  1. cutterline

    cutterline Newbie

    May 27, 2016
    ====Prelude (just read it if you're bored)====

    I have a 2ds EU region which I had downgraded to 9.2.0 many moons ago just to test if I could do it. After that I moved to SEA region and haven't really touched my 2ds since then. Later on, I hooked on phoenix wright series after procured carts of the series. I just finished 1-4 and wanting to play the 5th (It was on sale just until yesterday). I was between 2 options just upgrade to 11 or do some way around without going to 11.
    Later, I found out some scene of the homebrew and found if I upgrade to 11, I might need hardmod to do any crazy things later on. Well, I can do that but don't really have the time to do that. So I opted to try the a9lh.

    =====End of prelude====

    I spent 3 days doing this using the awesome Plailect's guide. First day, probably spent around 2 hours or so whilst doing something else,I setup all the stuffs just before downgrading it to 2.1.0.

    The next day, the madness began, I followed the guide and up to going to dukesrg.github.io/2xrsa.html?arm11.bin (I remembered this by heart now after 100+ tries). It would just stuck halfway and froze or once in a blue moon finished loading and froze. After like 20 tries or so, I gave it a rest and searched the web for solutions, like clear browser save data, inserting the sdcard just before confirm, partial downgrade cause (web browser version was already 174(55), CMIIW, I forgot exact last 2 numbers), etc. I even tried using the reboot.ms by renaming otp.dat (forgot the file name) to Launcher.dat. I tried some more, maybe around 20 tries of clear save data, stopped before I went mad. Just imagine looking at that stretched screen of 2ds.

    Next day, I upgraded to 9.2 using the 4.x hax to restore sysNAND, and re-initiated all the step from creating rednand (PART 3) and an hour later just to be stuck again in the bloody arm11.bin screen. I checked everything and nothing is wrong. I tried countless time from tried 10 versions of OTPhelper, changing SDcard, clear save data,etc and stopped before insanity encroached me. I was on the verge on giving up and decided to just settle with CFW. Before going back, I searched all thread with arm11.bin related, watched youtube on all those a9lh installation guide. Then by whim, I clicked this particular thread, something just clicked my mind upon reading the question.

    I have never been successful with browserhax after I moved here and I just gave up after 10-20 tries. Could it be the connection? Because I watched the video, the process was very brief, unlike mine that waited to load for seconds and froze. Upon this revelation, I whipped out my phone, tethered it, and voila! Successful in just one try.

    I wasted those hours because of bad connection. I don't really know what the exact problem was. It could be just rubbish wireless router, crowded traffic (I checked from my computer latency was fine though), 2ds wifi sucks in crowded traffic, or actually the ISP itself.

    TLDR; If anything else is correct but you're still stuck on arm11.bin, bad connection may affects the arm11.bin hax.
  2. proflayton123

    proflayton123 Sakura思い

    Jan 11, 2016
    Bad connection problems can be a vital cause of what causes this~
  3. avocado

    avocado GBAtemp Regular

    Apr 17, 2016
    I had the same problem as you did.
    I tried 3 times using home router, I always got error.

    Thank you for posting this.
    I tried with my cellphone and succeeded at the first trial.
  4. mahesoo

    mahesoo Newbie

    May 3, 2014
    United States
    yeah me too, when i was to load arm11.bin it just freezing,
    already tried clear data clear cache, history etc but it still wont work so it makes me worried so much then i found your thread and i tried to tethering to my phone internet and surprisingly it works, thank you. Still i don't understand my home connection was stable enough than my phone but why the phone works and the router didnt? hmm..
  5. einhuman197

    einhuman197 GBAtemp Advanced Fan

    Aug 17, 2015
    Inside your bootloader (´◉◞౪◟◉)
    Well, you can try the old flickering otp dumping payload, restore your 9.2 nand and install arm9loaderhax with the safea9lhinstaller 3dsx build. Here's the payload:

    Attached Files:

  6. godofwrath

    godofwrath GBAtemp Fan

    Sep 30, 2007
    Maybe somebody should bug plailect to add that to the troubleshooting section of the guide, seems like it could be a so/so common issue.
    Quantumcat likes this.
  7. porrascesar

    porrascesar Newbie

    Sep 7, 2009
    If someone else has this same problem, i'll share my case, same scenario, same screen, but my problem was that my arm11.bin file was 0kb big, i had accidentally decompresed the file using winrar instead of 7zip, unzipping it correctly fixed the problem
  8. Xyphoseos

    Xyphoseos Hack or no games

    Jun 29, 2016