Setting up SMB in Ubuntu with Samba for MPlayerCE

Discussion in 'Wii - Emulation and Homebrew' started by heat6jones, Sep 1, 2010.

  1. heat6jones
    OP

    Member heat6jones GBAtemp Regular

    Joined:
    Jun 7, 2007
    Messages:
    156
    Country:
    United States
    I recently installed Ubuntu 10.04 (loving it) and cannot seem to get an SMB server setup for MPlayerCE. First I installed Samba, went to System - Administration - Samba and I shared my Music folder to test with. Next I got my SD card from the wii and opened the apps/MplayerCE/ and opened the .conf file. Here I added my Ip address and the name of the folder. I set it so everyone had access to the folder so I did not type in a user name or password. I saved the conf but when I try to load smb share 1 I get an error.

    Is there an additional step I'm skipping?
     
  2. Richardarkless

    Member Richardarkless GBAtemp Regular

    Joined:
    Dec 11, 2009
    Messages:
    166
    Country:
    United Kingdom
    Can you view the smb on something else like another pc and have you tried out wiimc which is the successor to mplayerce to see if it works there

    Oh and congrats on making the switch, ive been using ubuntu 10.04 since april and linux in general for 6 years
     
  3. JonthanD

    Member JonthanD GBAtemp Regular

    Joined:
    Jul 9, 2010
    Messages:
    279
    Location:
    Sitting
    Country:
    United States
    I used to use my PS3 to watch movies and music from my PC when I had Vista, upgraded to 7 and it died, Tried different Linux distro's and still nothing. Set my router to pretty much pass anything through it and still no dice...

    I thought that WiiMC might work out for me but no FTP or SMB setting on any OS would work for me [​IMG]

    Would be nice to leverage the massive amounts of storage my PC has.... lol

    Anyway sorry to hijack your thread, but make sure you check your MTU settings on your router if your using them maybe set your Wii's IP as a DMZ and check every setting you can get your hands on twice.....
     
  4. heat6jones
    OP

    Member heat6jones GBAtemp Regular

    Joined:
    Jun 7, 2007
    Messages:
    156
    Country:
    United States
    Don't have another PC with me to check atm. Might do it later if a friend comes over. I just downloaded WiiMC and will attempt to try it with that app. I was thinking the long file name that Ubuntu gave the drive was causing a problem, so I renamed the partition in the terminal but I still get nothing.

    EDIT: Tried with WiiMC and still nothing. The weird thing is I can't access the shared folder even on the machine I'm sharing it on if I navigate there through the Network folder. I get the error 'Failed to Mount Windows Share'
     
  5. Richardarkless

    Member Richardarkless GBAtemp Regular

    Joined:
    Dec 11, 2009
    Messages:
    166
    Country:
    United Kingdom
    Ok, if it doesnt work in wiimc or the pc I suggest you double check your share name as ive heard that it has to be EXACTLY the same including the case so just in case go back in system, admin then samba and rename the share name to something simple with no cases e.g. music

    Just in case afterwards restart the samba service so it loads the new settings

    type "sudo service samba restart" in the terminal

    also check the ip address by right clicking on the wireless, connection information then write the same in smb.conf, its recommended that you set a static ip so it doesnt change whenever another machine uses that ip address
     
  6. heat6jones
    OP

    Member heat6jones GBAtemp Regular

    Joined:
    Jun 7, 2007
    Messages:
    156
    Country:
    United States
    Tried and it still didn't work. The folder I'm sharing is on an external HDD. Also I CAN acess my printer via the wiimc (atleast the files in the print folder) i think it has something to do with the external HDD setup.
     
  7. heat6jones
    OP

    Member heat6jones GBAtemp Regular

    Joined:
    Jun 7, 2007
    Messages:
    156
    Country:
    United States
    I think I need to change permissions on my external hard drive to allow file access but when i try it doesn't accept my changes

    Edit: The HDD is NTFS is that a problem?
     
  8. heat6jones
    OP

    Member heat6jones GBAtemp Regular

    Joined:
    Jun 7, 2007
    Messages:
    156
    Country:
    United States
    Solved!

    Went to terminal and ran:

    sudo apt-get install pysdm

    Which is a Storage Device Manager. Once installed I added the users ,Sambashare.
     
  9. Richardarkless

    Member Richardarkless GBAtemp Regular

    Joined:
    Dec 11, 2009
    Messages:
    166
    Country:
    United Kingdom
    ok cool, but its really strange as I didnt have to do any of this, just went into samba, added my share, chose the folder I wanted to share, made is visible and available to everyone and bam it worked out the box

    Perhaps pysdm installed a dependency which samba needed, I probably had that dependency thats why it worked for me

    oh well as long as it works, thats the main thing

    As for ntfs, if your single booting (just got ubuntu installed) I recommend you switch from ntfs as that file system needs defragmenting regularly which can only be done in windows which is a problem if you only got ubuntu installed

    You wont need to do this straight away, just a heads up

    When your ready to switch file systems choose either fat32 (if you havent got files over 4gb) or ext3 or 4 (ext3 is the best as you can download a driver for windows making the ext3 drive readable and writable even though its a linux file system)

    If you want to increase performance of streaming over to wiimc/mplayerce then ext4 is the best as it has got higher read/write speeds = faster loading of video
     

Share This Page