Set up Gateway/HBC on Japanese New 3DS Ver. 8.1.0-0J

Discussion in '3DS - Flashcards & Custom Firmwares' started by wataznach, May 2, 2016.

  1. wataznach
    OP

    wataznach Newbie

    Newcomer
    6
    0
    May 2, 2016
    United States
    Hey, everyone!

    So I just got a Japanese New 3DS from a friend who previously got gateway running on it before. However, he didn't send me any of his SD cards and the setup didn't work when I tried to only use the Nintendo DS Profile exploit with SD card files and red gateway card. Now, the Nintendo DS profile thing shows up instead of freezing/starting gateway or whatever it's supposed to do, so I think I need to restart the exploit process.

    What is the cheapest/fastest way to set up Gateway and/or HBC so that I can get games roms running? So far all I've really found is that I may need a game with exploitable game files (OoT3D/CN) or Sky3DS. Is there any easier or cheaper way to exploit yet? Also, would I need a different Japanese Sky3DS or something?
     
    Last edited by wataznach, May 2, 2016
  2. XxShalevElimelechxX

    XxShalevElimelechxX GBAtemp Regular

    Member
    182
    118
    Mar 30, 2016
    Israel
    Hi, u cant set up the HBL on 8.1 without cubic ninja, i would recommend u to update to 9.2 with a tutorial to access HBL and set up menuhax (launch gateway through HBL as the 3DS is on and launching your theme) but if u want to take a risk u can do arm9loaderhax (a9lh) that gives u a super early kernel access so u will be able to launch gateway immediately as the 3DS starts even before the NAND (os) starts so u will be able to unbrick your device without a hardmod but if u r new to this scene so dont do it cause its a little bit risky.
    i think u should upgrade to 9.2 and set up a CFW cause u wont need gateway anymore and u wont get bans (if u use a flashcart there is a chance u will get banned).
    set up menuhax and a cfw and if u want to try a9lh we will help u (i have it and its super awesome)
    hope that i helped ya and have a nice day and week:)
     
    cearp likes this.
  3. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Hey, you're in the same situation as my JN3DS! You won't be able to get out without a copy of JP cubic ninja or ocarina of time. JPN Ocarina of Time relies on either a 3DS with <10.6 firmware or a Cyber Save, which is the JPN equivalent of Powersaves and can get rather pricey.

    EDIT: However, you could alternatively get yourself a Nintendo DS flashcart to re-install the Gateway MSET ROP exploit on 8.1J. That is probably your cheapest/easiest option.

    If you don't know someone with a <10.6 firmware, your next best choice is to get a Sky3DS, because it costs as much as importing JPN Cubic Ninja and doesn't require the save dongle. From there, you should either do this or update to 10.7 and then proceed with the Plailect guide like everyone else: https://github.com/Plailect/Guide/wiki
     
    Last edited by CrispyYoshi, May 2, 2016
  4. wataznach
    OP

    wataznach Newbie

    Newcomer
    6
    0
    May 2, 2016
    United States
    Thanks for the reply! If I wanted to play games online until then (with the cartridges) since sky3ds might take long to ship, could I update to 10.7 before getting sky3ds? Also, where can I learn more about the NDS flashcart ROP exploit?
     
  5. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    To the first question, yes, except you can do that in Gateway's EmuNand without updating SysNand itself.

    Second question, it's pretty much "run a piece of nds software using a flashcart and it will reinstall the proper hack for your DS Profile so it properly boots into Gateway." Said software is a "Gateway Installer" .nds rom and is included in nearly all of the Gateway .zip packs, in a folder called "Blue card"

    But if you want to know more about why installing a ROP exploit in MSET (aka System Settings) works, you can read this:

     
    wataznach likes this.
  6. kamesenin888

    kamesenin888 GBAtemp Advanced Fan

    Member
    560
    146
    Oct 20, 2007
    Gateway with a private header is not a confirmed cause of bans, cheats with gateway is far superior, when they update the a9lh it would be on top again, the use of 3ds files is awesome, using 9.2 is convenient because of menuhax but sometimes is less stable than mset
     
  7. wataznach
    OP

    wataznach Newbie

    Newcomer
    6
    0
    May 2, 2016
    United States
    Thanks to everyone who has replied! I'm very new to exploits and have only done the spider exploit before with older 3dses, so I'm very inexperienced. I pretty much have no idea how to do what anyone else besides CrispyYoshi is saying.

    So should I not update with the default update that will be suggested and instead update Gateway's EmuNand without updating SysNand somehow? How would I do this?

    Also, are there any tutorials or threads going into more detail about the NDS flashcart exploit? I'm trying to find some but all seem really complicated and I'm not even sure if I'm looking for the right thing.

    I play competitive Mario Kart so I pretty much just need to play online as soon as possible (I have mk7 cartridge) but I don't want to miss out on any potential hacks by updating...
     
    Last edited by wataznach, May 2, 2016
  8. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Assuming your SD card already reads as "GATEWAYNAND" on your computer, you probably already have EmuNand set up. Just boot Gateway Mode and perform a system update through system settings. Be warned, though, that exiting System Settings will boot you back into SysNand. Be absolutely sure that you are in EmuNand when you update through System Settings, or you'll accidentally update your sysnand!

    Your first step is to get a NDS flashcart that can run on 3DS/DSi, like a DSTWO or R4i Gold (second option being cheaper/consumes less battery. There are fakes so I'm not sure where the best place to buy an R4i Gold is [someone here might recommend one?]). In any case, once you can run .nds roms through your flashcart, just download the Gateway Installer from the Blue Card folder of the GW update pack .zips from Gateway's official website, then run the Gateway Installer, select "New 3DS", and it reboot your system and will fix your DS Profile exploit.
     
    wataznach likes this.
  9. wataznach
    OP

    wataznach Newbie

    Newcomer
    6
    0
    May 2, 2016
    United States
    I don't think I've been able to enter EmuNand since getting the 3DS (and the SD doesn't say that either; I had to get a new SD since the original wasn't sent with the 3DS).

    What are the risks associated with updating SysNand to 10.7? Isn't there still the option to downgrade it to 9.2?
     
  10. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    You cannot downgrade from 10.7 without a copy of Cubic Ninja/Ocarina of Time/Pokemon Super Mystery Dungeon native to your region. You can still set up EmuNand within Gateway Launcher, but you'll need a DS flashcart to get in.
     
  11. nero99

    nero99 GBAtemp Advanced Maniac

    Member
    1,933
    873
    Sep 18, 2014
    United States
    Update to 10.7 and get the game vvvvv. It has a exploit which the. You can use to set up CFW or a9lh CFW
     
  12. wataznach
    OP

    wataznach Newbie

    Newcomer
    6
    0
    May 2, 2016
    United States
    Cubic Ninja rom on sky3ds would still work on 10.7, correct?

    I may just update to play mk7 online and invest in sky3ds so that I can do the exploit for multiple 3dses. I mostly just want to make sure whatever I do can be reversed.

    Isn't that only a secondary entry, though?
     
    Last edited by wataznach, May 2, 2016
  13. Temarile

    Temarile (ノ◕ヮ◕)ノ*:・゚✧ A9LH ✧゚・: *ヽ(◕ヮ◕ヽ)

    Member
    1,132
    422
    Jan 7, 2016
    Netherlands
    Yes sky3ds can be used on any known firmware so far.

    V6 is indeed a secondary exploit and needs setting up on an already hacked 3ds.

    So if you want to spend ~$90 go ahead and buy a sky3ds. You can then set up multiple exploits on it and use it all around. You could also look into buying a Ds flashcard as mentioned above. After setting everything up you can still use both the sky3ds and the ds card to play games anyway.
     
    wataznach and CrispyYoshi like this.
  14. CrispyYoshi

    CrispyYoshi GBAtemp Advanced Maniac

    Member
    1,516
    502
    Mar 20, 2010
    United States
    Yes, CN+Sky would work on multiple 3DSes, but you'd need the CN rom for each region. You don't need to buy anything besides a large SD card for any system at or under 10.5 firmware.

    VVVVVV is a secondary exploit and requires hacking the save prior to updating. It's digital and cannot be modified through another 3DS, unlike OoT.

    EDIT: Ninja'd!
     
    wataznach likes this.
  15. wataznach
    OP

    wataznach Newbie

    Newcomer
    6
    0
    May 2, 2016
    United States
    Thanks so much for the help! One last question if anyone here as any experience with it: does sky3ds mk7 rom work well online?
     
  16. Temarile

    Temarile (ノ◕ヮ◕)ノ*:・゚✧ A9LH ✧゚・: *ヽ(◕ヮ◕ヽ)

    Member
    1,132
    422
    Jan 7, 2016
    Netherlands
    I highly recommend to avoid going online with a sky3ds. There is this thing called headers. Just Google sky3ds headers and read everything up. I can see if I can find my little essay I wrote on it..

    EDIT: not really the post I was looking for but it still helps you.

    EDIT 2: this is what I was looking for :D

     
    Last edited by Temarile, May 2, 2016
    wataznach likes this.