SD card games not recognized after setting up emuNAND

Discussion in '3DS - Flashcards & Custom Firmwares' started by Odnetnin46, Jan 5, 2016.

  1. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    So I successfully downgraded my n3DS, and all went swimmingly, my n3DS rebooting straight to the home menu with everything intact, save for my folders exploding everywhere. I attempted to set up emuNAND and CakesFW using this haphazard guide because I was still stressed and shaking from my successful downgrade and wasn't thinking straight.

    I made my SD card and NAND backups, then set up emuNAND9, then transferred my SD backup to my SD card. I did NOT unlink sysNAND at any point. Now when I enter either NAND my 3DS doesn't recognize any legit games on my SD card, but it does see the DSiware I have.

    How do I fix this?

    n3DS 9.2U.
     
    Last edited by Odnetnin46, Jan 5, 2016
  2. Quantumcat

    Quantumcat Dead and alive

    Member
    10,495
    5,532
    Nov 23, 2014
    Australia
    Canberra, Australia
    Not sure why you have this problem, but you could spoof the eShop and redownload them all again. Also make sure your NNID is linked. (System settings then the button at the top of the touch screen)
     
  3. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    I've got like ~30GB of eshop stuff, so that's not going to be ideal at all. Is there any way I can just start over with my backups?

    Also, I don't know if it's worth noting, but when I tried installing FBI as a .cia to my sysNAND, it said it was successful, but nothing showed up on my home menu. At that point my games were still all there.
     
    Last edited by Odnetnin46, Jan 5, 2016
  4. Quantumcat

    Quantumcat Dead and alive

    Member
    10,495
    5,532
    Nov 23, 2014
    Australia
    Canberra, Australia
    For the FBI problem, you have to be in sig patched mode to be able to see it and use it. For the main problem, just double check your NNID is linked. If not, link it and see if that makes everything appear again.
     
  5. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    NNID settings tells me I need to update my firmware. Afterwards, it shows my NNID on the top screen that I've been using forever, so I assume that's good?

    As for FBI, I've been in sig patched mode for both sys and emuNAND and nothing shows up. Trying to install it again from the hb_launcher in sig patched mode (both in sys+emuNAND) gives me an error. See attached.

    Also attached is what the root of my SD looks like, if that helps at all.

    Also I really appreciate you trying to help me. I've gone elsewhere and nobody else has responded.
     

    Attached Files:

    Last edited by Odnetnin46, Jan 5, 2016
  6. Quantumcat

    Quantumcat Dead and alive

    Member
    10,495
    5,532
    Nov 23, 2014
    Australia
    Canberra, Australia
    I'm glad to try and help but I don't think I have the knowledge to do it properly :-p Whenever people have had "summary_wrong_argument" there's an easy fix from memory, try doing a search of the forums on that just in case (although you said the initial install worked, so might not be the same problem as theirs)

    You MIGHT need to log into your NNID for the games to appear but I'm not sure. I remember when I did a system transfer to my n3ds, I had to visit the eShop for it to finish, and whenI did, everything magically popped up. Although the FBI thing will have to be the first priority as because of recent developments by Nintendo, spoofing eShop requires installing things.
     
    Zidapi likes this.
  7. Quantumcat

    Quantumcat Dead and alive

    Member
    10,495
    5,532
    Nov 23, 2014
    Australia
    Canberra, Australia
    Deleted multiple post, sorry my phone is an idiot
     
    Last edited by Quantumcat, Jan 5, 2016
  8. Quantumcat

    Quantumcat Dead and alive

    Member
    10,495
    5,532
    Nov 23, 2014
    Australia
    Canberra, Australia
    Deleted multiple post, sorry my phone is an idiot
     
    Last edited by Quantumcat, Jan 5, 2016
  9. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    Ugh, dammit. I'd just like to start over at this point, because I think I've dug myself into a hole with no known ways out. Could I just do a total format of my SD, wiping the emuNAND partition, then grab my SD backup I made right before I installed emuNAND and try installing rxtools or something as opposed to CakesFW? I can't find anything helpful for the FBI error, and 9.5 emuNAND eshop spoofing seems very risky at this point since I'd have to format sysNAND on top of the fact that FBI hates me.
     
  10. Zidapi

    Zidapi GBAtemp Psycho!

    Member
    3,024
    1,805
    Dec 1, 2002
    I think as @Quantumcat suggested, you're going to need to sign in to your NNID, and enter the eshop before your digital content will show up.

    You don't need to re-download them or anything, they should just appear after you exit the eShop. You don't need to go to the effort of spoofing either, that's only required if you need to download content.

    You can either install and run free-multi-patcher, or use the eshop shortcut that came with the Homebrew Loader starter kit.
     
    Quantumcat likes this.
  11. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    Alright, I'll try multipatcher tomorrow since I'm dead tired from this nonsense. Neither eShop shortcut works by the way, in sig patched mode or not. They just say that I need to update my firmware after the NNID sign-in thing comes up briefly, which, I suspect, doesn't actually sign me in, or at least to the degree that it verifies my titles.
     
  12. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    So, the FBI installer issue was definitely due to me using firmware9.5.bin instead of firmware9.2.bin with CakesFW. Should I mess with firmware_patched.bin at all, too? When the hell should I use 9.5.bin in general?

    EDIT: For emuNAND. Right. I needed FBI installed properly to sysNAND beforehand for it to carry over to emuNAND. Time to H&S.
    Also unrelated, but does anyone know how to make themehax stop yellow screening so much? I'm getting it 60% of the time and that's on top of the 25% boot rate of Cakes. I'm using a custom theme if that's important.

    EDIT: Uninstalled themehax, and browserhax decided to stop working. Keep getting gray screened and then it boots me back to the home menu. I've deleted the tmp payload, reset save data, powercycled, etc. I have a spare 3DS + OoT3D so I can try and install a payload on that later today.

    EDIT: Okay, browserhax just hates tethered cellular networks. Now on to FBI injection.
     
    Last edited by Odnetnin46, Jan 5, 2016
    Quantumcat likes this.
  13. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    Alright, FBI injection was successful (at least on sysNAND, haven't tested emuNAND yet). I successfully installed FBI as its own .cia onto sysNAND, too, just to test it all out.

    After I test emuNAND FBI, would you guys say it's safe to delink NANDs now?

    EDIT: I booted into emuNAND, the H&S injection worked. My FBI .cia I installed while in sysNAND was also present, though since they're still linked, that's what's supposed to happen, right? I'm getting notifications about the home menu and such so that's evidence that I'm on emuNAND too, correct?

    Should I take the plunge and format sysNAND? Should I do anything else first beforehand?
     
    Last edited by Odnetnin46, Jan 6, 2016
    Quantumcat likes this.
  14. Quantumcat

    Quantumcat Dead and alive

    Member
    10,495
    5,532
    Nov 23, 2014
    Australia
    Canberra, Australia
    Just from reading (not from my own experience), in order to get FBI on emuNAND you have to create your emuNAND after installation on sysNAND. Wait till someone confirms, but, I think what you'll have to do is extract your emuNAND with emuNAND tool, create a new emuNAND, then inject your backup back in.
     
  15. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    Does that matter, either for FBI or my NNID games, now that I got FBI injected into the H&S app?

    Basically, can I just format sysNAND and start updating emuNAND now? I made my NAND backups and FBI's working now.

    EDIT: Just formatted. emuNAND and sysNAND are properly delinked. I can see my DSi titles on emuNAND, but not sysNAND. Just have to update emuNAND, then spoof my eshop, and pray my legit games show up after that.

    EDIT: Updated to 9.5U successfully. Patched Nver, tried loading the eshop up with HANS and loading NNID settings through emuNAND FBI, but I'm getting the 022-2634 error, meaning my NNID is almost definitely still linked serverside to a non-existent NAND or something, and I'll probably have to contact Nintendo support to get that signed out.

    I'll leave it at that for now. My last edit here will be results on my SD card games and NNID.

    EDIT: I lied
     
    Last edited by Odnetnin46, Jan 7, 2016
  16. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    Fixed the NNID problem with this. Unfortunately, it doesn't look like any of my previously downloaded eshop games are showing up on my home menu.

    Well, that sucks. Time to redownload a gorillion gigs of eshop games, find cryptofixed CIAs of my newer games, and restore what few save data backups I made.
     
    Last edited by Odnetnin46, Jan 7, 2016
  17. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    It's a stretch, but could this be why they're not showing up? The bigger folder only has all my legit eshop stuff, and the 7GB only has all the CIAs I installed manually to emuNAND. Should they be separate folders? Could I merge them or rename the bigger one to what the smaller's called, or is that a lost cause?
     

    Attached Files:

    • hmm.png
      hmm.png
      File size:
      143.3 KB
      Views:
      92
  18. Zidapi

    Zidapi GBAtemp Psycho!

    Member
    3,024
    1,805
    Dec 1, 2002
    Found this in another thread, full credit goes to @The Real Jdbye.
    Hopefully that solves it!
     
  19. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    Restored my Nintendo 3DS folder backup from before the downgrade, and it just boots to a black screen (probably due to Shufflehax still being on there?). Interestingly, when I press the power button, it sometimes brings me to the "features in sleep mode" screen where I can press home or power off, but the returning to home menu screen just hangs as well.

    I then tried my backup just before creating emuNAND, wherein I had deleted some titles that were cluttering up my SD card like Ironfall and a bunch of demos, and that didn't make my eshop games show up.

    I guess my only remaining option is to figure out how to manually delete Shufflehax on that first backup, since I can't eject the SD card while in emuNAND. Any ideas?
     
  20. Zidapi

    Zidapi GBAtemp Psycho!

    Member
    3,024
    1,805
    Dec 1, 2002
    No problem, this should sort that out. Again, full credit goes to @Ar7ific1al
     
  21. Odnetnin46
    OP

    Odnetnin46 GBAtemp Regular

    Member
    141
    17
    Jan 12, 2011
    United States
    Some basement
    That fixed it, and my stuff + badges are showing up! Gonna see if I can also slap the folder with all my unsigned CIAs in here too, then I'll finally be done with this thread. Thanks a million!

    EDIT: It's a black screen, even after deleting the 8f folders. Guess I'll just reinstall all those CIAs from scratch at this point - I can live with redoing the first four chapters of FE If.
     
    Last edited by Odnetnin46, Jan 8, 2016
  22. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,864
    2,597
    Jul 23, 2012
    United States
    Octo Canyon
    Welp, I've learned my lesson now about backing up my 3DS folder. I'm just going to reinstall everything from scratch. I'll just put the 2DS on it's charger while setting it to "Install and Delete .CIAs" while I sleep. Should be done by morning.