SaveMii leads to a black screen after installing a second game

Discussion in 'Wii U - Homebrew' started by Yoast, Oct 28, 2019.

  1. Yoast
    OP

    Yoast Newbie

    Newcomer
    1
    Oct 28, 2019
    Netherlands
    I hope someone can tell me what I'm doing wrong 'cause I'd like to copy the saves for all my games.

    Here's the situation: I have installed Xenoblade Chronicles X (XCX) to a USB drive using Mocha CFW and WUP Installer GX2 on my WiiU (5.5.4). I followed the guide on wiiu.hacks.guide and everything seems to work fine. The game works and I used SaveMii successfully to copy my save from NAND to USB (at the same time I made a back-up of all my saves which worked fine).

    I then continued and installed using WUP Installer GX2 some other games (Mario Party 10, Super Mario 3D World, Mariokart 8 and Monster Hunter 3 Ultimate). All the games work, but when I now start SaveMii (browser->Mocha->SaveMii) I end up with a black screen right after the splash screen.

    If I install a single game (tested are party 10, 3D world and XCX), SaveMii works and I can copy my save from NAND to USB (or restore from SD). But as soon as I install a second game, I end up with a black screen. If I install 2 (or more) games at the same time, I also get a black screen.

    I saw another thread here "who-else-is-getting-black-screens-in-savemii-mod" which seems similar, but the modified SaveMii versions posted in that thread all throw an exception.

    I was hoping there would be some kind of logging function in SaveMii to see what happens, but I can't see anything.

    Any suggestions?
     
  2. lolman9999

    lolman9999 Member

    Newcomer
    1
    Jun 3, 2019
    United States
    I had a similar issue with wup installer, but it went away. This seems to be a common issue with homebrew launcher, but maybe someone else would know more?
     
  3. Wuigi

    Wuigi GBAtemp Advanced Fan

    Member
    6
    Sep 14, 2012
    Germany
    If you dump your otp and seeprom keys you can also extract the saves that are stored on an wii u encrypted external HDD using wfs-extract from wfslib.
    You can copy your saves from the internal NAND to the encrypted hdd from the wii u disk management as well, so it is pretty straight forward.
    When all your saves are stored on the USB HDD, you can dump the path "/usr/save/00050000/" with wfs-extract to have all the saves on your pc so you can use them for cemu as well.
    An example command could be
    "wfs-extract --input \\.\PhysicalDrive3 --output D:\wiiu_saves --dump-path /usr/save/00050000/ --otp otp.bin --seeprom seeprom.bin"
     
    Last edited by Wuigi, Oct 28, 2019
  4. Yoast
    OP

    Yoast Newbie

    Newcomer
    1
    Oct 28, 2019
    Netherlands
    Thanks for the suggestions.

    I initially used disk management to copy the saves to the HDD, but it overwrote the game that I installed on the HDD. Thanks to your comment I realized that I could try it the other way around. First copy the save, then install the game. This worked like a charm.

    Although the issue is still there (SaveMii gives a black screen after splash) I managed to transfer my saves to the HDD.
     
Quick Reply
Draft saved Draft deleted
Loading...