Save file will not apply changes from Bruteforce but GG does need some answers!

Discussion in 'PS3 - Hacking & Homebrew' started by ZeroG777, Sep 12, 2017.

  1. ZeroG777

    ZeroG777 Newbie

    Aug 29, 2016
    United States
    Hi Im familiar with GG and bruteforce and I have hex editing a lot of my ps3 games so I have exp. I wanted to edit ragnarok odyssey ace us ps3 version monster materials so I went to GG they had all materials 999 but there are key plot items that you get only one of and I didnt want 999 of them but they didnt have advanced mode unlocked for it but because i wanted to edit it myself. So I went with bruteforce I have 4.74 version. I could decrypt the file and even though it was green and said decrypted it wouldnt always decrypt right for some reason I did file reinstalls ect ect. so once I got it decrypted right I found the offsets for my materials it floats a bit and its reversed hex order 5c780- 8+9 start the material type then came spaces then the item quantity started at 5c780- C+D so it looks like Data xx xx 00 00 Data xx xx 00 00 xx xx 00 00 and just repeated for however many materials you have. Im end game so I had a list. So the max is 999 03 e7 but reversed its e7 03.

    I plug in the changes and save it in the hex editor that came w/bruteforce re encrypt it full update pdf full build ect everything checks out but when I load the game it loads up but without the changes. So I figure theres a checksum somewhere, ( I dont know how to find it I guess I could open up two of the same files slightly renamed and use the compare difference to try to locate it) I open up brute crc32 open NPUB31406-PLY-SAVEDATA_0 PLY-DATA and paste crc32 into the do it section hit ok and I get this message back

    Requested CRC: 17EA8434
    11:47:05 AM :
    Nothing to be done

    So i load the game one more time but still no changes now this is where things get strange!!!!! I take that file with all the change on it (I checked in hex editor quick) go to GG do a quick option for max zenny let GG do its thing then I went to load up the game and my changes went through after that. So what the hell am I missing theres something GG does that Im not doing with Bruteforce.
    I though about that above method again because I had a similar problem with FF10 HD sphere levels because they wouldnt change and it worked.
    So if anyone has so insight I would be grateful thanks ^^