Sands of Destruction stuck on loading screen

Discussion in 'NDS - Console and Game Discussions' started by chrabia, Jan 16, 2012.

  1. chrabia
    OP

    chrabia Newbie

    Newcomer
    2
    0
    Jan 16, 2012
    Poland
    Hello everyone!
    I've been playing Sands of Destruction on my DS (with Acekard 2.1) from some time and one day it stopped working :/ (if I remember correctly I didn't really do anything in the meantime, maybe updated AKAIO, but it'd be strange for the game to work only on the older version :S).
    Everytime I try to play the game doesn't even turn on, it's stuck on "loading" text (that appears at turning on any game on Acekard).

    I updated AKAIO to 1.8.9 and nothing. I tried playing SOD on NO%GBA and it works fine there.

    What's the problem? ; /
     
  2. wasim

    wasim ♫ Music addict ♫

    Member
    907
    63
    Nov 13, 2010
    India
    Calicut
    Does this happen to any other ROM ??


    Try to find a clean dump, that might help.
     
  3. chrabia
    OP

    chrabia Newbie

    Newcomer
    2
    0
    Jan 16, 2012
    Poland
    No, I don't have these kind of problem with any other game (including i.e. Phoenix Wright series, Ghost Trick, FFs, Soma Bringer, TWEWY and many many others).
    And I already tried the clean dump.
     
  4. InuYasha

    InuYasha Professional Coke Fiend

    Member
    1,778
    55
    Dec 8, 2007
    United States
    Save your files to your pc as back up then format your memory card with Panasonic SD formatter and then readd your backup back to your card...