rxTools 3.0 installing FBI on 4.5 emuNAND problem

Discussion in '3DS - Flashcards & Custom Firmwares' started by ToniCodrea, Nov 17, 2015.

  1. ToniCodrea
    OP

    ToniCodrea Member

    Newcomer
    30
    2
    Sep 13, 2014
    Romania
    Whenever I try to install FBI on 4.5 rxTools EmuNAND, Health and Safety still is there, rxTools 3.0 tells me to use v3077, and I did., while 2.6 tells me to use v2050, and again, nothing. Can anyone help me, please?
     
  2. bitjacker

    bitjacker GBAtemp Disorderly

    Member
    204
    78
    Jan 23, 2014
    United States
    had no problems like this on 2.6 then again i am on 4.2
     
  3. ToniCodrea
    OP

    ToniCodrea Member

    Newcomer
    30
    2
    Sep 13, 2014
    Romania
    Just discovered that injecting on emuNAND only works on 9.0+, so should I assume the same for sysNAND? I have another 3DS on 1.1 and really wanna update it to 4.5.
     
  4. bitjacker

    bitjacker GBAtemp Disorderly

    Member
    204
    78
    Jan 23, 2014
    United States
    my sysnand is 4.2 and i injected fbi into my emunand without a problem
     
  5. ToniCodrea
    OP

    ToniCodrea Member

    Newcomer
    30
    2
    Sep 13, 2014
    Romania
    What's your emuNAND version?
     
  6. JPnintendo

    JPnintendo GBAtemp Regular

    Member
    186
    25
    Dec 3, 2009
    Argentina
    I installed FBI on 4.2U emunand without problem, then updated trougth cia. So you should be able to install it on <9.0 emunand.
     
  7. ToniCodrea
    OP

    ToniCodrea Member

    Newcomer
    30
    2
    Sep 13, 2014
    Romania
    Doesn't work for me unfortunately, don't know what I'm doing wrong. I'll try to inject it manually.
     
  8. JPnintendo

    JPnintendo GBAtemp Regular

    Member
    186
    25
    Dec 3, 2009
    Argentina
    It worked with a old release of Rxtools (the first one with FBI injection)
     
  9. mgrev

    mgrev Music Addict, Video Game Fanatic

    Member
    GBAtemp Patron
    mgrev is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,896
    2,268
    Apr 13, 2015
    Norway
    Under Tomato Hentai's stairs
    https://gbatemp.net/threads/release...ect-generator-jpn-usa-eur-chn-kor-twn.391525/
    Keep in mind that you can VERY EASILY brick your 3ds if you do something wrong, but the instructions should be very similar. just use Emunand tool
    to get a copy of your emuNAND. Use your Emunand .bin file instead of your regular nand.bin (you dont have to if you dont have anything installed on emunand) and inject it to the emunand partition after you are done. if you do not use the gateway way to inject nand, your 3ds will not be bricked(you probably dont know about that, so nothing to worry about)
     
  10. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Or just update your emunand then do the injection.
    And the rxtools fbi injection tool doesn't work on GW downgraded nand if you have one.
     
  11. bitjacker

    bitjacker GBAtemp Disorderly

    Member
    204
    78
    Jan 23, 2014
    United States
    my emunand is 10.1 and here is THE guide i followed written by roxas75 himself: http://pastebin.com/WVszD3Tm
    don't update emunand before you inject. do follow it to a T. tiny format is important no matter what anyone else says! after you have everything working, tiny format removes itself. after you update download the sonic boom theme. after this, go ahead and put whatever cias you want on your 3ds. i highly recommend yo-kai watch.
     
    Last edited by bitjacker, Nov 18, 2015
  12. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    "don't update emunand before you inject"

    What's the problem with this? That's what I always advised. If you're on a firmware under 6.X and you inject before updating the update will replace your FBI with the original H&S.
     
  13. bitjacker

    bitjacker GBAtemp Disorderly

    Member
    204
    78
    Jan 23, 2014
    United States
    mine was not replaced. the problem is that it is not one of the steps that roxas75 wrote in the guide i posted a link to. why do anything other than what the software maker says? the only direction i didnt follow was not generating the firmware.bin with python. i dont know what a batch script is...
     
    Last edited by bitjacker, Nov 18, 2015
  14. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,641
    439
    Jan 8, 2009
    China
    This case has already been discussed on @Riku 's FBI manual installation post.

    It's caused by either you auto-downloaded the update nag or you Gateway-Downgraded your 3DS.
    Both of them make FBI injection misjudge the TMD version.
    You can't manually use the correct version since FBI injection refuses to accept the version not judged by itself.

    Update emuNAND before injecting FBI is the best choice.
    But if you are unable to update emuNAND, or you want to inject FBI to SysNAND, look at the following:

    For update nag DLed 4.X, you should use Recovery Mode to clean up the update nag before injecting FBI.

    For GW-DG 4.X, you have to manually inject FBI or restore undowngraded SysNAND before injecting FBI.
     
    Last edited by MelonGx, Nov 19, 2015
    RainThunder likes this.
  15. bitjacker

    bitjacker GBAtemp Disorderly

    Member
    204
    78
    Jan 23, 2014
    United States
    melongx, my 3ds is unable to inject fbi in sysnandb but it worked fine in my emunand. if i ever want fbi on sysnand what will i need to do?
     
Loading...