rtorrent/libtorrent fails to ./configure

Discussion in 'Computer Games and General Discussion' started by fgghjjkll, Jul 19, 2010.

  1. fgghjjkll
    OP

    fgghjjkll GBATemp MegaMan

    Member
    GBAtemp Patron
    fgghjjkll is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,043
    49
    Jul 7, 2008
    When ever i sudo ./configure libtorrent 0.12.6 on CentOS via SSH, i alway get this:

    Code:
    ...
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for OPENSSL... yes
    checking for STUFF... configure: error: Package requirements (sigc++-2.0) were not met:
    
    No package 'sigc++-2.0' found
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively, you may set the environment variables STUFF_CFLAGS
    and STUFF_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    
    [fgghjjkll@miniitx libtorrent-0.12.6]$
    I have successfully make installed libsigc++-2.2.4. What is the best plan of action?

    I went back to trying to compile Transmission instead but i get this instead:

    Warning: Spoilers inside!

    I prefer to use Transmission than rtorrent. Any help for that?
     
  2. Frederica Bernkastel

    Frederica Bernkastel WebPerf and PWA advocate; @antoligy on Twitter

    Member
    GBAtemp Patron
    Frederica Bernkastel is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,154
    765
    Jan 31, 2008
    United Kingdom
    Hinamizawa
    that's the answer.
     
  3. fgghjjkll
    OP

    fgghjjkll GBATemp MegaMan

    Member
    GBAtemp Patron
    fgghjjkll is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,043
    49
    Jul 7, 2008
    i already have done that. But nevermind. I compiled and installed Tranmission now.