RROD after shutdown

Discussion in 'Xbox 360 - Games & Content' started by Mr. Waffle, Sep 14, 2009.

Sep 14, 2009

RROD after shutdown by Mr. Waffle at 8:27 PM (528 Views / 0 Likes) 3 replies

  1. Mr. Waffle
    OP

    Member Mr. Waffle A Free Waffle

    Joined:
    Jul 2, 2008
    Messages:
    250
    Country:
    Netherlands
    So, this just happened to me, and it scared the hell out of me.
    Each time, after I shut down my xbox, it gives 3 red flashing lights.
    I can turn it on, play games, everything, its just when I shut it off.
    Anybody has an idea of what it could be?
     
  2. Smuff

    Member Smuff Fossilized Gamer

    Joined:
    Jul 29, 2006
    Messages:
    1,024
    Location:
    By the sea
    Country:
    United Kingdom
    It's knackered - simple as that.

    Anytime soon it will just decide to let rip and them RROD will become a permanent feature.

    Options :
    1. Repair the x-clamps
    2. If it's within 3 years old, contact M$ for a free repair (you just need to drop it off at a UPS center)
    3. See above but pay for repair (if out of 3 year warranty)
    4. Bite the bullet and buy a new one.


    My commiserations.
     
  3. Maz7006

    Member Maz7006 iSEXu

    Joined:
    Aug 2, 2008
    Messages:
    3,622
    Country:
    Lebanon
    when you're palying these games, are you getting any corrupt graphics , freezes etc ?

    but basically your console is dying. [​IMG]
     
  4. Mr. Waffle
    OP

    Member Mr. Waffle A Free Waffle

    Joined:
    Jul 2, 2008
    Messages:
    250
    Country:
    Netherlands
    No, nothing, everything is just normal.
    Just the shutdown.

    EDIT: Well, it doesnt give the rrod anymore, but Im still afraid of a permanent rrod.
    Its my 2nd box, and my 1st one, I tried to repair, and it worked for 1 or 2 weeks but then it broke again, so I bought a new one.
    If I get permanent I'll first go to some shop that can repair it. There's defenitely something like that near Rotterdam.
    If it breaks again, just a new one, arcade this time.

    EDIT2: Again, now at startup. Screw this. Going to search for a repair, since it is flashed I can't send it at microsoft.
     

Share This Page