Rom not working properly

Discussion in 'GBA - Emulation' started by JustANoob;), Mar 12, 2017.

  1. JustANoob;)

    JustANoob;) Member

    Feb 12, 2016
    United States
    Hello forums - finally got around to posting something. Is this the right forum for this...?

    My problem is that I tried to dump a rom from the WiiU Virtual Console (The game was Pokémon Pinball R&S) by following this guide:
    While it seemed to work (I got a file that wasn't blank and had "POKEPIN R/S" somewhere inside the data, I can't use it with mGBA (3DS homebrew version), and I am not sure why. I thought it had something to do with motion blur, because it was mentioned at the end of the guide, but I really don't know. While looking around for a solution to motion blur, I found this: and managed to get a file out of it, but
    now I'm just stuck and have no idea what to do next, with the footer or the rom or mGBA, or if I'm even close to a solution.

    EDIT: Probably on the complete wrong track with the above information now crossed out. After running the rom in no$gba it gave me some probably more helpful errors:
    • Bad header checksum (real gameboy would shut down)
    • Bad ROM Entrypoint at Header [000h]
    • Bad Fixed Value 96h at Header [0B2h]

    I found a tool called GBATA and by using the header fix tool it fixed the bad checksum. I still don't know how to fix the other errors yet, and (I think) the checksum problem wasn't really important. So my question now: How do I fix the other two problems?

    I would appreciate some help if you could offer any. Thank you. :)
    Last edited by JustANoob;), Jun 2, 2017