1. meistarkus

    OP meistarkus Newbie
    Newcomer

    Joined:
    May 16, 2013
    Messages:
    2
    Country:
    Australia
    Hey guys!

    I'd like to share my big problem with you. I received it today and i was very glad it came quite fast.
    So i fired it up and gave it a try. First of all i tried the music then i selected the preinstalled FIFA game.
    :gba:
    It started very fast but after selecting the language, the console switched off immediately.
    I tried to turn it on again but without success. I pluged the charger in for about 6 hours and still nothing.
    When i push the power button, the green light goes on for as long as i push and hold the power button, but when i release it, the green light goes off too and nothing works. I tried it with the k-card plugged in, with an original GBA game, with an original GBC game and without any cartridge, but nothing seems to work.
    I would really appreciate your help, as 60$ is too much for putting it right into the waste :mellow:
     
  2. meistarkus

    OP meistarkus Newbie
    Newcomer

    Joined:
    May 16, 2013
    Messages:
    2
    Country:
    Australia
  3. Another World

    Another World Emulate the Planet!
    Former Staff

    Joined:
    Jan 3, 2008
    Messages:
    10,578
    Country:
    Colombia
    can you please post the CRC value and full name of the game that caused the issue?

    the fact that it won't turn on at all has me worried. i've not yet read that any crashing would permanently brick the system. i would have suggested a reformat of the msd card, as i had a corrupted background image give me a black screen after powering on. but you wrote that its not working with retail games so something else is wrong.

    try charging it using a different plug/usb cable. you should be able to get a charge sufficient enough to power-up after 30 minutes.

    also try pushing the reset button, its next to the headphone jack. you'll need a pin or paper clip to push it. although, i don't think its going to help.

    -another world
     
    alexei_gp likes this.
  4. Parasite X

    Parasite X Banned
    Banned

    Joined:
    Jul 6, 2009
    Messages:
    636
    Country:
    United States
    Did you try using the reset button next to the earphone plug?
     
  5. KingBlank

    KingBlank King of Nothing
    Member

    Joined:
    Sep 17, 2008
    Messages:
    667
    Country:
    New Zealand
    I did not use mine for several years, would not boot when I tried even after recharging the battery.
    Opened it up and cleaned the circuit board in a few spots that looked a bit messy, works now! :)
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - power,