Hacking RetroGameFan Updates/Releases

RavenAstra

Member
Newcomer
Joined
Jul 3, 2022
Messages
6
Trophies
0
Age
22
Location
Ontario
XP
10
Country
Canada
The one I have is similar (R4ISDHC RENOVATION 2.20T), it is not compatible with anything that isnt the original kernel and executable on the boot level (which is awful since if I hadnt found years ago the original kernel and made a copy it would be lost to time, since the original site doesnt exist), but if you copy the YSmenu files and try to boot the YSmenu.nds, it works (meaning that primary booting is not possible).
What you can do however is to give a quick access to YSmenu instead of seeking the YSmenu.nds on the game list everytime.
If it includes a Multimedia icon and Moonshell you can replace and rename the moonshell folders to the ones on YSmenu (I think I renamed the YSmenu.nds to moonshl2.nds), so when the flashcard starts, instead of clicking on the Game icon, you click on the Multimedia icon to load YSmenu quicker.

This flashcard had only one update on its lifetime to support DSi system update 1.4 and that is it. The original kernel works but has issues with games released later on the DS life like Pokemon BW2 and the most recent Yu Gi Oh game on the DS which I dont remember the name. With YSmenu all games work fine, even romhacks and translations, contrary to some posts saying that the original kernel in their flashcards is better.
Do you happen to still have original kernal? I have a R4 SDHC Renovation 2.10T and I haven't been able to find the kernal anywhere. I found this R4 SDHC 2010 firmware on this site by a user called Randall69 and it works in the sense that I can play games before 2010 on it, but anything newer, like Pokemon Black/Conquest, and I get a dldi error when trying to use YSMenu. I'm gonna give what you said a try though.

The original kernal on mine was time bombed and some files got deleted when I was younger. I've been trying to make it work on my v5 DS Lite. I also have a TTDS card too that still works but it also can't play any of the newer games. (haven't tried updating the kernal/firmware yet though) Also, in order to even be able to play ANY games on my R4 SDHC clone, I discovered I had to do a weird mix of files (3rd photo). I had to combine the regular R4 SDHC files with the clone one from RetroGameFan's multi cart update. The original files that I do have still are in the 4th photo, (I do not have the R4i Menu that came with it though where the ButtonLIB and RTS files were originally). Additionally, the DEMON.sys and DEMON0.sys files, along with the SWRESET.sys file, recreate themselves if I delete them and put my R4 back in my DS Lite.

I'm at my wits end on trying to get rid of the dldi error when I launch games in YSMenu.
 

Attachments

  • IMG_1475_2.jpg
    IMG_1475_2.jpg
    1.5 MB · Views: 13
  • IMG_1476.jpg
    IMG_1476.jpg
    1.5 MB · Views: 14
  • Screen Shot 2022-07-03 at 2.11.17 PM.png
    Screen Shot 2022-07-03 at 2.11.17 PM.png
    33.1 KB · Views: 14
  • Screen Shot 2022-07-03 at 2.14.09 PM.png
    Screen Shot 2022-07-03 at 2.14.09 PM.png
    22.1 KB · Views: 16

Pk11

A catgirl with a DSi
Member
Joined
Jun 26, 2019
Messages
879
Trophies
1
Age
20
Location
米国
Website
pk11.us
XP
2,861
Country
United States
Do you happen to still have original kernal? I have a R4 SDHC Renovation 2.10T and I haven't been able to find the kernal anywhere. I found this R4 SDHC 2010 firmware on this site by a user called Randall69 and it works in the sense that I can play games before 2010 on it, but anything newer, like Pokemon Black/Conquest, and I get a dldi error when trying to use YSMenu. I'm gonna give what you said a try though.

The original kernal on mine was time bombed and some files got deleted when I was younger. I've been trying to make it work on my v5 DS Lite. I also have a TTDS card too that still works but it also can't play any of the newer games. (haven't tried updating the kernal/firmware yet though) Also, in order to even be able to play ANY games on my R4 SDHC clone, I discovered I had to do a weird mix of files (3rd photo). I had to combine the regular R4 SDHC files with the clone one from RetroGameFan's multi cart update. The original files that I do have still are in the 4th photo, (I do not have the R4i Menu that came with it though where the ButtonLIB and RTS files were originally). Additionally, the DEMON.sys and DEMON0.sys files, along with the SWRESET.sys file, recreate themselves if I delete them and put my R4 back in my DS Lite.

I'm at my wits end on trying to get rid of the dldi error when I launch games in YSMenu.
On the r4sdhc.com are you using a non-SDHC card? (2 GB or smaller) It's possible that could cause a DLDI error, I know some DLDIs don't work on SDSC.
And just to be sure, have you tried deleting everything from the old kernel and using the files from the R4SDHC folder of this? It does say that website should be supported from that folder, though it's possible they made multiple non-intercompatible carts.

The DSTT should for sure work with YSMenu and support the newer games and such. That's probably the better cart so if you only need one working I'd try that.
 

RavenAstra

Member
Newcomer
Joined
Jul 3, 2022
Messages
6
Trophies
0
Age
22
Location
Ontario
XP
10
Country
Canada
On the r4sdhc are you using a non-SDHC card? (2 GB or smaller) It's possible that could cause a DLDI error, I know some DLDIs don't work on SDSC.
And just to be sure, have you tried deleting everything from the old kernel and using the files from the R4SDHC folder of this? It does say that website should be supported from that folder, though it's possible they made multiple non-intercompatible carts.

The DSTT should for sure work with YSMenu and support the newer games and such. That's probably the better cart so if you only need one working I'd try that.
I'm pretty sure it's a SDHC Clone and the micro sd card is 2GB. I know a long time ago, Pokemon Black did run on it once but then it froze and couldn't progress story anymore.

Yup, I tried deleting everything from the old kernal and using the R4SDHC folder. Yeah, like, I can get YSMenu to launch but I just keep getting those DLDI errors.

Yeah, I was hoping to give my boyfriend one of the cards and then we could play a bunch of the Pokemon games together but I might just buy him a new card and I'll continue to use the DSTT once I update it.

Thanks for replying back!
 

Pk11

A catgirl with a DSi
Member
Joined
Jun 26, 2019
Messages
879
Trophies
1
Age
20
Location
米国
Website
pk11.us
XP
2,861
Country
United States
I'm pretty sure it's a SDHC Clone and the micro sd card is 2GB. I know a long time ago, Pokemon Black did run on it once but then it froze and couldn't progress story anymore.

Yup, I tried deleting everything from the old kernal and using the R4SDHC folder. Yeah, like, I can get YSMenu to launch but I just keep getting those DLDI errors.

Yeah, I was hoping to give my boyfriend one of the cards and then we could play a bunch of the Pokemon games together but I might just buy him a new card and I'll continue to use the DSTT once I update it.

Thanks for replying back!
I meant of the SD card was non-SDHC, not the flashcard, which since it's 2 GB it is. Try using a 4GB or larger microSD in that flashcard if you can, it may fix the DLDI errors.
 

Codemastershock

Well-Known Member
Member
Joined
Oct 14, 2013
Messages
274
Trophies
0
XP
995
Country
Brazil
Do you happen to still have original kernal? I have a R4 SDHC Renovation 2.10T and I haven't been able to find the kernal anywhere. I found this R4 SDHC 2010 firmware on this site by a user called Randall69 and it works in the sense that I can play games before 2010 on it, but anything newer, like Pokemon Black/Conquest, and I get a dldi error when trying to use YSMenu. I'm gonna give what you said a try though.

The original kernal on mine was time bombed and some files got deleted when I was younger. I've been trying to make it work on my v5 DS Lite. I also have a TTDS card too that still works but it also can't play any of the newer games. (haven't tried updating the kernal/firmware yet though) Also, in order to even be able to play ANY games on my R4 SDHC clone, I discovered I had to do a weird mix of files (3rd photo). I had to combine the regular R4 SDHC files with the clone one from RetroGameFan's multi cart update. The original files that I do have still are in the 4th photo, (I do not have the R4i Menu that came with it though where the ButtonLIB and RTS files were originally). Additionally, the DEMON.sys and DEMON0.sys files, along with the SWRESET.sys file, recreate themselves if I delete them and put my R4 back in my DS Lite.

I'm at my wits end on trying to get rid of the dldi error when I launch games in YSMenu.
https://gbatemp.net/download/r4isdhc-renovation-v2-20t-kernel-and-ysmenu.37425/
It is the original kernel and it has the moonshell replaced by ysmenu, so you can boot games on the original kernel by choosing the game option or if you click on the Multimedia icon it goes to ysmenu.
 
  • Like
Reactions: RavenAstra

Megadriver94

Well-Known Member
Member
Joined
Aug 11, 2017
Messages
474
Trophies
0
Location
Earth
XP
1,630
Country
United States
For 2014-2019 R4 SDHC Cards from r4isdhc.com, do you need to have both the Primary Kernel and dual booting enabled, or is is dual booting optional? :unsure::unsure:
Hello, I would appreciate an answer to this here question I've been waiting on for weeks if not a month. I already did the primary Kernel part BTW.
 

RavenAstra

Member
Newcomer
Joined
Jul 3, 2022
Messages
6
Trophies
0
Age
22
Location
Ontario
XP
10
Country
Canada
It is the original kernel and it has the moonshell replaced by ysmenu, so you can boot games on the original kernel by choosing the game option or if you click on the Multimedia icon it goes to ysmenu.
IT WORKED!!!! Thank you so much!!!!! I ended up putting it on my newer 64 GB SDHX card that I formatted to be a Fat32
 
  • Like
Reactions: Codemastershock

RavenAstra

Member
Newcomer
Joined
Jul 3, 2022
Messages
6
Trophies
0
Age
22
Location
Ontario
XP
10
Country
Canada
Hello, I would appreciate an answer to this here question I've been waiting on for weeks if not a month. I already did the primary Kernel part BTW.
from my experience, you need to have both the primary kernal and dual booting enabled, that's what I did to get my card to work for the most part
 

lifehackerhansol

i write working(?) code
Member
Joined
Oct 2, 2021
Messages
372
Trophies
0
XP
801
Country
Canada
Hello, I would appreciate an answer to this here question I've been waiting on for weeks if not a month. I already did the primary Kernel part BTW.
It's optional. I'm not sure where you got that it is required.
It clearly lays out Primary booting (no original kernel) and dual booting (with original kernel). Your job is to pick one of them.
 

lifehackerhansol

i write working(?) code
Member
Joined
Oct 2, 2021
Messages
372
Trophies
0
XP
801
Country
Canada
On the topic of R4i-SDHC, for any that has a timebombed clone, I've built a small loader that will bypass the protection built into the cartridge firmware. If your cart is timebombed and following the Primary Instructions for R4i-SDHC YSmenu causes a red SD card icon with "MENU?" on it, you can replace the `R4.dat` file with the one inside this zip instead to make it boot.

The source code (GPL2) can be found at https://github.com/lifehackerhansol/flashcard-bootstrap (in main.c, the boot target is TTMenu.dat instead of BOOT.NDS)
 

Attachments

  • R4.DAT.zip
    125 KB · Views: 15

Megadriver94

Well-Known Member
Member
Joined
Aug 11, 2017
Messages
474
Trophies
0
Location
Earth
XP
1,630
Country
United States
I tried it on my DS Lite, and it worked as intended for the DS games! :) :)
However, for some reason it won't allow the GBA ROMS to be played without a physical flashcart! Why is that? Is there a way around it, or should I search for an actual GBA flash-cartridge? Which brands would work the most?
 

lifehackerhansol

i write working(?) code
Member
Joined
Oct 2, 2021
Messages
372
Trophies
0
XP
801
Country
Canada
I tried it on my DS Lite, and it worked as intended for the DS games! :) :)
However, for some reason it won't allow the GBA ROMS to be played without a physical flashcart! Why is that? Is there a way around it, or should I search for an actual GBA flash-cartridge? Which brands would work the most?
Use GBARunner2: https://github.com/unresolvedsymbol/GBARunner2-DSL-Enhanced/releases/latest

The GBA feature in YSMenu is designed explicitly for Slot-2 cartridges such as the EZ-Flash 3in1.
 
  • Like
Reactions: zfreeman

Codemastershock

Well-Known Member
Member
Joined
Oct 14, 2013
Messages
274
Trophies
0
XP
995
Country
Brazil
On the topic of R4i-SDHC, for any that has a timebombed clone, I've built a small loader that will bypass the protection built into the cartridge firmware. If your cart is timebombed and following the Primary Instructions for R4i-SDHC YSmenu causes a red SD card icon with "MENU?" on it, you can replace the `R4.dat` file with the one inside this zip instead to make it boot.

The source code (GPL2) can be found at https://github.com/lifehackerhansol/flashcard-bootstrap (in main.c, the boot target is TTMenu.dat instead of BOOT.NDS)
Thank you! Now my kernel finally autoboots to ysmenu! The best I could do before was replace the multimedia icon (moonshell) to ysmenu or to cycle through the ysmenu icon on the game list. It worked but I always wanted it to autoboot to ysmenu since the game compatibility is better than the game list of the flashcard.
 

AirMage

Member
Newcomer
Joined
Sep 1, 2014
Messages
6
Trophies
0
Age
29
XP
90
Country
Russia
On the topic of R4i-SDHC, for any that has a timebombed clone, I've built a small loader that will bypass the protection built into the cartridge firmware. If your cart is timebombed and following the Primary Instructions for R4i-SDHC YSmenu causes a red SD card icon with "MENU?" on it, you can replace the `R4.dat` file with the one inside this zip instead to make it boot.

The source code (GPL2) can be found at https://github.com/lifehackerhansol/flashcard-bootstrap (in main.c, the boot target is TTMenu.dat instead of BOOT.NDS)
THX. Couldn't launch ys menu directly without it
 

elCerebrain

Member
Newcomer
Joined
Dec 23, 2016
Messages
22
Trophies
0
Age
24
Location
Bogotá, DC
XP
108
Country
Colombia
Hello, I'm looking for help.

I have this R4i Gold: Front / Back

I got a file named r4igold_wood_v2.50.rar using Wayback Machine, this is the latest official kernel released by www.r4igold.cc for the R4i Gold Wood. There is another update R4GOLD2.6_EN.rar, this didn't work with the R4. I get a Black screen with Loading.

I tried using instructions for different flashcarts but none of them worked. Does anybody know how to make this work? I'm interested in using the most up to date kernel but none seem to work. :(

When I power on the DSi XL I get a DORASU game with a little kid. If I don't configure the DS Lite to boot automatically to the flashcart it won't be recognized.

My root folder looks like this:

_system_
moonshl2
moonmemo
_ds_mshl.nds
_ds_menu.dat.

_system_ folder looks like:

skin (folder)
usrcheat.dat
strings.txt
savesize.bin
romlist.dat
r4.dldi
font.bin
euc-cn.bin

Hope all of this information helps you on helping me. Thank you!
 
Last edited by elCerebrain,
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: +2