Homebrew Official Retroarch WiiU (wip.)

september796

Well-Known Member
Member
Joined
May 4, 2015
Messages
234
Trophies
0
XP
777
Country
Cote d'Ivoire
what's this graphical issue called and how to avoid it in RA?
i hate the 'pixel perfect' aspect ratio but even that setting doesn't stop it from occuring.

here's a picture, you can see one eye gets wider then the other as im moving through the stage in sm3

20211024_112815.jpg
 

Vague Rant

Deceptively cute
Member
Joined
Aug 7, 2008
Messages
2,378
Trophies
0
Location
Melbourne
Website
vaguerant.tumblr.com
XP
2,201
Country
what's this graphical issue called and how to avoid it in RA?
i hate the 'pixel perfect' aspect ratio but even that setting doesn't stop it from occuring.

here's a picture, you can see one eye gets wider then the other as im moving through the stage in sm3

View attachment 282529
What you're seeing there is nearest-neighbor scaling to a non-integer value. You're seeing it because the Integer Scale setting and the Aspect Ratio setting don't play very nice together. There's a few options you have here to avoid the issue:
  1. turn on Settings > Video > Bilinear Filtering; this will basically do a blurry scale from the original ~240p graphics to your RetroArch resolution. The issue will be gone, but you may like the blur even less.
  2. turn on Settings > Video > Scaling > Integer Scale and set Aspect Ratio to 1:1 PAR. This will guarantee every original game pixel is displayed over an exact multiple of pixels. e.g. a SNES game will display every single pixel as a 4x4 grid of Wii U pixels. There are two compromises you're making here: firstly, the image generally won't fill the whole screen for most platforms you emulate (e.g. 224 does not divide evenly into 480, 720 or 1080), so no matter what resolution your Wii U is configured to, you will have black borders around the edges of the screen at all times. Secondly, you are losing the original aspect ratio--pixels were not displayed as squares on any of these retro consoles, and in some cases they were extremely not-square, like CPS family arcade games, where if you display with 1:1 pixels, everything looks super wide, circles are ovals, etc.
  3. use the sharp-bilinear shader. This uses the Wii U's GPU to scale the image via nearest-neighbor to a perfect multiple (like option 2 above), then applies a bilinear filter (like option 1 above). This results in an image that's not quite as sharp as option 2, but way sharper than option 1, plus it allows you to use Aspect Ratio > Core Provided (or any other aspect ratio you like) without giving you any uneven pixels. Firstly, go to Main Menu > Online Updater > Update Slang Shaders, then load a game. Go to the Quick Menu > Shaders > Load > retro > sharp-bilinear.slangp, then scroll down and Apply Changes. It's possible this has been fixed by now, but when I first set this up on my end, I also had to enable Settings > Video > Bilinear Filtering to get that last filter step to work.
 

YukidaruPunch

Well-Known Member
Member
Joined
Oct 24, 2017
Messages
246
Trophies
0
Age
32
XP
593
Country
Brazil
What you're seeing there is nearest-neighbor scaling to a non-integer value. You're seeing it because the Integer Scale setting and the Aspect Ratio setting don't play very nice together. There's a few options you have here to avoid the issue:
  1. turn on Settings > Video > Bilinear Filtering; this will basically do a blurry scale from the original ~240p graphics to your RetroArch resolution. The issue will be gone, but you may like the blur even less.
  2. turn on Settings > Video > Scaling > Integer Scale and set Aspect Ratio to 1:1 PAR. This will guarantee every original game pixel is displayed over an exact multiple of pixels. e.g. a SNES game will display every single pixel as a 4x4 grid of Wii U pixels. There are two compromises you're making here: firstly, the image generally won't fill the whole screen for most platforms you emulate (e.g. 224 does not divide evenly into 480, 720 or 1080), so no matter what resolution your Wii U is configured to, you will have black borders around the edges of the screen at all times. Secondly, you are losing the original aspect ratio--pixels were not displayed as squares on any of these retro consoles, and in some cases they were extremely not-square, like CPS family arcade games, where if you display with 1:1 pixels, everything looks super wide, circles are ovals, etc.
  3. use the sharp-bilinear shader. This uses the Wii U's GPU to scale the image via nearest-neighbor to a perfect multiple (like option 2 above), then applies a bilinear filter (like option 1 above). This results in an image that's not quite as sharp as option 2, but way sharper than option 1, plus it allows you to use Aspect Ratio > Core Provided (or any other aspect ratio you like) without giving you any uneven pixels. Firstly, go to Main Menu > Online Updater > Update Slang Shaders, then load a game. Go to the Quick Menu > Shaders > Load > retro > sharp-bilinear.slangp, then scroll down and Apply Changes. It's possible this has been fixed by now, but when I first set this up on my end, I also had to enable Settings > Video > Bilinear Filtering to get that last filter step to work.
This is an excellent an super informative post. Thank you for that.
 

XDeltaOne

Have a good time ;)
Member
Joined
May 20, 2020
Messages
254
Trophies
0
XP
629
Country
Germany
What you're seeing there is nearest-neighbor scaling to a non-integer value. You're seeing it because the Integer Scale setting and the Aspect Ratio setting don't play very nice together. There's a few options you have here to avoid the issue:
  1. turn on Settings > Video > Bilinear Filtering; this will basically do a blurry scale from the original ~240p graphics to your RetroArch resolution. The issue will be gone, but you may like the blur even less.
  2. turn on Settings > Video > Scaling > Integer Scale and set Aspect Ratio to 1:1 PAR. This will guarantee every original game pixel is displayed over an exact multiple of pixels. e.g. a SNES game will display every single pixel as a 4x4 grid of Wii U pixels. There are two compromises you're making here: firstly, the image generally won't fill the whole screen for most platforms you emulate (e.g. 224 does not divide evenly into 480, 720 or 1080), so no matter what resolution your Wii U is configured to, you will have black borders around the edges of the screen at all times. Secondly, you are losing the original aspect ratio--pixels were not displayed as squares on any of these retro consoles, and in some cases they were extremely not-square, like CPS family arcade games, where if you display with 1:1 pixels, everything looks super wide, circles are ovals, etc.
  3. use the sharp-bilinear shader. This uses the Wii U's GPU to scale the image via nearest-neighbor to a perfect multiple (like option 2 above), then applies a bilinear filter (like option 1 above). This results in an image that's not quite as sharp as option 2, but way sharper than option 1, plus it allows you to use Aspect Ratio > Core Provided (or any other aspect ratio you like) without giving you any uneven pixels. Firstly, go to Main Menu > Online Updater > Update Slang Shaders, then load a game. Go to the Quick Menu > Shaders > Load > retro > sharp-bilinear.slangp, then scroll down and Apply Changes. It's possible this has been fixed by now, but when I first set this up on my end, I also had to enable Settings > Video > Bilinear Filtering to get that last filter step to work.
Unfortunately, it's stupid that the downloaded shaders don't work.
 

meeeow

Active Member
Newcomer
Joined
Aug 21, 2021
Messages
41
Trophies
0
XP
136
Country
Germany
What you're seeing there is nearest-neighbor scaling to a non-integer value. You're seeing it because the Integer Scale setting and the Aspect Ratio setting don't play very nice together. There's a few options you have here to avoid the issue:
  1. turn on Settings > Video > Bilinear Filtering; this will basically do a blurry scale from the original ~240p graphics to your RetroArch resolution. The issue will be gone, but you may like the blur even less.
  2. turn on Settings > Video > Scaling > Integer Scale and set Aspect Ratio to 1:1 PAR. This will guarantee every original game pixel is displayed over an exact multiple of pixels. e.g. a SNES game will display every single pixel as a 4x4 grid of Wii U pixels. There are two compromises you're making here: firstly, the image generally won't fill the whole screen for most platforms you emulate (e.g. 224 does not divide evenly into 480, 720 or 1080), so no matter what resolution your Wii U is configured to, you will have black borders around the edges of the screen at all times. Secondly, you are losing the original aspect ratio--pixels were not displayed as squares on any of these retro consoles, and in some cases they were extremely not-square, like CPS family arcade games, where if you display with 1:1 pixels, everything looks super wide, circles are ovals, etc.
  3. use the sharp-bilinear shader. This uses the Wii U's GPU to scale the image via nearest-neighbor to a perfect multiple (like option 2 above), then applies a bilinear filter (like option 1 above). This results in an image that's not quite as sharp as option 2, but way sharper than option 1, plus it allows you to use Aspect Ratio > Core Provided (or any other aspect ratio you like) without giving you any uneven pixels. Firstly, go to Main Menu > Online Updater > Update Slang Shaders, then load a game. Go to the Quick Menu > Shaders > Load > retro > sharp-bilinear.slangp, then scroll down and Apply Changes. It's possible this has been fixed by now, but when I first set this up on my end, I also had to enable Settings > Video > Bilinear Filtering to get that last filter step to work.
I downloaded the .zip via the online updater (and had to unpack it manually). Trying to load "sharp-bilinear.slangp" gives me an error: "Failed to apply shader preset bilinear.slang". It's the same problem with all other shaders. Do you know that might be the issue here?

edit:
I downloaded the shaders from this video and the sharp-linear Filter works:
I guess the original source is the following: https://github.com/Ta180m/RetroArch-Wii-U-Slang-Shaders (cick on code -> download as zip)
 
Last edited by meeeow,

ploggy

WAKA! WAKA!
Member
Joined
Aug 29, 2007
Messages
4,255
Trophies
1
XP
5,937
Country
United Kingdom
Confirmed!! My Wiimote, Switch Controller (via bloopair) and WiiU Gamepad can now all controller the UI at the same time!! @gblues :D :D :D :D

EDIT: your right about only the main controller can open the Menu :)

EDIT2: all controllers can open the Menu if you set a Menu Toggle Controller Combo in Hotkeys ;)
 
Last edited by ploggy,

september796

Well-Known Member
Member
Joined
May 4, 2015
Messages
234
Trophies
0
XP
777
Country
Cote d'Ivoire
What you're seeing there is nearest-neighbor scaling to a non-integer value. You're seeing it because the Integer Scale setting and the Aspect Ratio setting don't play very nice together. There's a few options you have here to avoid the issue:
  1. turn on Settings > Video > Bilinear Filtering; this will basically do a blurry scale from the original ~240p graphics to your RetroArch resolution. The issue will be gone, but you may like the blur even less.
  2. turn on Settings > Video > Scaling > Integer Scale and set Aspect Ratio to 1:1 PAR. This will guarantee every original game pixel is displayed over an exact multiple of pixels. e.g. a SNES game will display every single pixel as a 4x4 grid of Wii U pixels. There are two compromises you're making here: firstly, the image generally won't fill the whole screen for most platforms you emulate (e.g. 224 does not divide evenly into 480, 720 or 1080), so no matter what resolution your Wii U is configured to, you will have black borders around the edges of the screen at all times. Secondly, you are losing the original aspect ratio--pixels were not displayed as squares on any of these retro consoles, and in some cases they were extremely not-square, like CPS family arcade games, where if you display with 1:1 pixels, everything looks super wide, circles are ovals, etc.
  3. use the sharp-bilinear shader. This uses the Wii U's GPU to scale the image via nearest-neighbor to a perfect multiple (like option 2 above), then applies a bilinear filter (like option 1 above). This results in an image that's not quite as sharp as option 2, but way sharper than option 1, plus it allows you to use Aspect Ratio > Core Provided (or any other aspect ratio you like) without giving you any uneven pixels. Firstly, go to Main Menu > Online Updater > Update Slang Shaders, then load a game. Go to the Quick Menu > Shaders > Load > retro > sharp-bilinear.slangp, then scroll down and Apply Changes. It's possible this has been fixed by now, but when I first set this up on my end, I also had to enable Settings > Video > Bilinear Filtering to get that last filter step to work.
sharp-bilinear is the one that I needed. ty :D
 

Nomado

Well-Known Member
Newcomer
Joined
Mar 15, 2014
Messages
85
Trophies
0
Age
28
Location
Ulaanbaatar
XP
782
Country
Madagascar
Confirmed!! My Wiimote, Switch Controller (via bloopair) and WiiU Gamepad can now all controller the UI at the same time!! @gblues :D :D :D :D

EDIT: your right about only the main controller can open the Menu :)

EDIT2: all controllers can open the Menu if you set a Menu Toggle Controller Combo in Hotkeys ;)
Woah, so does that mean controllers are like they were back in 1.8.8? if so, this is a great news.
 
  • Like
Reactions: ploggy

ploggy

WAKA! WAKA!
Member
Joined
Aug 29, 2007
Messages
4,255
Trophies
1
XP
5,937
Country
United Kingdom
Woah, so does that mean controllers are like they were back in 1.8.8? if so, this is a great news.
Exactly. It's still in PR for now but once its merged it'll hit the buildbot, This has been one of the longest issues. A single fix increases WiiU RA usability by 50% ahah.
!WiiU forever!
 
  • Like
Reactions: Nomado

CORE

3:16
Member
Joined
Jul 15, 2018
Messages
1,148
Trophies
1
XP
1,825
Country
United Kingdom
SNES Super Scope Select Button not mapped via Touchscreen Mode?

Fire Button Works fine Hell it Awesome!!!

Any way to remap to Gamepad? The Button on Handle.

Has it already been mapped?

Port 1 SNES Joypad
Port 2 Super Scope
 

ploggy

WAKA! WAKA!
Member
Joined
Aug 29, 2007
Messages
4,255
Trophies
1
XP
5,937
Country
United Kingdom
SNES Super Scope Select Button not mapped via Touchscreen Mode?

Fire Button Works fine Hell it Awesome!!!

Any way to remap to Gamepad? The Button on Handle.

Has it already been mapped?

Port 1 SNES Joypad
Port 2 Super Scope
I have used the Touchscreen to play super scope games but I dont remember about the select button? It should be able to be mapped to the gamepad


EDIT: nope, doesnt look like its possible to map the other buttons on the Super Scope :P
 
Last edited by ploggy,
  • Like
Reactions: CORE

cugel

Well-Known Member
Member
Joined
Dec 5, 2018
Messages
115
Trophies
0
Age
43
XP
504
Country
United States
Does anyone technical know if the new linux driver allows for the direct management of files on usb drives? In this case for easily and quickly moving over a large rom collections that may contain complete dumps of Sega CD or PCE CD games.
 
General chit-chat
Help Users
    AncientBoi @ AncientBoi: [grabs my official Star Trek Disruptor] come in