Question Retroarch w/ mupen64 - UI/Textures offset on Ocarina/Mario Kart 64

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by imaethan, May 8, 2019.

  1. imaethan
    OP

    imaethan Newbie

    Newcomer
    1
    May 8, 2019
    Sweden
    Hey, I'm looking for some help as I've not been able to find anything to solve my issue.

    So I've been playing Ocarina of Time and Mario Kart 64 using Retroarch and the mupen64 core. Everything runs great apart from hud elements being offset. As well as 2d room textures in Oot not filling the screen properly, this also means when I'm talking to a character or focusing on an enemy the black bar that appears on the bottom of the screen is further up. Anyone got any ideas? It would be much appreciated.

    Added a screenshot of when I'm holding down the focus/lock on button. Note the heart is misplaced as well as the black bar.
     

    Attached Files:

  2. Pixen

    Pixen Newbie

    Newcomer
    2
    Jan 21, 2019
    Sweden
    There's a screenshot button on every Switch controller. As for the offset, are you using core provided AR or not? Hard to tell (again, see my first sentence) but if looks like you're running 4:3 whereas the textures might be tuned for a widescreen hack of some sort. Dät iss al aj kän pråvajd.
     
  3. imaethan
    OP

    imaethan Newbie

    Newcomer
    1
    May 8, 2019
    Sweden
    Core provided AR? Sorry about the photo, here's an actual screenshot. Yeah I'm using some HD texture pack but I don't think it's specifically for widescreen, even when I wasn't using the HD pack there was still problems with the black bar being offset as well as other UI elements.
     

    Attached Files:

  4. Pixen

    Pixen Newbie

    Newcomer
    2
    Jan 21, 2019
    Sweden
    I dunno about you but those icons look stretched out. Got any link to the texture pack you're using? I could check it out.
     
  5. imaethan
    OP

    imaethan Newbie

    Newcomer
    1
    May 8, 2019
    Sweden
    I can't post links but the texture pack is called Djipi Zelda 2015. It's not really my issue though, as the original icons appear to look the same without the texture pack.
     

    Attached Files:

  6. imaethan
    OP

    imaethan Newbie

    Newcomer
    1
    May 8, 2019
    Sweden
    Okay I've fixed the problem. Turns out "Framebuffer Emulation" was set to False when it should have been True.
     
  7. stitchxd

    stitchxd GBAtemp Fan

    Member
    3
    Apr 27, 2017
    United States
    nope
    You are using mupen-next right?
     
  8. imaethan
    OP

    imaethan Newbie

    Newcomer
    1
    May 8, 2019
    Sweden
    I am, aye. It's working great now I fixed the Framebuffer Emulation option.
     
  9. ganons

    ganons GBAtemp Addict

    Member
    6
    Jun 12, 2005
    Full speed with textures?
     
  10. imaethan
    OP

    imaethan Newbie

    Newcomer
    1
    May 8, 2019
    Sweden
    Aye, a pretty solid 50fps I guess since it's the PAL version? Knocked the resolution down a notch though. Also running one of the higher overclocks.
     
    ModderFokker619 likes this.
Loading...