Homebrew RetroArch Switch

rasqba

Member
Newcomer
Joined
Sep 25, 2015
Messages
15
Trophies
0
Age
26
XP
56
Country
Poland
Recently I updated my switch from 6.1 with 1.7.5 retroarch, to 6.2 and the newest nightly, and now I'm getting a strange slowdown in some games (tested NES and SNES games).

The slowdown happens once in a minute or two, and lasts about 1-2 seconds. Completely randomly, in different parts of the game. Looks like the game just slows down 25% for 2 seconds and then goes back to normal again.

Anyone knows what could be the cause? Any way to find it myself?

EDIT: I installed the old version of retroarch, and the problem is gone. Anything I should try next?
 
Last edited by rasqba,

zacly

Well-Known Member
Newcomer
Joined
Oct 5, 2018
Messages
61
Trophies
0
Age
36
XP
142
Country
Canada
I downloaded the latest nightly and ran retroarch with full ram and I still get slowdown on mario 64. Do 64 games still need to be overclocked to work? If not, what settings should I be changing other than threaded video?
 

Billy Acuña

Well-Known Member
Member
Joined
Oct 10, 2015
Messages
3,124
Trophies
1
Age
28
XP
3,585
Country
Mexico
I downloaded the latest nightly and ran retroarch with full ram and I still get slowdown on mario 64. Do 64 games still need to be overclocked to work? If not, what settings should I be changing other than threaded video?
Delete "retroarch_core_options.cfg" from retroarch folder, most of the games should be fullspeed with default settings
 
  • Like
Reactions: nevdee and zacly

zacly

Well-Known Member
Newcomer
Joined
Oct 5, 2018
Messages
61
Trophies
0
Age
36
XP
142
Country
Canada
thanks.. I went to the options and hit the + on every option (after loading a game) to set options back to default and then saved over the core options. I guess its the same thing but just a different way. I was helped over on their discord. Thanks for your response!
 
  • Like
Reactions: sorabora and nevdee

lordelan

Well-Known Member
Member
Joined
Jan 4, 2015
Messages
5,233
Trophies
1
Age
41
XP
4,942
Country
Germany
Check the settings under "Settings > Configuration" and make sure Load Content Specific Core Options Automatically" is turned "ON".
Turns out I was stupid. I went to Overrides in quick menu to save a game specific file instead of creating that from within the core options (first entry there).
Now it works and I can save settings per game. Thx. :)
 
  • Like
Reactions: FanboyKilla

hippy dave

BBMB
Member
Joined
Apr 30, 2012
Messages
7,229
Trophies
1
XP
8,819
Country
United Kingdom
I downloaded the latest nightly and ran retroarch with full ram and I still get slowdown on mario 64. Do 64 games still need to be overclocked to work? If not, what settings should I be changing other than threaded video?
FWIW if you're planning to play through the whole game, most of Mario 64 runs fullspeed without OC, but some parts like the submarine level do need OC.
 

minomore

Well-Known Member
Member
Joined
Dec 25, 2015
Messages
101
Trophies
0
Age
35
XP
1,260
Country
Just a bit of a random question. For playing original gameboy games (B/W) in colour what is the best emu and settings

Many thanks
 

lordelan

Well-Known Member
Member
Joined
Jan 4, 2015
Messages
5,233
Trophies
1
Age
41
XP
4,942
Country
Germany
Just a bit of a random question. For playing original gameboy games (B/W) in colour what is the best emu and settings

Many thanks
Gambatte. Head to core options there and you'll find what you've been looking for. Could be that you need the GBC Bios though. Not sure about that as I have that in place.
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: https://www.youtube.com/watch?v=iu7IqpcRuxM