Homebrew RetroArch Switch

JohnMiller91

Member
Newcomer
Joined
Apr 9, 2018
Messages
20
Trophies
0
Age
36
XP
260
Country
Germany
Was anyone able to get Pokemon Snap working? Game runs fine but after finishing first round I cant select any of the pictures taken to show to the Prof...
 

focusonme

Well-Known Member
Member
Joined
Jun 30, 2016
Messages
223
Trophies
0
Age
32
XP
409
Country
United States
i am currently on 5.1. is emulation performance better on 6.x? or should i stay on 5.1?

--------------------- MERGED ---------------------------

Was anyone able to get Pokemon Snap working? Game runs fine but after finishing first round I cant select any of the pictures taken to show to the Prof...
same here :(
 

lordelan

Well-Known Member
Member
Joined
Jan 4, 2015
Messages
5,269
Trophies
1
Age
42
XP
5,062
Country
Germany
Hey is there a way to use retroarch with an external USB, which is inserted in the docking station?
Cause I can't use retroarch on my ExFat formatted internal microSD card. So I wanted to use an external USB drive (Fat format).
1. Not yet. Maybe in the future.
2. A friendly hint: use FAT32.
 

protomouse

Active Member
Newcomer
Joined
Feb 1, 2014
Messages
44
Trophies
0
Age
34
XP
476
Country

zomgugoff

Well-Known Member
Newcomer
Joined
May 8, 2016
Messages
89
Trophies
0
Age
38
XP
577
Country
United States
I've built the px68k core for Switch, and it seems to run well except the games run a bit too fast on load (60 FPS instead of 55 FPS), which going into the quick menu and back again seems to fix.

This is really good. I haven't played enough X68K to know when something's running the wrong speed, but I'm still loving it.

EDIT: Is there a trick to getting analog working?
 
Last edited by zomgugoff,

Talha_Yilmaz

Well-Known Member
Newcomer
Joined
May 20, 2013
Messages
56
Trophies
0
Age
30
XP
206
Country
Gambia, The
Hey guys, i really try to like RetroArch but it does not like me, i guess. I have constant problems with it.

I have a Switch with 6.1.0 and SXOS 2.5.

RetroArch does not start anymore. Have both tried the NSP and the NRO versions. I tried reinstalling them multipile times. I tried different SX versions but still it does not start. After the little NX Logo on the bottom right of the screen, it turns black.

Do you know why its not workling?
 

protomouse

Active Member
Newcomer
Joined
Feb 1, 2014
Messages
44
Trophies
0
Age
34
XP
476
Country
This is really good. I haven't played enough X68K to know when something's running the wrong speed, but I'm still loving it.

EDIT: Is there a trick to getting analog working?

Should just work. Which game?

Cool! Did you make a PR for it to be included in the main repo? :)

I will once it's been sufficiently tested (any help appreciated there!) and the frame rate issue has been resolved. I can't reproduce it on RetroArch Linux.
 
  • Like
Reactions: lordelan

angelhp

Well-Known Member
Member
Joined
Nov 30, 2014
Messages
500
Trophies
0
XP
1,559
Country
United States
Should just work. Which game?



I will once it's been sufficiently tested (any help appreciated there!) and the frame rate issue has been resolved. I can't reproduce it on RetroArch Linux.
i cant play "Super mario" ?
I can pass title screen
also "Battle tank"
 

ElConsolero

Well-Known Member
Member
Joined
Jan 22, 2014
Messages
107
Trophies
0
Age
49
XP
1,023
Country
Gambia, The
Hey guys, i really try to like RetroArch but it does not like me, i guess. I have constant problems with it.

I have a Switch with 6.1.0 and SXOS 2.5.

RetroArch does not start anymore. Have both tried the NSP and the NRO versions. I tried reinstalling them multipile times. I tried different SX versions but still it does not start. After the little NX Logo on the bottom right of the screen, it turns black.

Do you know why its not workling?

No, I use same FW and SX OS and Retroarch (.nsp and .nro) works pretty well on my Switch. Did you just overwrite the files or did you delete folders? maybe, an old config file cause the error? or your sd card has an error? is it formatted exFat or fat32?
 

lordelan

Well-Known Member
Member
Joined
Jan 4, 2015
Messages
5,269
Trophies
1
Age
42
XP
5,062
Country
Germany
Hey guys, i really try to like RetroArch but it does not like me, i guess. I have constant problems with it.

I have a Switch with 6.1.0 and SXOS 2.5.

RetroArch does not start anymore. Have both tried the NSP and the NRO versions. I tried reinstalling them multipile times. I tried different SX versions but still it does not start. After the little NX Logo on the bottom right of the screen, it turns black.

Do you know why its not workling?
Best thing to do is completely delete your sd:\retroarch folder.
You could try starting over with another sd card or format yours but deleting that folder should be enough.
 
  • Like
Reactions: Talha_Yilmaz

stoffer666

Well-Known Member
Newcomer
Joined
May 21, 2018
Messages
62
Trophies
0
Age
39
XP
839
Country
Denmark
Hey guys, i really try to like RetroArch but it does not like me, i guess. I have constant problems with it.

I have a Switch with 6.1.0 and SXOS 2.5.

RetroArch does not start anymore. Have both tried the NSP and the NRO versions. I tried reinstalling them multipile times. I tried different SX versions but still it does not start. After the little NX Logo on the bottom right of the screen, it turns black.

Do you know why its not workling?
Try and delete your retroarch.cfg file with in retroarch folder.
 
  • Like
Reactions: Talha_Yilmaz
General chit-chat
Help Users
    Veho @ Veho: We must arm all the robots, it's the only way to be safe.