RetroArch - Menu Malfunction and Unstable Cores

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by Notshane, Jan 13, 2019.

  1. Notshane
    OP

    Notshane GBAtemp Regular

    Member
    3
    Dec 13, 2012
    United States
    I really, really wanted to be done with this. I just finished setting up RetroArch, finally got the playlists to work properly and even the controller and game icons to load. But for some unknown reason, I am stuck here:

    Warning: Spoilers inside!

    This picture is showing the part I am already stuck in. The moment I load it now, none of the inputs work and I can only use the standard buttons that always do the same thing they're meant to do, being Home and Screenshot. I am stuck here and I don't know why I can't navigate the menu at all. The "ozone" plugin already has its weird fair share of problems though, which is rather unfortunate since it's the most attractive UI available on RetroArch, and at random points whenever a certain game is loaded, it goes back to this interface (same UI, albeit this picture appears to be from an Android):

    Warning: Spoilers inside!

    Normally, whenever this happens, I just close RetroArch (as it also disappears from the Menu Driver for whatever reason until I restart), open it up, navigate back to Menu Driver, confirm "ozone" and then I have to hit "Quit" since "Restart" appears to do nothing, even though it works fine for every other Menu Driver. And after I reloaded, well, here we are. This is the first time this has happened and I have no idea what to do. I am completely slumped.

    The last part of the title mainly refers to two emulators I've been struggling to get working, being the ones that run the N64 and MAME respectively. I have tried a good amount of N64 games now and they all completely crash the Switch, well MAME does the same thing. Mega-CD and TurboGrafx-CD do the same thing too, actually, now that I think about it. I have no idea why this happens and I know it can't be the fault of the Switch since I've seen people successfully play these emulators on YouTube. If anyone knows what I need to do in order to get these cores to run, please let me know.
     
    Last edited by Notshane, Jan 13, 2019
  2. Notshane
    OP

    Notshane GBAtemp Regular

    Member
    3
    Dec 13, 2012
    United States
    Um, sorry! I did mean to put this into "Switch - Exploits, Custom Firmwares & Soft Mods" but I went to the wrong one!
     
  3. stick267

    stick267 Advanced Member

    Newcomer
    1
    Dec 17, 2018
    United States
    I've experienced both of those issues. Deleting the retroarch.cfg fixed the inputs not registering.

    How do you launch Retroarch? If I use the installed NSP then my menu is fine. But if I side launch it while holding R it never saves my menu choice and always defaults to the second one you pictured.
     
  4. Notshane
    OP

    Notshane GBAtemp Regular

    Member
    3
    Dec 13, 2012
    United States
    I have auto-RCM, but I hear Nintendo can ID ban Switchs, so I avoid installing NSPs in case I lose functionality of the tablet and still load off Album.
     
  5. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    That's the problem.
    You might need to install RA as an NSP.
    Only other workaround I can think of is if you side-load RetroArch through title redirection or something like that.
    I haven't read deeply into it, but I think you can bypass a game loading and make it load a homebrew app instead.
     
  6. m4xw

    m4xw Ancient Deity

    Member
    13
    May 25, 2018
    Germany
    Nah he is just mixing stable and nightly stuff.
    He will select ozone on nightly, but then use the stable loader which fallbacks to glui (which then saves)
     
    mikifantastik98 and ShadowOne333 like this.
  7. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    Ah I see.
    So he needs to update everything he has to latest nightly versions then?
     
  8. stick267

    stick267 Advanced Member

    Newcomer
    1
    Dec 17, 2018
    United States
    The only nightly component that I'm using is the mupen64 core. Everything else is 1.7.5. Could this still be causing the issue?
     
  9. Notshane
    OP

    Notshane GBAtemp Regular

    Member
    3
    Dec 13, 2012
    United States
    I don't know why CPU Overclock is back on there, but I'm pretty sure I had the stable release.
     
  10. m4xw

    m4xw Ancient Deity

    Member
    13
    May 25, 2018
    Germany
    Abso-freaking-lutely
    It breaks your playlists for older versions (since the merge a few days ago).
    Just a example.
     
    stick267 likes this.
  11. stick267

    stick267 Advanced Member

    Newcomer
    1
    Dec 17, 2018
    United States
    Interesting. Thanks for the info.
     
  12. m4xw

    m4xw Ancient Deity

    Member
    13
    May 25, 2018
    Germany
    1.7.6 isnt far away tho
     
  13. Notshane
    OP

    Notshane GBAtemp Regular

    Member
    3
    Dec 13, 2012
    United States
    N64 doesn't work at all on RetroArch. Once they get it up and running, someone should let me know. Same with TurboGrafx-CD and Mega-CD.
     
  14. m4xw

    m4xw Ancient Deity

    Member
    13
    May 25, 2018
    Germany
    Thats called Layer 8
     
    a9lh-1user likes this.
  15. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    But N64 works... ? :unsure:
    It has been for a while, with both Overclocking and the beta dynarec.
    You should really try to update all of your stuff, including Mupen64, there is even beta support for HD textures.
     
  16. m4xw

    m4xw Ancient Deity

    Member
    13
    May 25, 2018
    Germany
    Another case of starting-from-album-cant-read-docs and a bunch of missing BIOS' and I bet his mame issue is a unsupported romset.
    At this point I can just say, RTFM
     
    Last edited by m4xw, Jan 15, 2019
    ShadowOne333 likes this.
  17. Notshane
    OP

    Notshane GBAtemp Regular

    Member
    3
    Dec 13, 2012
    United States
    Anytime I open N64, it crashes. Got it off here:

    http://retroarch.com/?page=platforms

    And that menu changing is really obnoxious since ozone is the only one that jumps to another menu whenever I open certain games. Hopefully, 1.7.6 is more consistent. Every other emulator is great, well besides TurboGrafx-CD and Mega-CD not working either and also completely crashing the tablet upon attempting to start a game.
     
  18. m4xw

    m4xw Ancient Deity

    Member
    13
    May 25, 2018
    Germany
    I just told you all your Issues.
     
  19. Notshane
    OP

    Notshane GBAtemp Regular

    Member
    3
    Dec 13, 2012
    United States
    I downloaded all the cores off RetroArch, then updated them. I've done everything that I can do. Must all be sided with the Album then I guess. Screw it, if installing the NSP fixes all these dumb menu and core issues, I will just risk it and do it anyway.
     
  20. m4xw

    m4xw Ancient Deity

    Member
    13
    May 25, 2018
    Germany
    Yea. Use the bundles else you will never update the /switch loader, which is a full RA build by itself.
    That way you will only mix a ancient build of retroarch with newer versions.
    Also you absolutely dont need NSP, rather use https://gbatemp.net/threads/use-atmosphere-to-access-full-ram-with-homebrews-without-nsp.521240/
    NSP for N64 will be deprecated.
     
    ShadowOne333 likes this.
Loading...