1. Suikoden77

    Suikoden77 Member
    Newcomer

    Joined:
    Feb 5, 2010
    Messages:
    22
    Country:
    Hi guys, I have set up this weekend my vita with a raspberry and vitadockplus (https://github.com/SilentNightx/VitaDockPlus) and it recommends the MiniVitaTV plugin. However, when this plugin is installed I can't make the retroarch run any game, the app closes before loading the game. Does it happen to you too? Is there any guide to compile retroarch into vpk to test latest releases?
     
  2. FmT

    FmT Advanced Member
    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    67
    Country:
    Japan
    When MiniVitaTV plugin is activated, are you using dualshock ? if you are, are you launching the game from a playlist or from "load content" menu ? There was a similar bug on VitaTV before with retroarch, but you could still launch a game from "load content".

    To make your own builds of retroarch you need VitaSDK :
    https://github.com/vitasdk/vdpm

    Libretro-super is all you need to make your own compilation of retroarch :
    https://github.com/libretro/libretro-super

    Or simply get recent offical nightlies on : http://buildbot.libretro.com/nightly/playstation/vita/
     
  3. Suikoden77

    Suikoden77 Member
    Newcomer

    Joined:
    Feb 5, 2010
    Messages:
    22
    Country:
    Exactly, I am using a dualshock 4. And yes, I was trying to load the games from the playlists. However, I just tested from the load content menu and the same happens. In any case, I will try getting the latest nightlies in your link, because I downloaded the app through Vita Homebrew Browser / pkgj and it is possible that is an outdated version.

    Thanks for your help!

    Update:
    I have tried the last nightlies and seems to keep happening. I will try go go to previous versions to check if still happens
     
    Last edited by Suikoden77, Apr 5, 2021
  4. AkitoUF

    AkitoUF GBAtemp Regular
    Member

    Joined:
    Jan 5, 2016
    Messages:
    231
    Country:
    Chile
    Objectively talking there's no reason to upgrade to the latest version yet am I right?
     
  5. AllanFF

    AllanFF Member
    Newcomer

    Joined:
    Feb 5, 2021
    Messages:
    15
    Country:
    Brazil
    I was thinking about that too, after reading the changelog, there's not much changes specifically to Vita users.

    There are some global changes though, but since gpsp is crashing, I don't think I'll update for now.
     
    Rahkeesh likes this.
  6. FmT

    FmT Advanced Member
    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    67
    Country:
    Japan
    You should get last nightly as gPSP is fixed and have been worked a lot. mgba is present too. Can test a lot of gba games !
     
  7. Rahkeesh

    Rahkeesh GBAtemp Advanced Maniac
    Member

    Joined:
    Apr 3, 2018
    Messages:
    1,930
    Country:
    United States
    Don't know who cares about Hatari but that's gotten some love, with more games now supporting joystick, so with gPSP nightlies fixed I'll be happy to upgrade.

    Edit: and regretting that upgrade, Sonic Advance 2 is crashing on freaking attract mode.
     
    Last edited by Rahkeesh, Apr 6, 2021
    MKKhanzo likes this.
  8. Evilmitaka

    Evilmitaka Newbie
    Newcomer

    Joined:
    Nov 30, 2017
    Messages:
    5
    Country:
    Mexico
    Is any of you, noted worst performance than before in the snes cores if you set the a better audio quality even with 2002? in 1.9.1 stable
     
  9. mosslump

    mosslump Member
    Newcomer

    Joined:
    Jun 11, 2020
    Messages:
    13
    Country:
    United States
    I am glad someone did this experiment! :) Wonder if the older versions of the patches will resurface as all the links are long dead.

    On the latest nightly 4/13 however, (only one I have tested) gpSP crashes within a minute with just about all gba roms I have tested, ff6 or otherwise.
     
    Last edited by mosslump, Apr 13, 2021
  10. FmT

    FmT Advanced Member
    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    67
    Country:
    Japan
    I've uploaded the IPS patch collection of FF5A and FF6A : FF5A 2.0a and FF6A 1.1 should working fine. The latest version FF5A 3.0a and FF6A 2.1 will have problem with emulators, but are working fine on a real gba / ds / 3ds

    https://1fichier.com/?hn8beh6qhqxu5klwbaq5

    You need an IPS Patcher program to apply, files come with their original readme.txt
     
    Last edited by FmT, Apr 13, 2021
    mosslump likes this.
  11. kristianity77

    kristianity77 GBATemp old fogey
    Member

    Joined:
    Jul 10, 2003
    Messages:
    1,629
    Country:
    United Kingdom
    Whats the deal on the nightlies with retroarch.vpk and a retroarch piglet vpk? Whats the difference?
     
  12. AllanFF

    AllanFF Member
    Newcomer

    Joined:
    Feb 5, 2021
    Messages:
    15
    Country:
    Brazil
    As far as I know Piglet Retroarch uses a new technology, but it's not fully optmized yet, so betetr leavei it for now.
     
  13. kristianity77

    kristianity77 GBATemp old fogey
    Member

    Joined:
    Jul 10, 2003
    Messages:
    1,629
    Country:
    United Kingdom
    I downloaded the normal version and yeah I think I'll leave Retroarch alone on the vita, the constant crashing is enough for me to not bother
     
  14. Rahkeesh

    Rahkeesh GBAtemp Advanced Maniac
    Member

    Joined:
    Apr 3, 2018
    Messages:
    1,930
    Country:
    United States
    Piglet can at least see shaders but doesn't seem to apply any. I think it might just be there to support the experimental flycast for now.

    But yeah gPSP is still very crashy, whatever fix either wasn't pushed or it didn't do what was advertised.
     
  15. kristianity77

    kristianity77 GBATemp old fogey
    Member

    Joined:
    Jul 10, 2003
    Messages:
    1,629
    Country:
    United Kingdom
    What was the last version of retroarch to run that gpsp was relatively stable as I may roll back to that.
     
  16. FmT

    FmT Advanced Member
    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    67
    Country:
    Japan
    Last edited by FmT, Apr 14, 2021
    cvskid likes this.
  17. AllanFF

    AllanFF Member
    Newcomer

    Joined:
    Feb 5, 2021
    Messages:
    15
    Country:
    Brazil
    Does it happen on every game ?
     
    Last edited by AllanFF, Apr 14, 2021
  18. kristianity77

    kristianity77 GBATemp old fogey
    Member

    Joined:
    Jul 10, 2003
    Messages:
    1,629
    Country:
    United Kingdom
    No, from having a couple of hours messing around it seems its just gpsp. Snes, genesis, gameboy etc all working fine.
     
    Rahkeesh likes this.
  19. AllanFF

    AllanFF Member
    Newcomer

    Joined:
    Feb 5, 2021
    Messages:
    15
    Country:
    Brazil
    I did not try GBA Emulation on Vita yet, but I'm confortably emulating SNES, and it's working well. I'm on 1.9.0
     
  20. LibretroRetroArc

    LibretroRetroArc GBAtemp Advanced Fan
    Member

    Joined:
    Aug 24, 2012
    Messages:
    748
    Country:
    Netherlands
    Regarding the gpSP libretro regression for Vita - this is an unfortunate issue that has crept in as part of the many improvements/refactors. However, the lead author will get a Vita soon so that we can hopefully fix this crash bug once and for all.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - RetroArch, Nightlies, Libretro