ret = -2011?

Discussion in 'Wii - Hacking' started by DerekHill, Dec 21, 2011.

  1. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    navigating through custom ios installer 2.3

    1.ios36
    2.ios56 v5661
    3.ios249
    4.WAD install
    5.wii sd slot

    instaaling custom IOS, please wait...
    >>install ERROR! (ret = -2011)

    so....wtfs up?

    running 4.3U and trying to get USB loader GX working.

    if you need other info lemme know and ill do the best i can to tell you. im still fairly new to all this.
     


  2. obcd

    obcd GBAtemp Advanced Maniac

    Member
    1,594
    278
    Apr 5, 2011
    Belgium
    I don't know that program, but it looks like the error is caused by the program not using an ios with the proper rights to install the cios.
    It might help if you could post a syscheck of all your wii installed ios.

    Did you follow any guide to install the cios?
     
  3. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    well for the sake of trying to get it to work, do you have 4.3U and a working usb loader? syscheck came back with nothing saying everything checked out.
     
  4. obcd

    obcd GBAtemp Advanced Maniac

    Member
    1,594
    278
    Apr 5, 2011
    Belgium
    Looks like you used the modmii syscheck that finds out if every ios is up to date?
    I was talking about the general one that shows the revisions of all installed ios and their goodies.
    I live in europe, so my wii is on the E system menu.
    What cios are you trying to install? Did you follow a guide for your softmod? Maybe all the proper cios are already installed, and wan't allow you to overwrite them.
    If your run usbloader_gx, what is happening?
     
  5. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    http://www.youtube.com/watch?v=UO2Md7j4n4Q

    trying tof ollow this part. but it crashes at the cIOS
     
  6. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    if i run usb loader it gives me an error that ios249 or 222 is not installed. but when i try to install it i get the -2011 error.
     
  7. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    I only watched the video till 0:55 and i can suspect that you are not following it.
     
  8. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    sec recorded a video

    http://www.youtube.com/watch?v=4qoOG__cR3k
     
  9. DaMan4169

    DaMan4169 Advanced Member

    Newcomer
    95
    4
    Aug 12, 2009
    United States
    You should be using 236 not 36 to install and unless you want controller lag you should just use rev21d2x cIOS. Also if you really do have USB loader GX 1.0 r866, you will need to update to at least 2.0, cIOS rev19 support wasn't added until gx 1.0 r922.......

    http://gbatemp.net/topic/149922-usb-loader-gx/ has link for gx 2.3, pretty sure you need to be running Homebrew on IOS58 for latest version.
     
  10. obcd

    obcd GBAtemp Advanced Maniac

    Member
    1,594
    278
    Apr 5, 2011
    Belgium
    The youtube tutorial is a little outdated. You might try modmii for windows instead. It's very up to date, and you will get better support (altough you probably won't need it) here, as most people know it.
    Just start over as if your wii was never modded before. Check the HBC to make sure that it's using ios 58 If that's the case, you might skip the initial softmodding steps that lead to installing the hbc.

    Backup your wii nand with bootmii and keep the nand.bin and keys.bin somewhere safe on your pc. If something goes wrong, they are the ultimate rescue solution.
     
  11. JoostinOnline
    This message by JoostinOnline has been removed from public view by a moderator, Sep 22, 2017.
    Dec 22, 2011
  12. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,537
    21,496
    Sep 13, 2009
    Poland
    Gaming Grotto
    Been answered a hundred times - IOS locked out for installation, HASH check failed, error returned.

    It's very likely that the IOS used for installation is not Trucha Bug'd or doesn't have NAND priviledges. Run a Syscheck and post the results here.

    Alternatively, if you're in a bit of a hurry, use a different IOS that has NAND priviledges and is Trucha Bug'd for your installation.

    This way or another this smells like AnyTitle Deleter action to me.
     
  13. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    ok, so lets start from step 1. what is the list of programs i should be using and what guide should i be following.
     
  14. obcd

    obcd GBAtemp Advanced Maniac

    Member
    1,594
    278
    Apr 5, 2011
    Belgium
    Modmii for windows by Xflak. It's in the wii hacking stickies. It will download the rest for you.

    If you have the HBC 1.08 running on ios 58 and bootmii working, you can skip the steps for installing those. In that case, just use bootmii to backup your nand first.

    otherwise, just follow the modmii tutorial as if your wii was not modded.
     
  15. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    got to wad manager but says failed to mount sd any suggestions? so far everything has been smooth.
     
  16. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    reload to IOS236 and try again
     
  17. kylster

    kylster mich weich töten

    Member
    1,395
    32
    Sep 11, 2010
    United States
    Fr33D0M R1N6
    You may want to grab the newest cios installer v3.1 from here http://code.google.com/p/d2x-cios-installer/downloads/list
     
  18. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    also there was no gx loader that came with it.

    i tried reloading ios236 and it still wont mount the sd card.
     
  19. kylster

    kylster mich weich töten

    Member
    1,395
    32
    Sep 11, 2010
    United States
    Fr33D0M R1N6
    You can download USB Loader GX from here beta: http://code.google.com/p/usbloader-gui/issues/detail?id=1769 ; GBAtemp fourms: http://gbatemp.net/topic/149922-usb-loader-gx/

    If your trying to install a .WAD you could try installing it from your pc over Wifi using apps like Wiiload or I really like Transmitemii: http://wiibrew.org/wiki/TransmitMii ; just enter the HBC and and from you PC send the Wad over just make sure you are connected to the internet :)
     
  20. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    make sure u have SD:\WAD\ on the sd card, it should be there if u used ModMii properly. If that's there and mmm still isn't able to load your sd card, either try another sd card, or try another wad manager (ie. yawmm or wiimod), or try installing the wads from a FAT32 HDD instead of an sd card.
     
  21. DerekHill
    OP

    DerekHill Member

    Newcomer
    12
    0
    Dec 21, 2011
    the only problem now is its still not accepting cIOS, i cant get 249 to get usb loader working.