[Repair question] GBA with AGS-101 mod flickers / horizontal lines. How to fix?

Discussion in 'GBA - Hardware, Devices and Utilities' started by geyser, Dec 15, 2016.

  1. geyser
    OP

    geyser Member

    Newcomer
    15
    3
    Dec 15, 2016
    Serbia, Republic of
    Gameboy Advance with AGS-101 mod, 40PIN motherboard, standard soldering wire P1+DA1. After switch ON everything is OK, later after 10-15 minutes it start flickering with thin black horizontal lines, different location. Adjusting potenciometer solve the problem for a while, but then "scan lines" appears again.



    Anyone face with such issue? Any suggestion? Any US modders can help locally?
     
  2. malheur

    malheur Advanced Member

    Newcomer
    51
    40
    Oct 11, 2016
    pot just affects the scan line. so turn it back to where it was, and i think that random black horizontal line is simply cable problem. pull out the ribbon cable and clean or blow every(lcd, lcd side of the ribbon, mother board, mobo side of the ribbon) side and put it back together would be fix. 50% sure.
     
    slaphappygamer and tatumanu like this.
  3. geyser
    OP

    geyser Member

    Newcomer
    15
    3
    Dec 15, 2016
    Serbia, Republic of
    thanks, will try that, but pot in different position cause the same result, lines appears again after 5-10 minutes in game
     
  4. malheur

    malheur Advanced Member

    Newcomer
    51
    40
    Oct 11, 2016
    potentiometer is not solve anything in your case. because it is simply your symptom does not involve potentiometer.
     
  5. rs1n

    rs1n Advanced Member

    Newcomer
    81
    20
    Jul 26, 2013
    United States
    My guesses would be:

    1) Screen is getting too much pressure (make sure that the case has been modified properly to hold the LCD and that unnecessary "liners" are removed so that when closing the case, there is no pressure on the screen.

    2) Connector not properly seated.
     
  6. geyser
    OP

    geyser Member

    Newcomer
    15
    3
    Dec 15, 2016
    Serbia, Republic of
    1) screen is ok, all liners removed, screen placement well dremeled
    2) this is the only i need to check, GBA now is about 10k miles away, will reply shortly :)
     
  7. cybershark

    cybershark Newbie

    Newcomer
    1
    0
    Jan 11, 2017
    Brazil
    Hi,

    I have exactly the same problem, a GBA modded with AGS-101 screen.

    The mod that i'm using is the malheur and gaggi method, as described here:
    https://gbatemp.net/threads/40-pin-gba-with-white-tab-lcd-perfect-solution.448597/

    The flickering occurs with different levels of intensity, and sometimes it doesn't happen for a few seconds.

    Should i put another trimpot in between CP3 and the top solder point of R15 and tweak it?

    Thank you
     
    Last edited by cybershark, Jan 11, 2017