1. Rasa39

    Rasa39 LovesCuteShiz
    Member

    Joined:
    Aug 16, 2015
    Messages:
    313
    Country:
    United Kingdom
    I've got 9.0 keys but still get the "are keys correct?" error when trying to use it on any 9.x updates. Everything other fw works, just not the latest.
     
  2. anothertemper

    anothertemper Advanced Member
    Newcomer

    Joined:
    Oct 12, 2016
    Messages:
    60
    Country:
    Works on the Luigi's Mansion update. Thanks!
     
  3. Czupakabra

    Czupakabra Newbie
    Newcomer

    Joined:
    Oct 30, 2019
    Messages:
    5
    Country:
    Poland
    Hi ,

    Can you tell me how you did it ?

    I have keys - dumped form Lockpick and NSP. Im trying to do something with it because its not working on atmo 0.94 and 9.0.1 and im getting error like :
    Unknown meta type! Are keys correct?

    In renxpack_extracted_nsp i have NCA files and i dont know what to do with it. Can somebody tell me what to do ?
    Cheers
     
  4. anothertemper

    anothertemper Advanced Member
    Newcomer

    Joined:
    Oct 12, 2016
    Messages:
    60
    Country:
    I found a set of 9.0 keys. I'm not too well-versed in this but it seems like if you're trying to convert the nsp that you are not on a 9.0 firmware, and thus would not have the 9.0 keys to dump from your console. You need to find a set of 9.0 keys and use those for the program. I'm pretty sure I'm not allowed to post those here, though.
     
  5. Czupakabra

    Czupakabra Newbie
    Newcomer

    Joined:
    Oct 30, 2019
    Messages:
    5
    Country:
    Poland

    Any chance to give me only some tips where i have to search ;) i know that i cant send a private msg but maybe you can send a github link for example ;) Cheers
     
  6. Clydefrosch

    Clydefrosch GBAtemp Guru
    Member

    Joined:
    Jan 2, 2009
    Messages:
    5,494
    Country:
    Germany
    is it normal for updates to end up much smaller after conversion?
     
  7. The-4n

    OP The-4n GBAtemp Fan
    Member

    Joined:
    Aug 3, 2018
    Messages:
    430
    Country:
    United States
    If they contain DeltaFragments, yes
     
  8. linuxares

    linuxares I'm not a generous god!
    Moderator

    Joined:
    Aug 5, 2007
    Messages:
    7,243
    Country:
    Sweden
    Curious question, what are DeltaFragments?
     
  9. Clydefrosch

    Clydefrosch GBAtemp Guru
    Member

    Joined:
    Jan 2, 2009
    Messages:
    5,494
    Country:
    Germany
  10. Advanced User

    Advanced User Advanced Member
    Newcomer

    Joined:
    Jan 20, 2014
    Messages:
    58
    Country:
    I would like to remain on firmware 8.0 for the time being because there seem to be many issues with 9.0. So how do I get the necessary 9.0 keys? Aren't they console specific?
     
  11. Advanced User

    Advanced User Advanced Member
    Newcomer

    Joined:
    Jan 20, 2014
    Messages:
    58
    Country:
    Update: I found out that the keys are identical for all consoles, except for secure_boot_key and tsec_key. After a long search I found a pastebin post from September 15, which I assumed were the 9.0.0 keys. So I inserted my own secure_boot_key and tsec_key from my 8.0 prod.key, and it works, I can successfully use reNXpack to lower the firmware requirement of new 9.0 files.
    Hope this info will help others with the same problem.
     
    KnightMars and oleole like this.
  12. oleole

    oleole Member
    Newcomer

    Joined:
    Aug 4, 2006
    Messages:
    41
    Country:
    Thank you it helped me. Update installed, took me a few minutes to find out how to compile the code for MacOS. I was rather surprised you don't have to input a version: you just provide the key file and the nsp and that's it.
     
  13. Advanced User

    Advanced User Advanced Member
    Newcomer

    Joined:
    Jan 20, 2014
    Messages:
    58
    Country:
    Actually, I am sorry to report the pastebin key from September 15 I talked about wasn't 9.0 after all. However, a kind soul pointed me towards a dark place where someone uploaded a tool called "NSC BUILDER v0.91b" that includes the 9.0 keys. Unfortunately the file wasn't formatted correctly and didn't include everything, so I copy/pasted the new/different keys into the file from September 15, and now it really works. And by the way, I don't think that the private secure_boot_key and tsec_key matter at all; I left the key file with the ones it came with and it still works. I have no idea why it was so difficult to get this key file, you'd expect there to be copies in lots of places...
     
  14. regnad

    regnad Button Masher
    Member

    Joined:
    May 19, 2008
    Messages:
    2,242
    Country:
    I found the file you mention on github, but I don't see any 9.0 keys. :(

    Edit: never mind! I didn’t pick up your wink wink.
     
    Last edited: Dec 11, 2019
  15. wii07

    wii07 Advanced Member
    Newcomer

    Joined:
    Sep 9, 2019
    Messages:
    52
    Country:
    Finland
    Anyone got to repack a real 9.1.0 update like the darksiders genesis update or the latest music racer update successfully? I always get a bad nca magic error when the repacking should begin, but im using the 9.1.0 keyfile from yuzu.

    Anyone can give me a hint or can help me? I got no problem repacking stuff up to 9.0.1, only the 9.1.0 ones are making these problems for me repacking.

    Edit: I was missing some keys in my keyfile. For the people with a similar problem: google for master_key_0a and so on.
     
    Last edited: Feb 15, 2020 at 12:17 PM
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - firmwares, reNXpack, Nintendo