RELEASE reNXpack - Repack Nintendo Switch nsps to work on lower firmwares

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by The-4n, Apr 10, 2019.

  1. bakedbeans

    bakedbeans Member

    Newcomer
    2
    Jan 13, 2018
    Algeria
    Maybe, but i can load the base file in Yuzu emulator so i would assume it isn't broken. Unless Yuzu ignores a certain error of course
     
  2. Dutt

    Dutt Advanced Member

    Newcomer
    4
    Jun 15, 2018
    Australia
    I get an error when i press convert..

    reNXpack execution started. Please wait...
    reNXpack v1.16 by The-4n
    Failed to convert G:\blaablaablaa\keys.dat to UTF-16!
     
  3. Sunnyboy

    Sunnyboy GBAtemp Regular

    Member
    4
    Mar 22, 2008
    United States
    Hi,
    just a question
    is it possible to make more files at once?

    — Posts automatically merged - Please don't double post! —

    Hi,
    just a question.
    is it possible to make ACA NEOGEO Collection with 105 games to one nsp
    or is there a max for a nsp?
     
    Last edited by Sunnyboy, May 10, 2019
  4. Sunnyboy

    Sunnyboy GBAtemp Regular

    Member
    4
    Mar 22, 2008
    United States
    the newest games give me this error
    Creating xml metadata renxpack_extracted_nsp\c5cce5371619ffdf261ba3930d439269.cnmt.xml
    unable to create nsp
    anyone has the same problem?
     
  5. KnightMars

    KnightMars Member

    Newcomer
    2
    Mar 22, 2019
    Malaysia
    May I know which nsp game you want to convert?

    — Posts automatically merged - Please don't double post! —

    Are you using the latest keys.txt?
     
  6. Sunnyboy

    Sunnyboy GBAtemp Regular

    Member
    4
    Mar 22, 2008
    United States
    ì have the latest key, and the last i try whas super live of pixel
    it`s whas always working
     
  7. Sunnyboy

    Sunnyboy GBAtemp Regular

    Member
    4
    Mar 22, 2008
    United States
    VERY STRANGE, it`s working, now i put the game in the same directory as reNXpack, i alway`s has the nsp on a other hd and working also good.
    so problem solve
     
  8. TimeDevouncer

    TimeDevouncer GBAtemp Regular

    Member
    5
    Jun 7, 2018
    Spain
    FFVII 1.0.1 update doesn't seems to be working (6.2), right? Or I'm doing something wrong?
     
    Last edited by TimeDevouncer, May 22, 2019
  9. rasqba

    rasqba Member

    Newcomer
    1
    Sep 25, 2015
    Poland
    For me the update installed fine on 6.2 after using this app, but the game crashes after the "Square Enix" screen.
     
    TimeDevouncer likes this.
  10. TWIS

    TWIS Member

    Newcomer
    3
    Mar 8, 2008
    France
    Hi i'm on 6.1ver and i have unknow meta type, i don't understand why, anyone can help ?
     
  11. The-4n
    OP

    The-4n GBAtemp Fan

    Member
    9
    Aug 3, 2018
    United States
    Your keys are not good ones or you are missing some keys
     
  12. geiz123

    geiz123 Newbie

    Newcomer
    1
    Sep 11, 2009
    United States
    Will not work if game master key is higher than your current firmware keys.

    So if your keys if from 6.1.0 and you try to patch Fire Emblem Three Houses (master key=7.0.0-8.0.0), then it will not work. You will get Unknown meta or bad key error.
     
    Last edited by geiz123, Jul 24, 2019
  13. The-4n
    OP

    The-4n GBAtemp Fan

    Member
    9
    Aug 3, 2018
    United States
    You need to have those master keys in your keyfile
     
  14. geiz123

    geiz123 Newbie

    Newcomer
    1
    Sep 11, 2009
    United States
    In order to get those keys I would need to update my switch dump the keys and downgrade.

    Is there a way to those key without updating the switch?
     
  15. The-4n
    OP

    The-4n GBAtemp Fan

    Member
    9
    Aug 3, 2018
    United States
    Keys are not unique to each console, They are shared between all consoles
     
  16. geiz123

    geiz123 Newbie

    Newcomer
    1
    Sep 11, 2009
    United States
    Ah, no wonder it is called the master key...
     
  17. bakedbeans

    bakedbeans Member

    Newcomer
    2
    Jan 13, 2018
    Algeria
    The wiki is rather empty.
    Don't we have tool somewhere that you can feed your dumped file into and prints the required and minimum required firmware version out so we can fill in some data?
     
  18. The-4n
    OP

    The-4n GBAtemp Fan

    Member
    9
    Aug 3, 2018
    United States
    No.
    There's no tool for that.
    I nearly have no time to even update my own tools.
    Request a wiki account from cyan if you want to update it.
     
  19. AdmiralSpeedy

    AdmiralSpeedy GBAtemp Regular

    Member
    1
    Apr 4, 2016
    Canada
    I used this tonight, mainly to remove fake tickets from some NSPs I have and I noticed that on few DLCs and updates, the repacked file is significantly smaller (by several hundred MB) but still seems to work fine. Anyone know what causes this? Usually the repack is only 2-3 KB smaller because the ticket gets removed.

    EDIT: I decided to test this a bit more and in Data Management I checked the size of an update that got smaller when repacked and it was 947MB. I then used Goldleaf to remove the update, confirmed it was gone in Data Management and then reinstalled the non-repacked version, which is 1.06GB, and it appears as 947MB in Data Management as well. I assume this means there is some kind of useless dummy data/padding in the original NSP that is ignored when it's repacked?
     
    Last edited by AdmiralSpeedy, Sep 2, 2019
  20. Zukov

    Zukov Dinosaur

    Member
    4
    Oct 2, 2016
    Chile
    Does it work on Astral chain?
     
Quick Reply
Draft saved Draft deleted
Loading...