Removing R4 or 3in1 between plays causes GBA saves to erase?

Discussion in 'R4 DS' started by Sora de Eclaune, Mar 23, 2014.

  1. Sora de Eclaune
    OP

    Sora de Eclaune Baby squirrel, you's a sexy motherfucker.

    Member
    2,801
    625
    Feb 15, 2011
    United States
    123 Fake Street
    Just as a general note, I have two friends having the same problem. I learned of one friend's problem today, and when I asked a knowledgeable Skype friend about this just now, they revealed to me that they have the same problem.

    Okay, so onto the problem!

    My friends each have a DS Lite, an R4 (the newer, non-spring loading kind), and a DS Lite-sized EZ-Flash 3in1. If they remove their R4 or 3in1 between plays, any GBA games that aren't saved to the NOR get their saves erased next time they try to launch the ROMs.

    Now, let me clarify quickly so you don't think they removed the R4 or 3in1 while the game was saving. They saved their game, the game said "The game is saved.", and they turned their system off. THEN they removed the R4, put the R4 back in, turned the system on, and relaunched the game. The game was then treated as a fresh game with no save files. The same result happens if the 3in1 is removed like this.

    I have one friend's DS Lite at this exact moment, and have tested this without fail. I believe it is the removal of the R4 or 3in1 that triggers this. If the R4 and 3in1 are not removed, the saves stay intact. If a different R4 is used with that 3in1, all the GBA saves on that R4 will be erased, too (how do I know? I accidentally tried my R4 with the 3in1 by mistake; note: my 3in1 does not have this issue). If a different 3in1 is used with that R4, the saves stay intact. So, I believe it might be an issue with the 3in1.

    HOWEVER...I do not believe it is an issue with the battery, as any games saved to the NOR keep their saves intact. It is only the NOR game that does not get its save erased.

    Changing the save files filetype does not change the outcome unless they are changed to something that isn't recognized as a save file. Changing a save file's name does save the save, but then there's no way to get the save's filename the same as the ROM's again without removing the R4, which will effectively cause the save to be erased again. I can backup a newly-done save with a save file saved on it just fine, and the save works exactly as it should in VBA, but when I get the save emptied by launching the game in the R4 and then go to replace the empty save with the backup save and load the ROM, the backup save is empty. If I back up that "empty" save...it's treated as an empty save by VBA, too.

    It's kind of curious I was only informed of this issue today by the one friend, when it's been going on for several months now, but now it's apparently my problem. Not that I wouldn't make it my problem now, considering that if I hadn't been told and let them use my R4, I would be trying to kill them because it would have looked like they intentionally replaced all of my GBA save files with empty saves...

    So...there you go. There's the problem. Who knows how I can fix it? My only friend who could have helped has gotten the problem too, and they were actually going to ask me how to fix it, so I have technically have two systems I must try and fix.